Initial import of mysql51-embedded from wip, packaged by myself

and updated by mwdavies and myself. sketch will make proper
mysql51-packages when he finds some round tuits.

MySQL is a SQL (Structured Query Language) database server.  SQL is the
most popular database language in the world.  MySQL is a client-server
implementation that consists of a server daemon `mysqld' and many
different client programs/libraries.

The main goals of MySQL are speed and robustness.

The base upon which MySQL is built is a set of routines that have been
used in a highly demanding production environment for many years.  While
MySQL is still in development it already offers a rich and highly useful
function set.

The official way to pronounce 'MySQL' is 'My Ess Que Ell' (Not MY-SEQUEL).

This package contains the MySQL embedded server programs.
This commit is contained in:
wiz 2010-02-15 17:01:12 +00:00
parent 12edfbbc3c
commit 0fadf3ebcf
7 changed files with 203 additions and 0 deletions

View file

@ -0,0 +1,15 @@
MySQL is a SQL (Structured Query Language) database server. SQL is the
most popular database language in the world. MySQL is a client-server
implementation that consists of a server daemon `mysqld' and many
different client programs/libraries.
The main goals of MySQL are speed and robustness.
The base upon which MySQL is built is a set of routines that have been
used in a highly demanding production environment for many years. While
MySQL is still in development it already offers a rich and highly useful
function set.
The official way to pronounce 'MySQL' is 'My Ess Que Ell' (Not MY-SEQUEL).
This package contains the MySQL embedded server programs.

View file

@ -0,0 +1,55 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/02/15 17:01:12 wiz Exp $
DISTNAME= mysql-5.1.43
PKGNAME= ${DISTNAME:S/-/-embedded-/}
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL:=MySQL-5.1/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.mysql.com/
COMMENT= MySQL 5, a free SQL database (embedded server)
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
GNU_CONFIGURE_PREFIX= ${PREFIX}/mysqld
USE_LANGUAGES= c c++
CONFIGURE_ARGS+= --with-embedded-server
CONFIGURE_ARGS+= --with-mysqld-ldflags=-all-static
CONFIGURE_ARGS+= --with-pic
CONFIGURE_ARGS+= --without-bench
CONFIGURE_ARGS+= --without-docs
CONFIGURE_ARGS+= --without-extra-tools
CONFIGURE_ARGS+= --without-libedit
CONFIGURE_ARGS+= --without-libwrap
CONFIGURE_ARGS+= --without-man
CONFIGURE_ARGS+= --without-server
CONFIGURE_ARGS+= --without-ssl
# the usual == problem
CHECK_PORTABILITY_SKIP= configure BUILD/compile-pentium-gcov
CFLAGS+= -fPIC -DPIC
CXXFLAGS+= -fPIC -DPIC
INSTALLATION_DIRS= mysqld/lib/mysql
# install headers and client library
INSTALL_DIRS= include libmysql sql
# We only need readline to placate the configure script. None of the
# binaries are actually linked against -lreadline, so make this only
# a build-time dependency.
#
BUILDLINK_DEPMETHOD.readline= build
# NetBSD version is not recognized
USE_BUILTIN.readline= no
.include "../../devel/readline/buildlink3.mk"
post-install:
${INSTALL_LIB} ${WRKSRC}/libmysqld/libmysqld.a \
${DESTDIR}${PREFIX}/mysqld/lib/mysql
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,84 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2010/02/15 17:01:12 wiz Exp $
mysqld/bin/mysql_tzinfo_to_sql
mysqld/include/mysql/decimal.h
mysqld/include/mysql/errmsg.h
mysqld/include/mysql/keycache.h
mysqld/include/mysql/m_ctype.h
mysqld/include/mysql/m_string.h
mysqld/include/mysql/my_alloc.h
mysqld/include/mysql/my_attribute.h
mysqld/include/mysql/my_config.h
mysqld/include/mysql/my_dbug.h
mysqld/include/mysql/my_dir.h
mysqld/include/mysql/my_getopt.h
mysqld/include/mysql/my_global.h
mysqld/include/mysql/my_list.h
mysqld/include/mysql/my_net.h
mysqld/include/mysql/my_no_pthread.h
mysqld/include/mysql/my_pthread.h
mysqld/include/mysql/my_sys.h
mysqld/include/mysql/my_xml.h
mysqld/include/mysql/mysql.h
mysqld/include/mysql/mysql_com.h
mysqld/include/mysql/mysql_embed.h
mysqld/include/mysql/mysql_time.h
mysqld/include/mysql/mysql_version.h
mysqld/include/mysql/plugin.h
mysqld/include/mysql/sql_common.h
mysqld/include/mysql/sslopt-case.h
mysqld/include/mysql/sslopt-longopts.h
mysqld/include/mysql/sslopt-vars.h
mysqld/include/mysql/typelib.h
mysqld/lib/mysql/libmysqlclient.la
mysqld/lib/mysql/libmysqld.a
mysqld/libexec/mysqld
mysqld/share/mysql/charsets/Index.xml
mysqld/share/mysql/charsets/README
mysqld/share/mysql/charsets/armscii8.xml
mysqld/share/mysql/charsets/ascii.xml
mysqld/share/mysql/charsets/cp1250.xml
mysqld/share/mysql/charsets/cp1251.xml
mysqld/share/mysql/charsets/cp1256.xml
mysqld/share/mysql/charsets/cp1257.xml
mysqld/share/mysql/charsets/cp850.xml
mysqld/share/mysql/charsets/cp852.xml
mysqld/share/mysql/charsets/cp866.xml
mysqld/share/mysql/charsets/dec8.xml
mysqld/share/mysql/charsets/geostd8.xml
mysqld/share/mysql/charsets/greek.xml
mysqld/share/mysql/charsets/hebrew.xml
mysqld/share/mysql/charsets/hp8.xml
mysqld/share/mysql/charsets/keybcs2.xml
mysqld/share/mysql/charsets/koi8r.xml
mysqld/share/mysql/charsets/koi8u.xml
mysqld/share/mysql/charsets/latin1.xml
mysqld/share/mysql/charsets/latin2.xml
mysqld/share/mysql/charsets/latin5.xml
mysqld/share/mysql/charsets/latin7.xml
mysqld/share/mysql/charsets/macce.xml
mysqld/share/mysql/charsets/macroman.xml
mysqld/share/mysql/charsets/swe7.xml
mysqld/share/mysql/czech/errmsg.sys
mysqld/share/mysql/danish/errmsg.sys
mysqld/share/mysql/dutch/errmsg.sys
mysqld/share/mysql/english/errmsg.sys
mysqld/share/mysql/errmsg.txt
mysqld/share/mysql/estonian/errmsg.sys
mysqld/share/mysql/french/errmsg.sys
mysqld/share/mysql/german/errmsg.sys
mysqld/share/mysql/greek/errmsg.sys
mysqld/share/mysql/hungarian/errmsg.sys
mysqld/share/mysql/italian/errmsg.sys
mysqld/share/mysql/japanese/errmsg.sys
mysqld/share/mysql/korean/errmsg.sys
mysqld/share/mysql/norwegian-ny/errmsg.sys
mysqld/share/mysql/norwegian/errmsg.sys
mysqld/share/mysql/polish/errmsg.sys
mysqld/share/mysql/portuguese/errmsg.sys
mysqld/share/mysql/romanian/errmsg.sys
mysqld/share/mysql/russian/errmsg.sys
mysqld/share/mysql/serbian/errmsg.sys
mysqld/share/mysql/slovak/errmsg.sys
mysqld/share/mysql/spanish/errmsg.sys
mysqld/share/mysql/swedish/errmsg.sys
mysqld/share/mysql/ukrainian/errmsg.sys

View file

@ -0,0 +1,16 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2010/02/15 17:01:12 wiz Exp $
BUILDLINK_TREE+= mysql-embedded
.if !defined(MYSQL_EMBEDDED_BUILDLINK3_MK)
MYSQL_EMBEDDED_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.mysql-embedded+= mysql-embedded>=5.1.36nb3
BUILDLINK_PKGSRCDIR.mysql-embedded?= ../../databases/mysql51-embedded
MYSQLD_PATH= ${BUILDLINK_PREFIX.mysql-embedded}/mysqld/lib/mysql
BUILDLINK_PASSTHRU_DIRS+= ${MYSQLD_PATH}
BUILDLINK_PASSTHRU_RPATHDIRS+= ${MYSQLD_PATH}
.endif # MYSQL_EMBEDDED_BUILDLINK3_MK
BUILDLINK_TREE+= -mysql-embedded

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2010/02/15 17:01:12 wiz Exp $
SHA1 (mysql-5.1.43.tar.gz) = fff98e59f17487d646998662409bc894a422b7e9
RMD160 (mysql-5.1.43.tar.gz) = 51aa017edc165f13f2cb696ee210505b8f2a21ee
Size (mysql-5.1.43.tar.gz) = 22319586 bytes
SHA1 (patch-aa) = 8a45d6dd9dcacd686b024e0e554f0487410cbaaa
SHA1 (patch-ab) = 36ad9671911a8af11a6f6f2477d3d53980a9a76c

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/02/15 17:01:12 wiz Exp $
--- include/my_handler.h.orig 2009-06-16 12:23:31.000000000 +0000
+++ include/my_handler.h
@@ -39,7 +39,7 @@ extern "C" {
But beware the dependency of MI_MAX_POSSIBLE_KEY_BUFF and HA_MAX_KEY_LENGTH.
*/
-#define HA_MAX_KEY_LENGTH 1000 /* Max length in bytes */
+#define HA_MAX_KEY_LENGTH 4000 /* Max length in bytes */
#define HA_MAX_KEY_SEG 16 /* Max segments for key */
#define HA_MAX_POSSIBLE_KEY_BUFF (HA_MAX_KEY_LENGTH + 24+ 6+6)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2010/02/15 17:01:12 wiz Exp $
--- include/myisam.h.orig 2009-06-16 12:23:32.000000000 +0000
+++ include/myisam.h
@@ -48,7 +48,7 @@ extern "C" {
The following defines can be increased if necessary.
But beware the dependency of MI_MAX_POSSIBLE_KEY_BUFF and MI_MAX_KEY_LENGTH.
*/
-#define MI_MAX_KEY_LENGTH 1000 /* Max length in bytes */
+#define MI_MAX_KEY_LENGTH 4000 /* Max length in bytes */
#define MI_MAX_KEY_SEG 16 /* Max segments for key */
#define MI_MAX_KEY_BUFF (MI_MAX_KEY_LENGTH+MI_MAX_KEY_SEG*6+8+8)