Fix YYDEBUG usage.

This commit is contained in:
joerg 2020-02-18 16:47:20 +00:00
parent cdc678fd81
commit 0fd0d3bd7a
2 changed files with 29 additions and 3 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.6 2015/11/07 23:47:52 dholland Exp $
$NetBSD: distinfo,v 1.7 2020/02/18 16:47:20 joerg Exp $
SHA1 (tn3270-0.20100116.tar.gz) = b550f2c240aa3b185b935c11ed36e75c8c574503
RMD160 (tn3270-0.20100116.tar.gz) = 59ca2fcaa8f44258eb9cb0069cf17e560754f2c9
SHA512 (tn3270-0.20100116.tar.gz) = 92b89b302b0827b6995c0b04f4642585f93021c5a5e7d30f414ba3fd9314ed019ba35e9a155f0cf7d9c1be7bad37dda44622f9245409a024113358a90005e9b1
Size (tn3270-0.20100116.tar.gz) = 156352 bytes
SHA1 (patch-aa) = dfec3563624578dc775f4ec7d0ce813eb9431dce
SHA1 (patch-tools_mkmake_mkmake.y) = 8e9dab56b989f1dc3cfc7a17daf6cf95d2dda886
SHA1 (patch-tools_mkmake_mkmake.y) = f2d2cb67fae365f91707f1b11a47f24a04411f85

View file

@ -1,7 +1,9 @@
$NetBSD: patch-tools_mkmake_mkmake.y,v 1.2 2015/11/07 23:47:52 dholland Exp $
$NetBSD: patch-tools_mkmake_mkmake.y,v 1.3 2020/02/18 16:47:20 joerg Exp $
- use standard headers
- avoid symbol name collision on OpenBSD where clock() from time.h leaks in
- YYDEBUG is always defined in newer byacc versions, so check for non-0
value instead
--- tools/mkmake/mkmake.y.orig 2010-01-17 18:00:07.000000000 +0000
+++ tools/mkmake/mkmake.y
@ -24,3 +26,27 @@ $NetBSD: patch-tools_mkmake_mkmake.y,v 1.2 2015/11/07 23:47:52 dholland Exp $
/* mkmake.y */
void yyerror(char *);
void assign(same_t *, same_t *);
@@ -957,7 +962,7 @@ yylex()
return token_type(buffer); \
}
#define save(c) { last_char = c; last_saved = 1; }
-#if defined(YYDEBUG)
+#if YYDEBUG - 0
#define Return(y,c) if (yydebug) { \
printf("[%d]", c); \
fflush(stdout); \
@@ -1096,12 +1101,14 @@ do_dump()
string_t *string;
same_t *same, *same2;
+#if YYDEBUG - 0
if (yydebug > 1) {
printf("strings...\n");
for (string = strings; string; string = string->next) {
printf("\t%s\n", string->string);
}
}
+#endif
printf("# variables...\n");
for (visit(variables, same); !visited(same); visit_next(same)) {