Update to 1.57; addresses PR 23884. Changes:
- added cloneNode to XML::LibXML::Document - include Schema/RelaxNG code only with libxml2 >= 2.6.0 (to support old libxml2) - applied patch to example/cb_example.pl (bug 4262) - fixed insertBefore/insertAfter on empty elements (bug 3691) - more DOM conformant XML::LibXML->createDocument API (by Robin Berjon) - fixed encoding problems with API calls in document encoding - improved support for importing DTD subsets - fixed DTD validation error reporting problems with libxml2-2.6.x - fixed compilation problems with libxml2-2.6.x - fixed XML::LibXML::Number to support negative numbers - added XML Schema validation interface (XML::LibXML::Schema) - added XML RelaxNG validation interface (XML::LibXML::RelaxNG) - Michael K. Edwards' patch applied with some amendments from Petr Pajas: * add debian build files (I added SKIP_SAX_INSTALL flag for Makefile.PL and changed the patch so that it doesn't disable sax parser registration completely by default, and rather made debian build use this flag) * general cleanup (use SV_nolen, etc.) * SAX parsers cleanup * general error reporting code cleanup/rewrite, try preventing possible memory leaks * recover(1) now triggers warnings (disable with $SIG{__WARN__}=sub {}) * slighlty more strict parse_string behavior (now same as when parsing fh, etc): e.g. parse_string("<foo:bar>"), i.e prefix without NS declaration, raises error unless recover(1) is used * documentation fixes/updates * slightly updated test set to reflect the new slightly more strict parsing. - fixed default c14n XPath to include attributes and namespaces (Petr Pajas) - make libxml2's xmlXPathOrderDocElems available through a new $doc->indexElements method - added version information of libxml2 - Les Richardson's documentation patch applied.
This commit is contained in:
parent
5fa1eeecb5
commit
0fd92e94d8
3 changed files with 5 additions and 31 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.12 2004/03/26 02:27:55 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2004/03/29 23:50:49 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= XML-LibXML-1.56
|
||||
DISTNAME= XML-LibXML-1.57
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 3
|
||||
SVR4_PKGNAME= p5xlx
|
||||
CATEGORIES= textproc perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=XML/}
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.3 2004/01/15 09:11:58 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.4 2004/03/29 23:50:49 wiz Exp $
|
||||
|
||||
SHA1 (XML-LibXML-1.56.tar.gz) = c0f76dfc444cd792a59bdcc4f0fba0e8dfa6d373
|
||||
Size (XML-LibXML-1.56.tar.gz) = 165047 bytes
|
||||
SHA1 (patch-aa) = c54db48ed0ec3dba5b1ab8ef6678f3f78b7f586a
|
||||
SHA1 (XML-LibXML-1.57.tar.gz) = e0219748e8fe49c03aec89eebed6a6f2c19c1a1b
|
||||
Size (XML-LibXML-1.57.tar.gz) = 169306 bytes
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2004/01/15 09:11:58 xtraeme Exp $
|
||||
|
||||
--- LibXML.xs.orig 2004-01-15 10:09:53.000000000 +0100
|
||||
+++ LibXML.xs 2004-01-15 10:10:17.000000000 +0100
|
||||
@@ -70,13 +70,13 @@
|
||||
extern int xmlSubstituteEntitiesDefaultVal;
|
||||
#define xmlSubstituteEntitiesDefaultValue xmlSubstituteEntitiesDefaultVal
|
||||
#else
|
||||
-LIBXML_DLL_IMPORT extern int xmlDoValidityCheckingDefaultValue;
|
||||
-LIBXML_DLL_IMPORT extern int xmlSubstituteEntitiesDefaultValue;
|
||||
+LIBXML_DLL_IMPORT int xmlDoValidityCheckingDefaultValue;
|
||||
+LIBXML_DLL_IMPORT int xmlSubstituteEntitiesDefaultValue;
|
||||
#endif
|
||||
-LIBXML_DLL_IMPORT extern int xmlGetWarningsDefaultValue;
|
||||
-LIBXML_DLL_IMPORT extern int xmlKeepBlanksDefaultValue;
|
||||
-LIBXML_DLL_IMPORT extern int xmlLoadExtDtdDefaultValue;
|
||||
-LIBXML_DLL_IMPORT extern int xmlPedanticParserDefaultValue;
|
||||
+LIBXML_DLL_IMPORT int xmlGetWarningsDefaultValue;
|
||||
+LIBXML_DLL_IMPORT int xmlKeepBlanksDefaultValue;
|
||||
+LIBXML_DLL_IMPORT int xmlLoadExtDtdDefaultValue;
|
||||
+LIBXML_DLL_IMPORT int xmlPedanticParserDefaultValue;
|
||||
|
||||
#define TEST_PERL_FLAG(flag) \
|
||||
SvTRUE(perl_get_sv(flag, FALSE)) ? 1 : 0
|
Loading…
Reference in a new issue