Update to 0.10.2:

This is GStreamer Good Plug-ins 0.10.2, "Papa was a rolling stone".

Changes since 0.10.1:
      * New libcdio based CDDA reading element
      * APE tag reader ported
      * ID3 tag reading fixes
      * Sun Audio Sink fixes
      * GOOM and gconf element fixes
      * lots of bug and leak fixes

Bugs fixed since 0.10.1:
      * 328336 : silence warings which make dvdec / dvdemux unusable
      * 315557 : Internal event problem with MP3s from vgmix.com
      * 323327 : [cdio] port cddasrc to 0.10
      * 325148 : Bugs in G711 RTP packetization logic
      * 325649 : apetag plugin needs porting to 0.10
      * 326446 : check that all elements in -good pass queries they can't ...
      * 326602 : id3demux is not compiling without ZLIB
      * 326683 : build problem caused by AS_LIBTOOL_TAGS([CXX])
      * 326736 : gconf(audio|video)sink response to key changes
      * 326864 : [wavparse] time to bytes format conversion broken
      * 327009 : [esdsink] won't compile with includes in non-standard prefix
      * 327765 : [sunaudio] fixes for mixer and stuttering mp3 playback
      * 327825 : [matroskamux]  Matroska muxer deadlock
      * 327871 : [videobox] crash when cropping
      * 328241 : id3demux emits NULL date for year tags
      * 328264 : Fix build with gcc 2.95
      * 328531 : [matroskamux] doesn't send newsegment event, critical war...
      * 329181 : totem crash when using goom effect
      * 329810 : Fails to read ID3 tag
      * 330005 : Please use the autodetect sinks by default
      * 317658 : [cdio] support for cd-text and cd-g
This commit is contained in:
wiz 2006-02-13 19:22:33 +00:00
parent bd6bc84a3d
commit 0fec9be09a
8 changed files with 10 additions and 97 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.2 2006/02/05 23:10:15 joerg Exp $
# $NetBSD: Makefile,v 1.3 2006/02/13 19:22:33 wiz Exp $
#
.include "Makefile.common"
PKGREVISION= 1
COMMENT+= good plugins
CONFIGURE_ARGS+= --enable-gconf

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.2 2006/01/25 19:53:16 wiz Exp $
# $NetBSD: Makefile.common,v 1.3 2006/02/13 19:22:33 wiz Exp $
#
GST_PLUGINS0.10_TYPE= good
@ -7,6 +7,7 @@ GST_PLUGINS0.10_TYPE= good
.for driver in aalib \
aalibtest \
cairo \
cdio \
dv1394 \
esd \
esdtest \
@ -27,7 +28,7 @@ GST_PLUGINS0.10_TYPE= good
CONFIGURE_ARGS+= --disable-${driver}
.endfor
DISTNAME= gst-plugins-${GST_PLUGINS0.10_TYPE}-0.10.1
DISTNAME= gst-plugins-${GST_PLUGINS0.10_TYPE}-0.10.2
.include "../../multimedia/gst-plugins0.10-base/plugins.mk"

View file

@ -1,7 +1,8 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/01/18 15:42:27 jmmv Exp $
@comment $NetBSD: PLIST,v 1.2 2006/02/13 19:22:33 wiz Exp $
lib/gstreamer-0.10/libgstalaw.la
lib/gstreamer-0.10/libgstalpha.la
lib/gstreamer-0.10/libgstalphacolor.la
lib/gstreamer-0.10/libgstapetag.la
lib/gstreamer-0.10/libgstauparse.la
lib/gstreamer-0.10/libgstautodetect.la
lib/gstreamer-0.10/libgstavi.la

View file

@ -1,9 +1,5 @@
$NetBSD: distinfo,v 1.2 2006/01/30 21:20:42 rillig Exp $
$NetBSD: distinfo,v 1.3 2006/02/13 19:22:33 wiz Exp $
SHA1 (gst-plugins-good-0.10.1.tar.bz2) = 2329914f69225fd91ec57839b68e7fc14177b00d
RMD160 (gst-plugins-good-0.10.1.tar.bz2) = 117858f7c9d7e223d80f180ed53b8f0d6cf9c0d4
Size (gst-plugins-good-0.10.1.tar.bz2) = 928881 bytes
SHA1 (patch-aa) = 7b7c7cf0b7fa181c7181ee98728994328ffe0b9a
SHA1 (patch-ab) = e776c564650a9f4944a5a8f5e569917d4306d931
SHA1 (patch-ac) = 8dbcc89f4755009bf40eab293fe2422458f80c79
SHA1 (patch-ad) = 558c51bf59be1239a27af665e76bc0e4ea8a6f24
SHA1 (gst-plugins-good-0.10.2.tar.bz2) = 2a4116d8bfb815b3fff117df3414b977e821dcec
RMD160 (gst-plugins-good-0.10.2.tar.bz2) = 63103286d064dc47a464c365604579c9a9ecfdab
Size (gst-plugins-good-0.10.2.tar.bz2) = 963026 bytes

View file

@ -1,19 +0,0 @@
$NetBSD: patch-aa,v 1.1 2006/01/30 21:20:42 rillig Exp $
Keywords: c90
--- gst/avi/gstavidemux.c.orig 2006-01-10 15:01:55.000000000 +0100
+++ gst/avi/gstavidemux.c 2006-01-30 21:33:28.000000000 +0100
@@ -2219,10 +2219,11 @@ swap_line (guint8 * d1, guint8 * d2, gui
static GstBuffer *
gst_avi_demux_invert (avi_stream_context * stream, GstBuffer * buf)
{
- buf = gst_buffer_make_writable (buf);
gint y, h = stream->strf.vids->height, w = stream->strf.vids->width;
guint8 *tmp = NULL;
+ buf = gst_buffer_make_writable (buf);
+
if (GST_BUFFER_SIZE (buf) < (w * h)) {
GST_WARNING ("Buffer is smaller than reported Width x Height");
return buf;

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ab,v 1.1 2006/01/30 21:20:42 rillig Exp $
Keywords: c90
--- gst/rtp/gstrtpmp4vdepay.c.orig 2006-01-10 15:01:57.000000000 +0100
+++ gst/rtp/gstrtpmp4vdepay.c 2006-01-30 21:34:26.000000000 +0100
@@ -132,13 +132,12 @@ gst_rtp_mp4v_depay_setcaps (GstBaseRTPDe
GstRtpMP4VDepay *rtpmp4vdepay;
GstCaps *srccaps;
const gchar *str;
+ gint clock_rate = 90000; // default
rtpmp4vdepay = GST_RTP_MP4V_DEPAY (depayload);
structure = gst_caps_get_structure (caps, 0);
- gint clock_rate = 90000; // default
-
if (gst_structure_has_field (structure, "clock-rate")) {
gst_structure_get_int (structure, "clock-rate", &clock_rate);
}

View file

@ -1,25 +0,0 @@
$NetBSD: patch-ac,v 1.1 2006/01/30 21:20:42 rillig Exp $
Keywords: c90
--- gst/udp/gstdynudpsink.c.orig 2006-01-10 15:01:57.000000000 +0100
+++ gst/udp/gstdynudpsink.c 2006-01-30 21:35:15.000000000 +0100
@@ -187,6 +187,8 @@ gst_dynudpsink_render (GstBaseSink * bsi
guint8 *data;
GstNetBuffer *netbuf;
struct sockaddr_in theiraddr;
+ guint16 destport;
+ guint32 destaddr;
memset (&theiraddr, 0, sizeof (theiraddr));
@@ -203,9 +205,6 @@ gst_dynudpsink_render (GstBaseSink * bsi
data = GST_BUFFER_DATA (netbuf);
GST_DEBUG ("about to send %d bytes", size);
- guint16 destport;
- guint32 destaddr;
-
// let's get the address from the netbuffer
gst_netaddress_get_ip4_address (&netbuf->to, &destaddr, &destport);

View file

@ -1,19 +0,0 @@
$NetBSD: patch-ad,v 1.1 2006/01/30 21:20:42 rillig Exp $
Keywords: c90
--- gst/udp/gstmultiudpsink.c.orig 2006-01-10 15:01:57.000000000 +0100
+++ gst/udp/gstmultiudpsink.c 2006-01-30 21:34:54.000000000 +0100
@@ -462,10 +462,10 @@ gst_multiudpsink_get_stats (GstMultiUDPS
find = g_list_find_custom (sink->clients, &udpclient,
(GCompareFunc) client_compare);
if (find) {
- client = (GstUDPClient *) find->data;
-
GValue value = { 0 };
+ client = (GstUDPClient *) find->data;
+
/* Result is a value array of (bytes_sent, packets_sent,
* connect_time, disconnect_time), all as uint64 */
result = g_value_array_new (4);