Fixes a build failure when the letter 'j' appears in MAKEFLAGS.

This commit is contained in:
jmcneill 2019-06-22 12:52:13 +00:00
parent 047d77d669
commit 0ffaa44100
2 changed files with 20 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2019/03/26 11:48:14 adam Exp $
$NetBSD: distinfo,v 1.7 2019/06/22 12:52:13 jmcneill Exp $
SHA1 (tevent-0.10.0.tar.gz) = 28a19f00d270f4f6009b4ae29eee3df0de6270b6
RMD160 (tevent-0.10.0.tar.gz) = 34aecf5b177993cfb26d1d5dd319f58c9d797fa7
@ -6,4 +6,5 @@ SHA512 (tevent-0.10.0.tar.gz) = 1b55560f2355d98779087046e72528ef30cfbcaf86fc4ad4
Size (tevent-0.10.0.tar.gz) = 794845 bytes
SHA1 (patch-buildtools_wafsamba_samba__conftests.py) = 50ff76f5b085f770751ca8bb93c8544cfdcd40d9
SHA1 (patch-buildtools_wafsamba_samba__install.py) = d801340617da325e3bb70a90350e45cc8e383c2d
SHA1 (patch-buildtools_wafsamba_samba__utils.py) = 0a587421870c1974175fadbb02dde215f35938f2
SHA1 (patch-wscript) = 34f464296ca3e8eb9b50e1f85f31c38c4c8fdf93

View file

@ -0,0 +1,18 @@
$NetBSD: patch-buildtools_wafsamba_samba__utils.py,v 1.1 2019/06/22 12:52:13 jmcneill Exp $
Fixes a build failure when the letter 'j' appears in MAKEFLAGS.
--- buildtools/wafsamba/samba_utils.py.orig 2019-03-21 10:12:32.000000000 +0000
+++ buildtools/wafsamba/samba_utils.py
@@ -519,10 +519,7 @@ def CHECK_MAKEFLAGS(options):
setattr(options, opt[0:loc], opt[loc+1:])
elif opt[0] != '-':
for v in opt:
- if re.search(r'j[0-9]*$', v):
- jobs_set = True
- jobs = opt.strip('j')
- elif v == 'k':
+ if v == 'k':
options.keep = True
elif re.search(r'-j[0-9]*$', opt):
jobs_set = True