After bothering to set GNOME_CONFIG and ORBIT_CONFIG to the paths to the

respective pkgconfig-style scripts, we should actually use them instead of
directly invoking "gnome-config" or "orbit-config".  This will allow us to
properly buildlinkify this package.
This commit is contained in:
jlam 2002-04-09 20:44:24 +00:00
parent 7d0a32cc45
commit 1047d01f95
2 changed files with 60 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.7 2002/03/24 19:59:37 rh Exp $
$NetBSD: distinfo,v 1.8 2002/04/09 20:44:24 jlam Exp $
SHA1 (gnome-vfs-1.0.3.tar.gz) = 51b4ca77591ee83b35d3987f0f26740623c1fa0a
Size (gnome-vfs-1.0.3.tar.gz) = 1211129 bytes
@ -8,4 +8,4 @@ SHA1 (patch-ac) = 4da6d9b46d059710dcd8248dd9d23cb79e5253e1
SHA1 (patch-ad) = cf959c7d8eb70dba844ea01e887e7487111d9cbd
SHA1 (patch-ae) = a0906ba19a6953aca3b173f03fb1b2d9bf742a09
SHA1 (patch-af) = c76c64801b643828f6cb8751131447335d39c28e
SHA1 (patch-ag) = 55361667a39f4a6b7afbf23b7daa06345ec93418
SHA1 (patch-ag) = 7862d16ca47133e4d0c03391ba5f79ec730d14a1

View file

@ -1,7 +1,63 @@
$NetBSD: patch-ag,v 1.4 2002/03/24 19:59:39 rh Exp $
$NetBSD: patch-ag,v 1.5 2002/04/09 20:44:25 jlam Exp $
--- configure.orig Fri Oct 12 18:35:44 2001
--- configure.orig Fri Oct 12 04:35:44 2001
+++ configure
@@ -5591,8 +5591,8 @@
fi
if test x$gnome_cv_orbit_found = xyes; then
- ORBIT_CFLAGS=`orbit-config --cflags client server`
- ORBIT_LIBS=`orbit-config --use-service=name --libs client server`
+ ORBIT_CFLAGS=`$ORBIT_CONFIG --cflags client server`
+ ORBIT_LIBS=`$ORBIT_CONFIG --use-service=name --libs client server`
else
@@ -5609,8 +5609,8 @@
gnome_cv_gnorba_found=no
if test x$gnome_cv_orbit_found = xyes; then
- GNORBA_CFLAGS="`gnome-config --cflags gnorba gnomeui`"
- GNORBA_LIBS="`gnome-config --libs gnorba gnomeui`"
+ GNORBA_CFLAGS="`$GNOME_CONFIG --cflags gnorba gnomeui`"
+ GNORBA_LIBS="`$GNOME_CONFIG --libs gnorba gnomeui`"
if test -n "$GNORBA_LIBS"; then
gnome_cv_gnorba_found=yes
fi
@@ -5630,8 +5630,8 @@
fi
if test x$gnome_cv_orbit_found = xyes; then
- GNORBA_CFLAGS="`gnome-config --cflags gnorba gnomeui`"
- GNORBA_LIBS="`gnome-config --libs gnorba gnomeui`"
+ GNORBA_CFLAGS="`$GNOME_CONFIG --cflags gnorba gnomeui`"
+ GNORBA_LIBS="`$GNOME_CONFIG --libs gnorba gnomeui`"
else
@@ -5709,14 +5709,14 @@
fi
-VFS_GNOME_CFLAGS="`gnome-config --cflags gnome`"
-VFS_GNOMEUI_CFLAGS="`gnome-config --cflags gnome gnomeui`"
-VFS_GNOMEGNORBA_CFLAGS="`gnome-config --cflags gnome gnomeui gnorba`"
-VFS_CAPPLET_CFLAGS="`gnome-config --cflags gnome gnomeui capplet`"
-VFS_GNOME_LIBS="`gnome-config --libs gnome`"
-VFS_GNOMEUI_LIBS="`gnome-config --libs gnome gnomeui`"
-VFS_GNOMEGNORBA_LIBS="`gnome-config --libs gnome gnomeui gnorba`"
-VFS_CAPPLET_LIBS="`gnome-config --libs gnome gnomeui capplet`"
+VFS_GNOME_CFLAGS="`$GNOME_CONFIG --cflags gnome`"
+VFS_GNOMEUI_CFLAGS="`$GNOME_CONFIG --cflags gnome gnomeui`"
+VFS_GNOMEGNORBA_CFLAGS="`$GNOME_CONFIG --cflags gnome gnomeui gnorba`"
+VFS_CAPPLET_CFLAGS="`$GNOME_CONFIG --cflags gnome gnomeui capplet`"
+VFS_GNOME_LIBS="`$GNOME_CONFIG --libs gnome`"
+VFS_GNOMEUI_LIBS="`$GNOME_CONFIG --libs gnome gnomeui`"
+VFS_GNOMEGNORBA_LIBS="`$GNOME_CONFIG --libs gnome gnomeui gnorba`"
+VFS_CAPPLET_LIBS="`$GNOME_CONFIG --libs gnome gnomeui capplet`"
VFS_GLIB_CONFIG="glib-config"
@@ -10210,7 +10210,6 @@
data/Makefile
data/mime/Makefile