Fix dep on MD5 by substituting Digest::MD5 and appropriate changes.
Part of PR/14127 by Sen Nagata.
This commit is contained in:
parent
1ef61a1795
commit
10569aa018
4 changed files with 42 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2001/02/17 17:49:58 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2001/10/02 11:52:53 mjl Exp $
|
||||
# FreeBSD Id: Makefile,v 1.7 1997/06/24 18:43:23 jfitz Exp
|
||||
#
|
||||
|
||||
|
@ -10,7 +10,7 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Crypt/}
|
|||
MAINTAINER= packages@netbsd.org
|
||||
COMMENT= perl5 cipher block chaining mode for various crypto algorithms
|
||||
|
||||
DEPENDS+= p5-Digest-MD5>=2.12:../../security/p5-Digest-MD5
|
||||
DEPENDS+= p5-Digest-MD5>=2.16:../../security/p5-Digest-MD5
|
||||
|
||||
USE_PERL5= # defined
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Crypt/CBC/.packlist
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/19 15:40:35 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/10/02 11:52:53 mjl Exp $
|
||||
|
||||
SHA1 (Crypt-CBC-1.25.tar.gz) = 8a9c214582d144ffa8d33e44b5764be96b5d9770
|
||||
Size (Crypt-CBC-1.25.tar.gz) = 6899 bytes
|
||||
SHA1 (patch-aa) = aa140b01dcd32f27cf2d122208cebb0a285a5391
|
||||
SHA1 (patch-ab) = c5635e0233f2f62253bf27a9b29e266eb73b4a64
|
||||
|
|
13
security/p5-Crypt-CBC/patches/patch-aa
Normal file
13
security/p5-Crypt-CBC/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2001/10/02 11:52:53 mjl Exp $
|
||||
|
||||
--- Makefile.PL.orig Tue Oct 2 13:37:10 2001
|
||||
+++ Makefile.PL Tue Oct 2 13:37:25 2001
|
||||
@@ -4,7 +4,7 @@
|
||||
WriteMakefile(
|
||||
'NAME' => 'Crypt::CBC',
|
||||
'VERSION_FROM' => 'CBC.pm', # finds $VERSION
|
||||
- 'PREREQ_PM' => {'MD5' => '1.00' },
|
||||
+ 'PREREQ_PM' => {'Digest::MD5' => '1.16' },
|
||||
'LIBS' => [''], # e.g., '-lm'
|
||||
'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
|
||||
'INC' => '', # e.g., '-I/usr/include/other'
|
24
security/p5-Crypt-CBC/patches/patch-ab
Normal file
24
security/p5-Crypt-CBC/patches/patch-ab
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ab,v 1.1 2001/10/02 11:52:53 mjl Exp $
|
||||
|
||||
--- CBC.pm.orig Tue Oct 2 13:38:01 2001
|
||||
+++ CBC.pm Tue Oct 2 13:42:11 2001
|
||||
@@ -1,6 +1,6 @@
|
||||
package Crypt::CBC;
|
||||
|
||||
-use MD5;
|
||||
+use Digest::MD5;
|
||||
use Carp;
|
||||
use strict;
|
||||
use vars qw($VERSION);
|
||||
@@ -28,9 +28,9 @@
|
||||
|
||||
# the real key is computed from the first N bytes of the
|
||||
# MD5 hash of the provided key.
|
||||
- my $material = MD5->hash($key);
|
||||
+ my $material = Digest::MD5::md5($key);
|
||||
while (length($material) < $ks + $bs) {
|
||||
- $material .= MD5->hash($material);
|
||||
+ $material .= Digest::MD5::md5($material);
|
||||
}
|
||||
|
||||
# Original implementation of SSLEay used part of the key for the IV
|
Loading…
Reference in a new issue