Fix build with LLVM IAS on ARM.

This commit is contained in:
joerg 2015-03-24 14:28:52 +00:00
parent c88614e105
commit 105d758c31
3 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.96 2015/01/27 05:20:10 dbj Exp $
$NetBSD: distinfo,v 1.97 2015/03/24 14:28:52 joerg Exp $
SHA1 (qt-everywhere-opensource-src-4.8.6.tar.gz) = ddf9c20ca8309a116e0466c42984238009525da6
RMD160 (qt-everywhere-opensource-src-4.8.6.tar.gz) = 0220d4e76ac761c9ecfb8ddab6f2c1dc6ad70c33
@ -64,6 +64,8 @@ SHA1 (patch-src_3rdparty_webkit_Source_JavaScriptCore_wtf_Threading.h) = fa7519e
SHA1 (patch-src_3rdparty_webkit_Source_WebCore_dom_Element.cpp) = 90fd6a884f9fd058210c3011bea2ce695011d2e3
SHA1 (patch-src_3rdparty_webkit_Source_WebCore_platform_DefaultLocalizationStrategy.cpp) = 0377066bd28d5eae02e8fcf200da4360c286ad84
SHA1 (patch-src_3rdparty_webkit_Source_WebCore_platform_graphics_MediaPlayer.cpp) = f9a1f71b4607c5f542c059873cf5735fad9ff3a1
SHA1 (patch-src_3rdparty_webkit_Source_WebCore_platform_graphics_filters_arm_FEGaussianBlurNEON.cpp) = 51b6bddf81978fd7ae6580132a74aeaec84b724f
SHA1 (patch-src_3rdparty_webkit_Source_WebCore_platform_graphics_filters_arm_FELightingNEON.cpp) = a0a3d9d066aa6ae3c42cee198287b10e46e7f25d
SHA1 (patch-src_3rdparty_webkit_Source_WebCore_platform_qt_PlatformKeyboardEventQt.cpp) = b28cf71983f8e71b82b1c634a10b3898ca13ede5
SHA1 (patch-src_corelib_io_io.pri) = cde98927b524c92fae1e053c2359e77bde2c240a
SHA1 (patch-src_corelib_io_qfilesystemwatcher.cpp) = bb16b95d20286b1aa069dc25843d7e0067cc0268

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_3rdparty_webkit_Source_WebCore_platform_graphics_filters_arm_FEGaussianBlurNEON.cpp,v 1.1 2015/03/24 14:28:53 joerg Exp $
--- src/3rdparty/webkit/Source/WebCore/platform/graphics/filters/arm/FEGaussianBlurNEON.cpp.orig 2015-03-18 10:26:12.000000000 +0000
+++ src/3rdparty/webkit/Source/WebCore/platform/graphics/filters/arm/FEGaussianBlurNEON.cpp
@@ -285,7 +285,7 @@ TOSTRING(neonDrawAlphaChannelGaussianBlu
"vmov.u32 " REMAINING_STRIDES_R ", " REMAINING_STRIDES_S0 NL
// Early return for 0 strides.
"cmp " REMAINING_STRIDES_R ", #0" NL
- "ldmeqia sp!, {r4-r8, r10, r11, pc}" NL
+ "ldmiaeq sp!, {r4-r8, r10, r11, pc}" NL
// Initialize the sum variable.
"vmov.u32 " SUM_Q ", #0" NL

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_3rdparty_webkit_Source_WebCore_platform_graphics_filters_arm_FELightingNEON.cpp,v 1.1 2015/03/24 14:28:53 joerg Exp $
--- src/3rdparty/webkit/Source/WebCore/platform/graphics/filters/arm/FELightingNEON.cpp.orig 2015-03-18 10:18:46.000000000 +0000
+++ src/3rdparty/webkit/Source/WebCore/platform/graphics/filters/arm/FELightingNEON.cpp
@@ -398,7 +398,7 @@ TOSTRING(neonDrawLighting) ":" NL
"vmin.f32 " TMP2_D0 ", " TMP2_D0 ", " CONST_ONE_HI_D NL
"vmul.f32 " TMP3_Q ", " COLOR_Q ", " TMP2_D0 "[1]" NL
"vcvt.u32.f32 " TMP3_Q ", " TMP3_Q NL
- "vmov.u32 r2, r3, " TMP3_S0 ", " TMP3_S1 NL
+ "vmov r2, r3, " TMP3_S0 ", " TMP3_S1 NL
// The color values are stored in-place.
"strb r2, [" PIXELS_R ", #-11]" NL
"strb r3, [" PIXELS_R ", #-10]" NL