Make this build on OS X. The new files are taken from the emacs cvs

repository.
This commit is contained in:
kristerw 2004-07-31 21:01:54 +00:00
parent b34088ef7d
commit 10a31bbed9
6 changed files with 1515 additions and 11 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.72 2004/04/19 15:39:34 markd Exp $
# $NetBSD: Makefile,v 1.73 2004/07/31 21:01:54 kristerw Exp $
# FreeBSD Id: Makefile,v 1.30 1997/12/14 02:03:53 asami Exp
DISTNAME= emacs-21.3
@ -35,6 +35,8 @@ CONFIGURE_ARGS+= --with-gif
.include "../../graphics/png/buildlink3.mk"
CONFIGURE_ARGS+= --with-png
MAKEFLAGS+= EMACSLOADPATH=${WRKSRC}/lisp
.include "../../mk/bsd.prefs.mk"
.if defined(EMACS_USE_XAW3D) && !empty(EMACS_USE_XAW3D:M[Yy][Ee][Ss])
@ -68,6 +70,9 @@ REPLACE_PERL= lib-src/grep-changelog
post-extract:
${CP} ${FILESDIR}/site-init.el ${WRKSRC}/lisp
${CP} ${FILESDIR}/amd64.h ${WRKSRC}/src/m
${CP} ${FILESDIR}/powermac.h ${WRKSRC}/src/m
${CP} ${FILESDIR}/darwin.h ${WRKSRC}/src/s
${CP} ${FILESDIR}/unexmacosx.c ${WRKSRC}/src
pre-install:
@${FIND} ${WRKSRC} -type f -name "*.orig" -print | ${XARGS} ${RM} -f

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.15 2004/02/25 19:11:43 drochner Exp $
$NetBSD: distinfo,v 1.16 2004/07/31 21:01:54 kristerw Exp $
SHA1 (emacs-21.3.tar.gz) = a8aae1b619e50ed6fed5b1351b54b38ed98c61b8
Size (emacs-21.3.tar.gz) = 20399831 bytes
SHA1 (patch-aa) = fee6fe91fb9a2f75300903cc5c6e023bb8de6be5
SHA1 (patch-ab) = 7e1523d174ef8083b0bcc6cbecde833502350109
SHA1 (patch-ab) = 11aaeecc08619f3962b1a07c1db01dc9c7a2c5a7
SHA1 (patch-ad) = 39a11bc214ae3d2f9d634c30b196a46d473ab92f
SHA1 (patch-ae) = e2b66b23efb90608470aef5ebd0c75e27bcd6b55
SHA1 (patch-ag) = 3d64c0d53e3a8a737eeb04a6080a92a826b73620

View file

@ -0,0 +1,324 @@
/* System description header file for Darwin (Mac OS X).
Copyright (C) 2001, 02, 2004 Free Software Foundation, Inc.
This file is part of GNU Emacs.
GNU Emacs is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2, or (at your option)
any later version.
GNU Emacs is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with GNU Emacs; see the file COPYING. If not, write to
the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA. */
/*
* Define symbols to identify the version of Unix this is.
* Define all the symbols that apply correctly.
*/
/* #define UNIPLUS */
/* #define USG5 */
/* #define USG */
/* #define HPUX */
/* #define UMAX */
/* #define BSD4_1 */
#define BSD4_2
/* BSD4_3 and BSD4_4 are already defined in sys/param.h */
/* #define BSD4_3 */
/* #define BSD4_4 */
#define BSD_SYSTEM
/* #define VMS */
/* MAC_OS is used to conditionally compile code common to both MAC_OS8
and MAC_OSX. */
#ifdef MAC_OSX
#ifdef HAVE_CARBON
#define MAC_OS
#endif
#endif
/* SYSTEM_TYPE should indicate the kind of system you are using.
It sets the Lisp variable system-type. */
#define SYSTEM_TYPE "darwin"
/* NOMULTIPLEJOBS should be defined if your system's shell
does not have "job control" (the ability to stop a program,
run some other program, then continue the first one). */
/* #define NOMULTIPLEJOBS */
/* Emacs can read input using SIGIO and buffering characters itself,
or using CBREAK mode and making C-g cause SIGINT.
The choice is controlled by the variable interrupt_input.
Define INTERRUPT_INPUT to make interrupt_input = 1 the default (use SIGIO)
Emacs uses the presence or absence of the SIGIO and BROKEN_SIGIO macros
to indicate whether or not signal-driven I/O is possible. It uses
INTERRUPT_INPUT to decide whether to use it by default.
SIGIO can be used only on systems that implement it (4.2 and 4.3).
CBREAK mode has two disadvantages
1) At least in 4.2, it is impossible to handle the Meta key properly.
I hear that in system V this problem does not exist.
2) Control-G causes output to be discarded.
I do not know whether this can be fixed in system V.
Another method of doing input is planned but not implemented.
It would have Emacs fork off a separate process
to read the input and send it to the true Emacs process
through a pipe. */
#define INTERRUPT_INPUT
/* Letter to use in finding device name of first pty,
if system supports pty's. 'a' means it is /dev/ptya0 */
#define FIRST_PTY_LETTER 'p'
/*
* Define HAVE_TERMIOS if the system provides POSIX-style
* functions and macros for terminal control.
*
* Define HAVE_TERMIO if the system provides sysV-style ioctls
* for terminal control.
*
* Do not define both. HAVE_TERMIOS is preferred, if it is
* supported on your system.
*/
#define HAVE_TERMIOS
/* #define HAVE_TERMIO */
#define NO_TERMIO
/*
* Define HAVE_PTYS if the system supports pty devices.
*/
#define HAVE_PTYS
/*
* Define NONSYSTEM_DIR_LIBRARY to make Emacs emulate
* The 4.2 opendir, etc., library functions.
*/
/* #define NONSYSTEM_DIR_LIBRARY */
/* Define this symbol if your system has the functions bcopy, etc. */
#define BSTRING
/* subprocesses should be defined if you want to
have code for asynchronous subprocesses
(as used in M-x compile and M-x shell).
This is generally OS dependent, and not supported
under most USG systems. */
#define subprocesses
/* If your system uses COFF (Common Object File Format) then define the
preprocessor symbol "COFF". */
/* #define COFF */
/* define MAIL_USE_FLOCK if the mailer uses flock
to interlock access to /usr/spool/mail/$USER.
The alternative is that a lock file named
/usr/spool/mail/$USER.lock. */
#define MAIL_USE_FLOCK
/* Define CLASH_DETECTION if you want lock files to be written
so that Emacs can tell instantly when you try to modify
a file that someone else has modified in his Emacs. */
#define CLASH_DETECTION
/* Define this if your operating system declares signal handlers to
have a type other than the usual. `The usual' is `void' for ANSI C
systems (i.e. when the __STDC__ macro is defined), and `int' for
pre-ANSI systems. If you're using GCC on an older system, __STDC__
will be defined, but the system's include files will still say that
signal returns int or whatever; in situations like that, define
this to be what the system's include files want. */
/* #define SIGTYPE int */
/* If the character used to separate elements of the executable path
is not ':', #define this to be the appropriate character constant. */
/* #define SEPCHAR ':' */
/* Define this if the system can use mmap for buffer text allocation. */
/* #define USE_MMAP_FOR_BUFFERS 1 */
/* ============================================================ */
/* Here, add any special hacks needed
to make Emacs work on this system. For example,
you might define certain system call names that don't
exist on your system, or that do different things on
your system and must be used only through an encapsulation
(Which you should place, by convention, in sysdep.c). */
/* Some compilers tend to put everything declared static
into the initialized data area, which becomes pure after dumping Emacs.
On these systems, you must #define static as nothing to foil this.
Note that emacs carefully avoids static vars inside functions. */
/* #define static */
/* If the system's imake configuration file defines `NeedWidePrototypes'
as `NO', we must define NARROWPROTO manually. Such a define is
generated in the Makefile generated by `xmkmf'. If we don't
define NARROWPROTO, we will see the wrong function prototypes
for X functions taking float or double parameters. */
/* #define NARROWPROTO 1 */
/* ============================================================ */
/* After adding support for a new system, modify the large case
statement in the `configure' script to recognize reasonable
configuration names, and add a description of the system to
`etc/MACHINES'.
If you've just fixed a problem in an existing configuration file,
you should also check `etc/MACHINES' to make sure its descriptions
of known problems in that configuration should be updated. */
/* Avoid the use of the name init_process (process.c) because it is
also the name of a Mach system call. */
#define init_process emacs_init_process
/* Fix compilation problem for regex.c. */
#define __restrict
/* Used in dispnew.c. Copied from freebsd.h. */
#define PENDING_OUTPUT_COUNT(FILE) ((FILE)->_p - (FILE)->_bf._base)
/* System uses OXTABS instead of the expected TAB3. (Copied from
bsd386.h.) */
#define TAB3 OXTABS
/* Darwin ld insists on the use of malloc routines in the System
framework. */
#define SYSTEM_MALLOC
/* Define HAVE_SOCKETS if system supports 4.2-compatible sockets. */
#define HAVE_SOCKETS
/* Extra initialization calls in main for Mac OS X system type. */
#ifdef HAVE_CARBON
#define SYMS_SYSTEM syms_of_mac()
#endif
/* Definitions for how to dump. Copied from nextstep.h. */
#define UNEXEC unexmacosx.o
#define START_FILES pre-crt0.o
/* start_of_text isn't actually used, so make it compile without error. */
#define TEXT_START (0)
/* This seems to be right for end_of_text, but it may not be used anyway. */
#define TEXT_END get_etext()
/* This seems to be right for end_of_data, but it may not be used anyway. */
#define DATA_END get_edata()
/* Definitions for how to compile & link. */
/* Indicate that we are compiling for Mac OS X and where to find Mac
specific headers. */
#define C_SWITCH_SYSTEM -fpascal-strings -fno-common -DMAC_OSX -I../mac/src
/* Link in the Carbon lib. The -headerpad option tells ld (see man
page) to leave room at the end of the header for adding load
commands. Needed for dumping. 0x690 is the total size of 30
segment load commands (at 56 each). */
#define LD_SWITCH_SYSTEM_TEMACS -prebind -framework Carbon -framework QuickTime -lstdc++ -Xlinker -headerpad -Xlinker 690
#define C_SWITCH_SYSTEM_TEMACS -Dtemacs
/* The ncurses library has been moved out of the System framework in
Mac OS X 10.2. So if ./configure detects it, set the command-line
option to use it. */
#ifdef HAVE_LIBNCURSES
#define LIBS_TERMCAP -lncurses
/* This prevents crashes when running Emacs in Terminal.app under
10.2. */
#define TERMINFO
#endif
/* Link this program just by running cc. */
#define ORDINARY_LINK
/* We don't have a g library, so override the -lg LIBS_DEBUG switch. */
#define LIBS_DEBUG
/* Adding -lm confuses the dynamic linker, so omit it. */
#define LIB_MATH
/* Tell src/Makefile.in to create files in the Mac OS X application
bundle mac/Emacs.app. */
#ifdef HAVE_CARBON
#define OTHER_FILES macosx-app
#endif
/* Define the following so emacs symbols will not conflict with those
in the System framework. Otherwise -prebind will not work. */
/* Do not define abort in emacs.c. */
#define NO_ABORT
/* Do not define matherr in floatfns.c. */
#define NO_MATHERR
/* This prevents a compilation error in xfaces.c: struct kboard * is
used in a function protocol the first time this type appears in the
file, since MULTI_KBOARD is undefined for the Mac OS X build. */
#ifndef NOT_C_CODE
struct kboard;
#endif
/* The following solves the problem that Emacs hangs when evaluating
(make-comint "test0" "/nodir/nofile" nil "") when /nodir/nofile
does not exist. */
#undef HAVE_WORKING_VFORK
#define vfork fork
#define DONT_REOPEN_PTY
#ifdef temacs
#define malloc unexec_malloc
#define realloc unexec_realloc
#define free unexec_free
#endif
/* Reroute calls to SELECT to the version defined in mac.c to fix the
problem of Emacs requiring an extra return to be typed to start
working when started from the command line. */
#if defined (HAVE_CARBON) && (defined (emacs) || defined (temacs))
#define select sys_select
#endif
/* Use the GC_MAKE_GCPROS_NOOPS (see lisp.h) method for marking the
stack. */
#define GC_MARK_STACK GC_MAKE_GCPROS_NOOPS
/* arch-tag: 481d443d-4f89-43ea-b5fb-49706d95fa41
(do not change this comment) */
#define GETPGRP_NO_ARG
#define HAVE_ALLOCA

View file

@ -0,0 +1,115 @@
/* Machine description file for Apple Power Macintosh
Copyright (C) 2001 Free Software Foundation, Inc.
This file is part of GNU Emacs.
GNU Emacs is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2, or (at your option)
any later version.
GNU Emacs is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with GNU Emacs; see the file COPYING. If not, write to
the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
Boston, MA 02111-1307, USA. */
/* The following line tells the configuration script what sort of
operating system this machine is likely to run.
USUAL-OPSYS="darwin" */
/* Define WORDS_BIG_ENDIAN iff lowest-numbered byte in a word
is the most significant byte. */
#define WORDS_BIG_ENDIAN
/* Define NO_ARG_ARRAY if you cannot take the address of the first of a
* group of arguments and treat it as an array of the arguments. */
#define NO_ARG_ARRAY
/* Define WORD_MACHINE if addresses and such have
* to be corrected before they can be used as byte counts. */
/* #define WORD_MACHINE */
/* Now define a symbol for the cpu type, if your compiler
does not define it automatically:
Ones defined so far include vax, m68000, ns16000, pyramid,
orion, tahoe, APOLLO and many others */
/* Use type int rather than a union, to represent Lisp_Object */
/* This is desirable for most machines. */
#define NO_UNION_TYPE
/* Define EXPLICIT_SIGN_EXTEND if XINT must explicitly sign-extend
the 24-bit bit field into an int. In other words, if bit fields
are always unsigned.
If you use NO_UNION_TYPE, this flag does not matter. */
/* #define EXPLICIT_SIGN_EXTEND */
/* Data type of load average, as read out of kmem. */
#define LOAD_AVE_TYPE long
/* Convert that into an integer that is 100 for a load average of 1.0 */
#define LOAD_AVE_CVT(x) (int) (((double) (x)) * 100.0 / FSCALE)
/* Define CANNOT_DUMP on machines where unexec does not work.
Then the function dump-emacs will not be defined
and temacs will do (load "loadup") automatically unless told otherwise. */
/* #define CANNOT_DUMP */
/* Define VIRT_ADDR_VARIES if the virtual addresses of
pure and impure space as loaded can vary, and even their
relative order cannot be relied on.
Otherwise Emacs assumes that text space precedes data space,
numerically. */
/* #define VIRT_ADDR_VARIES * */
/* Define NO_REMAP if memory segmentation makes it not work well
to change the boundary between the text section and data section
when Emacs is dumped. If you define this, the preloaded Lisp
code will not be sharable; but that's better than failing completely. */
#define NO_REMAP
/* Some really obscure 4.2-based systems (like Sequent DYNIX)
* do not support asynchronous I/O (using SIGIO) on sockets,
* even though it works fine on tty's. If you have one of
* these systems, define the following, and then use it in
* config.h (or elsewhere) to decide when (not) to use SIGIO.
*
* You'd think this would go in an operating-system description file,
* but since it only occurs on some, but not all, BSD systems, the
* reasonable place to select for it is in the machine description
* file.
*/
/* #define NO_SOCK_SIGIO */
/* After adding support for a new system, modify the large case
statement in the `configure' script to recognize reasonable
configuration names, and add a description of the system to
`etc/MACHINES'.
If you've just fixed a problem in an existing configuration file,
you should also check `etc/MACHINES' to make sure its descriptions
of known problems in that configuration should be updated. */
/* arch-tag: d8af08a6-48b3-4c8a-94a0-0b4acae5e1f0
(do not change this comment) */
#define CANNOT_DUMP

File diff suppressed because it is too large Load diff

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.17 2004/02/25 19:11:43 drochner Exp $
$NetBSD: patch-ab,v 1.18 2004/07/31 21:01:54 kristerw Exp $
--- configure.orig 2003-03-18 15:19:12.000000000 +0100
+++ configure 2004-02-25 20:04:08.000000000 +0100
@@ -822,6 +822,7 @@
--- configure.orig Tue Mar 18 15:19:12 2003
+++ configure Sat Jul 31 03:56:01 2004
@@ -822,9 +822,13 @@
sparc*-*-netbsd*) machine=sparc ;;
vax-*-netbsd*) machine=vax ;;
arm-*-netbsd*) machine=arm ;;
@ -10,10 +10,17 @@ $NetBSD: patch-ab,v 1.17 2004/02/25 19:11:43 drochner Exp $
esac
;;
@@ -9124,6 +9125,22 @@
+ ## Darwin / Mac OS X
+ powerpc-apple-darwin* )
+ machine=powermac opsys=darwin ;;
## OpenBSD ports
*-*-openbsd* )
opsys=openbsd
@@ -9123,6 +9127,22 @@
fi
+
+# NETBSD: NetBSD's newer run-time linker fix.
+if test $opsys = netbsd; then
+ if test -f /usr/lib/crti.o; then
@ -29,7 +36,6 @@ $NetBSD: patch-ab,v 1.17 2004/02/25 19:11:43 drochner Exp $
+
+ fi
+fi
+
# Set up the CFLAGS for real compilation, so we can substitute it.
CFLAGS="$REAL_CFLAGS"
CPPFLAGS="$REAL_CPPFLAGS"