Update mikutter to 0.0.3.9.

While here, let to allow co-existence with ruby-escape package.

Improvements
* none
Fixes
* impossible to search with Japanese
* impossible to google search with Japanese
* fire shortcut key for tweet when typing search string
* memory leaks
* devours API with retrying tweet of keyed account that does not authenticat me
* not play sound on some platforms.
This commit is contained in:
obache 2011-06-19 04:19:56 +00:00
parent 6b7f059293
commit 10ecd8791c
5 changed files with 31 additions and 13 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.9 2011/06/12 12:41:15 obache Exp $
# $NetBSD: Makefile,v 1.10 2011/06/19 04:19:56 obache Exp $
#
DISTNAME= mikutter.0.0.3.8
DISTNAME= mikutter.0.0.3.9
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME:S/./-/}
CATEGORIES= net
MASTER_SITES= http://mikutter.hachune.net/bin/
@ -39,7 +39,9 @@ REPLACE_RUBY_DIRS= core
INSTALLATION_DIRS+= bin share/doc/mikutter share/applications share/mikutter
do-build:
cd ${WRKSRC}/core/lib && ${RM} -rf json* hmac*.rb oauth* memoize.rb ruby-bsearch-*
cd ${WRKSRC}/core/lib && \
${RM} -rf json* hmac*.rb oauth* memoize.rb ruby-bsearch-* && \
${MKDIR} miku && ${MV} escape.rb miku/escape.rb
${SED} -e 's,@PREFIX@,${PREFIX},g' < ${FILESDIR}/desktop.in > ${WRKDIR}/desktop
${SED} -e 's,@PREFIX@,${PREFIX},g' < ${FILESDIR}/mikutter.sh.in > ${WRKDIR}/mikutter.sh

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2011/06/12 12:41:15 obache Exp $
@comment $NetBSD: PLIST,v 1.9 2011/06/19 04:19:56 obache Exp $
bin/mikutter
share/applications/mikutter.desktop
share/doc/mikutter/README
@ -36,8 +36,8 @@ share/mikutter/core/entity.rb
share/mikutter/core/environment.rb
share/mikutter/core/image.rb
share/mikutter/core/initialize.rb
share/mikutter/core/lib/escape.rb
share/mikutter/core/lib/lazy.rb
share/mikutter/core/lib/miku/escape.rb
share/mikutter/core/lib/piapro.rb
share/mikutter/core/lib/timelimitedqueue.rb
share/mikutter/core/lib/timelimitedqueue/test/test_timelimitedqueue.rb

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.9 2011/06/12 12:41:15 obache Exp $
$NetBSD: distinfo,v 1.10 2011/06/19 04:19:56 obache Exp $
SHA1 (mikutter.0.0.3.8.tar.gz) = 58cfd3f21caccf7810ddf818ea721a4eedbebbdf
RMD160 (mikutter.0.0.3.8.tar.gz) = 8caafad46495ef3c84d852822348f5df7ae03ce6
Size (mikutter.0.0.3.8.tar.gz) = 2025444 bytes
SHA1 (patch-core_mui_cairo__inner__tl.rb) = db183cdbef99d9dba67f43a684b4dc99a1c94028
SHA1 (mikutter.0.0.3.9.tar.gz) = aee145a77d46ab1c1c231c9c0bb3d2af8488b3a4
RMD160 (mikutter.0.0.3.9.tar.gz) = b4fe6cc0a1f04b7becce1dbab50aa7d9f9d565a0
Size (mikutter.0.0.3.9.tar.gz) = 2027673 bytes
SHA1 (patch-core_mui_cairo__inner__tl.rb) = 5a6d46874f5cc48e19f4289c8475e9eb5ccc2d98
SHA1 (patch-core_utils.rb) = ef027320f9217264cc0e8ec0b2de87bf7b829db0

View file

@ -1,8 +1,8 @@
$NetBSD: patch-core_mui_cairo__inner__tl.rb,v 1.1 2011/06/12 12:41:15 obache Exp $
$NetBSD: patch-core_mui_cairo__inner__tl.rb,v 1.2 2011/06/19 04:19:56 obache Exp $
* use system bseach library instead of included one.
--- core/mui/cairo_inner_tl.rb.orig 2011-06-05 13:30:21.000000000 +0000
--- core/mui/cairo_inner_tl.rb.orig 2011-06-15 17:42:27.000000000 +0000
+++ core/mui/cairo_inner_tl.rb
@@ -1,7 +1,7 @@
# -*- coding: utf-8 -*-
@ -12,4 +12,4 @@ $NetBSD: patch-core_mui_cairo__inner__tl.rb,v 1.1 2011/06/12 12:41:15 obache Exp
+miquire :lib, 'bsearch'
class Gtk::TimeLine::InnerTL < Gtk::CRUD
attr_accessor :postbox
attr_accessor :postbox, :hp

View file

@ -0,0 +1,15 @@
$NetBSD: patch-core_utils.rb,v 1.1 2011/06/19 04:19:56 obache Exp $
* use included escape library instead of system one.
--- core/utils.rb.orig 2011-06-12 14:01:26.000000000 +0000
+++ core/utils.rb
@@ -83,7 +83,7 @@ def file_or_directory_require(rb)
require rb end end
Dir::chdir(File::dirname(__FILE__))
-miquire :lib, 'escape'
+miquire :lib, 'miku/escape'
miquire :lib, 'lazy'
# すべてのクラスにメモ化機能を