Yet another perl 5.12.x error fix

Oked by wiz@
This commit is contained in:
pettai 2010-10-06 21:27:29 +00:00
parent 4b3424618e
commit 10edf61acb
3 changed files with 24 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.99 2010/10/03 21:53:17 pettai Exp $
# $NetBSD: Makefile,v 1.100 2010/10/06 21:27:29 pettai Exp $
DISTNAME= Mail-SpamAssassin-3.3.1
PKGNAME= spamassassin-3.3.1
PKGREVISION= 2
PKGREVISION= 3
SVR4_PKGNAME= sa
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_APACHE:=spamassassin/source/}

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.54 2010/10/04 22:12:06 pettai Exp $
$NetBSD: distinfo,v 1.55 2010/10/06 21:27:30 pettai Exp $
SHA1 (Mail-SpamAssassin-3.3.1.tar.gz) = 8b32a857cc89c8d057442400bc00f33fd703ce06
RMD160 (Mail-SpamAssassin-3.3.1.tar.gz) = 154fb16de88b3cc9fac41f721af21b181a2368f3
@ -21,3 +21,4 @@ SHA1 (patch-bg) = 29a06349f3f34b5f5de5142c6c0ec4b3e9e14cab
SHA1 (patch-bh) = 3fb1753552819bf1ae47a0275aac237b684d8d78
SHA1 (patch-bi) = 896a0eb836bf9227454cd947c3b4f09f010c1c2a
SHA1 (patch-bj) = 0ea3dd23fa5505e0ac8ecbb4b8cc84205b3c41d8
SHA1 (patch-bk) = b93142e01e6a25a0143676866a6b717ab5f96497

View file

@ -0,0 +1,20 @@
$NetBSD: patch-bk,v 1.1 2010/10/06 21:27:30 pettai Exp $
fixes "Use of uninitialized value $opt{"syslog-socket"} in lc" error
--- spamd/spamd.raw.orig 2010-03-16 14:49:25.000000000 +0000
+++ spamd/spamd.raw
@@ -443,10 +443,12 @@ my $log_facility = $opt{'syslog'} || 'ma
# socket of 'none' means as much as --syslog=null. Sounds complicated? It is.
# But it works.
# )
-my $log_socket = lc($opt{'syslog-socket'});
+my $log_socket = $opt{'syslog-socket'};
if (!defined $log_socket || $log_socket eq '') {
$log_socket = am_running_on_windows() ? 'none' : 'unix';
+} else {
+ $log_socket = lc $log_socket;
}
# This is the default log file; it can be changed on the command line