Update dbus python bindings to 1.2.2.

D-Bus Python Bindings 1.2.2 (2016-02-22)
========================================

The “mind fray” release.

Versioning changes:

• dbus-python releases now have an even micro version (1.2.0, 1.2.2),
  and snapshots from git have an odd micro version (1.2.1).

Dependencies:

• Building from git (but not from tarballs) now requires
  macros from the GNU Autoconf Archive, for example the autoconf-archive
  package in Debian or Fedora derivatives.

• Building from git (but not from tarballs) now requires Automake 1.13
  or later.

• The automated tests and some examples now require PyGI (the gi module),
  not PyGObject 2 (the deprecated glib and gobject modules).

Enhancements:

• There is now a setuptools setup.py, allowing dbus-python to be installed
  into a virtualenv using pip from a standard Automake source release. This
  requires pre-existing system-wide installations of the normal build
  dependencies (pkg-config, libdbus, dbus-glib, a C compiler) and has
  some limitations. For system-wide installations and development,
  please use the Autoconf/Automake build system directly.
  (fd.o #55439; Simon McVittie)

• dbus-python now uses the common compiler warnings from AX_COMPILER_FLAGS
  (Simon McVittie)

• The automated tests can now be installed as GNOME-style "installed tests",
  and should be somewhat more reliable (Simon McVittie)

Fixes:

• "from dbus.service import *" now imports FallbackObject
  (fd.o #85720; Ben Longbons)

• The GConf-related examples work again (fd.o #85720; Ben Longbons)

• Consistently make examples executable, and install them all
  (fd.o #85720; Ben Longbons)

• Search PATH for an appropriately-versioned pythonX.Y-config, or as a last
  resort python-config, if there isn't a ${PYTHON}-config in the
  same directory as ${PYTHON} (fd.o #92085; Yamashita, Yuu)

• Add support for the Automake 1.13 parallel test driver (Simon McVittie)

• Skip building API documentation if "import epydoc" fails (Simon McVittie)
This commit is contained in:
wiz 2016-03-03 12:16:24 +00:00
parent 08bd17205f
commit 112b123c35
5 changed files with 29 additions and 25 deletions

View file

@ -1,14 +1,10 @@
# $NetBSD: Makefile,v 1.9 2016/02/26 10:24:12 jperkin Exp $
# $NetBSD: Makefile,v 1.10 2016/03/03 12:16:24 wiz Exp $
DISTNAME= dbus-python-1.2.0
PKGNAME= dbus-python-common-1.2.0
DISTNAME= dbus-python-1.2.2
PKGNAME= ${DISTNAME:S/python/python-common/}
CATEGORIES= sysutils
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus-python/
#BUILD_DEPENDS+= ${PYPKGPREFIX}-docutils>=0:../../textproc/py-docutils
#DEPENDS+= ${PYPKGPREFIX}-pyrex>=0.9.3:../../lang/py-pyrex
#PYTHON_VERSIONS_INCOMPATIBLE=33 34 35 # py-pyrex
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.freedesktop.org/Software/dbus
COMMENT= Python bindings for the D-BUS message bus system
@ -17,6 +13,9 @@ LICENSE= mit
CONFLICTS+= py[0-9]*-dbus<1.1.1
PYTHON_FOR_BUILD_ONLY= yes
#BUILD_DEPENDS+= ${PYPKGPREFIX}-docutils>=0:../../textproc/py-docutils
#DEPENDS+= ${PYPKGPREFIX}-pyrex>=0.9.3:../../lang/py-pyrex
#PYTHON_VERSIONS_INCOMPATIBLE=33 34 35 # py-pyrex
USE_TOOLS+= pkg-config gmake
GNU_CONFIGURE= yes

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.3 2015/11/04 01:32:09 agc Exp $
$NetBSD: distinfo,v 1.4 2016/03/03 12:16:24 wiz Exp $
SHA1 (dbus-python-1.2.0.tar.gz) = 7a00f7861d26683ab7e3f4418860bd426deed9b5
RMD160 (dbus-python-1.2.0.tar.gz) = cba09a1ca259bfa49c943142110a968241f40360
SHA512 (dbus-python-1.2.0.tar.gz) = 013b23e08fa1ed43f53a756587fefbc9770f7c51e93510e555acbd77230b7200693419bba9a69680d790bbaf123f4a195afa38b3eee1143da950fee0b5130bce
Size (dbus-python-1.2.0.tar.gz) = 602426 bytes
SHA1 (dbus-python-1.2.2.tar.gz) = c2b93b1f0e4945711d6f6d232e63cb9aa3a93359
RMD160 (dbus-python-1.2.2.tar.gz) = 2f05ee946b0ebc62318f6d4e20e8c51ce131d864
SHA512 (dbus-python-1.2.2.tar.gz) = a92b0bbb29ce20c5a90d44819ef31c755b3bab7ce3cfb3d0157ea2c37af63b859213f5f59703e4f3d5bbe6861e506749a740f3a11a7b87b1c3f81aa7b9c172d6
Size (dbus-python-1.2.2.tar.gz) = 608781 bytes

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.30 2016/02/26 10:24:13 jperkin Exp $
# $NetBSD: Makefile,v 1.31 2016/03/03 12:16:24 wiz Exp $
DISTNAME= dbus-python-1.2.0
DISTNAME= dbus-python-1.2.2
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/-python//}
CATEGORIES= sysutils
MASTER_SITES= http://dbus.freedesktop.org/releases/dbus-python/

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.12 2015/11/04 01:32:27 agc Exp $
$NetBSD: distinfo,v 1.13 2016/03/03 12:16:24 wiz Exp $
SHA1 (dbus-python-1.2.0.tar.gz) = 7a00f7861d26683ab7e3f4418860bd426deed9b5
RMD160 (dbus-python-1.2.0.tar.gz) = cba09a1ca259bfa49c943142110a968241f40360
SHA512 (dbus-python-1.2.0.tar.gz) = 013b23e08fa1ed43f53a756587fefbc9770f7c51e93510e555acbd77230b7200693419bba9a69680d790bbaf123f4a195afa38b3eee1143da950fee0b5130bce
Size (dbus-python-1.2.0.tar.gz) = 602426 bytes
SHA1 (patch-aa) = ca721c56463a5180e6a33e5a3d6135660e93c38f
SHA1 (patch-py-compile) = 5dbbdd89c0cc5e51203d8200c8846f12730cf25f
SHA1 (dbus-python-1.2.2.tar.gz) = c2b93b1f0e4945711d6f6d232e63cb9aa3a93359
RMD160 (dbus-python-1.2.2.tar.gz) = 2f05ee946b0ebc62318f6d4e20e8c51ce131d864
SHA512 (dbus-python-1.2.2.tar.gz) = a92b0bbb29ce20c5a90d44819ef31c755b3bab7ce3cfb3d0157ea2c37af63b859213f5f59703e4f3d5bbe6861e506749a740f3a11a7b87b1c3f81aa7b9c172d6
Size (dbus-python-1.2.2.tar.gz) = 608781 bytes
SHA1 (patch-aa) = cb5478b7f6660f099b5370c04d639b2300d3a633

View file

@ -1,16 +1,22 @@
$NetBSD: patch-aa,v 1.1 2012/08/01 18:04:26 drochner Exp $
$NetBSD: patch-aa,v 1.2 2016/03/03 12:16:24 wiz Exp $
--- Makefile.in.orig 2012-07-31 22:25:22.000000000 +0000
--- Makefile.in.orig 2016-02-22 16:35:24.000000000 +0000
+++ Makefile.in
@@ -956,9 +956,8 @@ info: info-recursive
@@ -2067,15 +2067,8 @@ info: info-am
info-am:
-install-data-am: install-dbusincludeHEADERS install-dist_docDATA \
- install-installed_testLTLIBRARIES \
- install-installed_test_metaDATA \
- install-installed_test_testDATA \
- install-nobase_dist_installed_testPYTHON \
- install-nobase_dist_installed_testSCRIPTS \
- install-nobase_installed_testPROGRAMS \
- install-nobase_pythonPYTHON install-nodist_docDATA \
- install-pkgconfigDATA
+install-data-am: \
+ install-nobase_pythonPYTHON
install-dvi: install-dvi-recursive
install-dvi: install-dvi-am