Initial import of tdb, version 1.0.6. Description follows:
TDB is a Trivial Database. In concept, it is very much like GDBM, and BSD's DB except that it allows multiple simultaneous writers and uses locking internally to keep writers from trampling on each other. TDB is also extremely small. Approved by wiz. This closes my own PR 18122.
This commit is contained in:
parent
5dabc911cf
commit
114d556e96
7 changed files with 200 additions and 0 deletions
4
databases/tdb/DESCR
Normal file
4
databases/tdb/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
TDB is a Trivial Database. In concept, it is very much like GDBM,
|
||||
and BSD's DB except that it allows multiple simultaneous writers
|
||||
and uses locking internally to keep writers from trampling on
|
||||
each other. TDB is also extremely small.
|
18
databases/tdb/Makefile
Normal file
18
databases/tdb/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2002/11/29 19:19:12 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= tdb-1.0.6
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=tdb/}
|
||||
|
||||
MAINTAINER= jmmv@netbsd.org
|
||||
HOMEPAGE= http://www.sourceforge.net/projects/tdb/
|
||||
COMMENT= Small database system which uses files to store data
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_BUILDLINK2= YES
|
||||
USE_GMAKE= YES
|
||||
USE_LIBTOOL= YES
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
20
databases/tdb/PLIST
Normal file
20
databases/tdb/PLIST
Normal file
|
@ -0,0 +1,20 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/11/29 19:19:12 jmmv Exp $
|
||||
bin/tdbdump
|
||||
bin/tdbtool
|
||||
include/tdb.h
|
||||
lib/libtdb.a
|
||||
lib/libtdb.la
|
||||
lib/libtdb.so
|
||||
lib/libtdb.so.1
|
||||
lib/libtdb.so.1.0
|
||||
man/man3/tdb.3
|
||||
man/man3/tdb_chainlock.3
|
||||
man/man3/tdb_close.3
|
||||
man/man3/tdb_delete.3
|
||||
man/man3/tdb_error.3
|
||||
man/man3/tdb_exists.3
|
||||
man/man3/tdb_fetch.3
|
||||
man/man3/tdb_firstkey.3
|
||||
man/man3/tdb_open.3
|
||||
man/man3/tdb_store.3
|
||||
man/man3/tdb_traverse.3
|
20
databases/tdb/buildlink2.mk
Normal file
20
databases/tdb/buildlink2.mk
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: buildlink2.mk,v 1.1.1.1 2002/11/29 19:19:12 jmmv Exp $
|
||||
#
|
||||
|
||||
.if !defined(TDB_BUILDLINK2_MK)
|
||||
TDB_BUILDLINK2_MK= # defined
|
||||
|
||||
BUILDLINK_PACKAGES+= tdb
|
||||
BUILDLINK_DEPENDS.tdb?= tdb>=1.0.6
|
||||
BUILDLINK_PKGSRCDIR.tdb?= ../../databases/tdb
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.tdb=tdb
|
||||
BUILDLINK_PREFIX.tdb_DEFAULT= ${LOCALBASE}
|
||||
BUILDLINK_FILES.tdb= include/tdb.h
|
||||
BUILDLINK_FILES.tdb+= lib/libtdb.*
|
||||
|
||||
BUILDLINK_TARGETS+= tdb-buildlink
|
||||
|
||||
tdb-buildlink: _BUILDLINK_USE
|
||||
|
||||
.endif # TDB_BUILDLINK2_MK
|
6
databases/tdb/distinfo
Normal file
6
databases/tdb/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/11/29 19:19:12 jmmv Exp $
|
||||
|
||||
SHA1 (tdb-1.0.6.tar.gz) = d1876522f1b8ffa8cf844a1f6605e0c32d387a7a
|
||||
Size (tdb-1.0.6.tar.gz) = 139948 bytes
|
||||
SHA1 (patch-aa) = 7af794ccbaeab55f4d44f41212ca881dd169506e
|
||||
SHA1 (patch-ab) = dbe92ea1facfb3d601a7ce1a9b7f9a25e0c879cc
|
100
databases/tdb/patches/patch-aa
Normal file
100
databases/tdb/patches/patch-aa
Normal file
|
@ -0,0 +1,100 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/11/29 19:19:12 jmmv Exp $
|
||||
|
||||
--- configure.orig Tue Dec 11 05:06:33 2001
|
||||
+++ configure
|
||||
@@ -1592,95 +1592,8 @@ else
|
||||
fi
|
||||
|
||||
|
||||
-echo $ac_n "checking for gdbm_open in -lgdbm""... $ac_c" 1>&6
|
||||
-echo "configure:1597: checking for gdbm_open in -lgdbm" >&5
|
||||
-ac_lib_var=`echo gdbm'_'gdbm_open | sed 'y%./+-%__p_%'`
|
||||
-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
- echo $ac_n "(cached) $ac_c" 1>&6
|
||||
-else
|
||||
- ac_save_LIBS="$LIBS"
|
||||
-LIBS="-lgdbm $LIBS"
|
||||
-cat > conftest.$ac_ext <<EOF
|
||||
-#line 1605 "configure"
|
||||
-#include "confdefs.h"
|
||||
-/* Override any gcc2 internal prototype to avoid an error. */
|
||||
-/* We use char because int might match the return type of a gcc2
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-char gdbm_open();
|
||||
-
|
||||
-int main() {
|
||||
-gdbm_open()
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:1616: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- eval "ac_cv_lib_$ac_lib_var=yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- eval "ac_cv_lib_$ac_lib_var=no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
-LIBS="$ac_save_LIBS"
|
||||
-
|
||||
-fi
|
||||
-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
- echo "$ac_t""yes" 1>&6
|
||||
- have_gdbm=true
|
||||
-else
|
||||
- echo "$ac_t""no" 1>&6
|
||||
have_gdbm=false
|
||||
-fi
|
||||
-
|
||||
-if test "x$have_gdbm" = "xfalse";then
|
||||
- echo "configure: warning: WARNING: tdbtest is disabled. It needs gdbm." 1>&2
|
||||
-fi
|
||||
-echo $ac_n "checking for dlopen in -ldl""... $ac_c" 1>&6
|
||||
-echo "configure:1641: checking for dlopen in -ldl" >&5
|
||||
-ac_lib_var=`echo dl'_'dlopen | sed 'y%./+-%__p_%'`
|
||||
-if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
- echo $ac_n "(cached) $ac_c" 1>&6
|
||||
-else
|
||||
- ac_save_LIBS="$LIBS"
|
||||
-LIBS="-ldl $LIBS"
|
||||
-cat > conftest.$ac_ext <<EOF
|
||||
-#line 1649 "configure"
|
||||
-#include "confdefs.h"
|
||||
-/* Override any gcc2 internal prototype to avoid an error. */
|
||||
-/* We use char because int might match the return type of a gcc2
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-char dlopen();
|
||||
-
|
||||
-int main() {
|
||||
-dlopen()
|
||||
-; return 0; }
|
||||
-EOF
|
||||
-if { (eval echo configure:1660: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
- rm -rf conftest*
|
||||
- eval "ac_cv_lib_$ac_lib_var=yes"
|
||||
-else
|
||||
- echo "configure: failed program was:" >&5
|
||||
- cat conftest.$ac_ext >&5
|
||||
- rm -rf conftest*
|
||||
- eval "ac_cv_lib_$ac_lib_var=no"
|
||||
-fi
|
||||
-rm -f conftest*
|
||||
-LIBS="$ac_save_LIBS"
|
||||
-
|
||||
-fi
|
||||
-if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
- echo "$ac_t""yes" 1>&6
|
||||
- have_dllib=true
|
||||
-else
|
||||
- echo "$ac_t""no" 1>&6
|
||||
have_dllib=false
|
||||
-fi
|
||||
-
|
||||
-if test "x$have_dllib" = "xfalse";then
|
||||
- echo "configure: warning: WARNING: tdbtorture is disabled. It needs libdl." 1>&2
|
||||
-fi
|
||||
-
|
||||
|
||||
|
||||
if $have_gdbm; then
|
32
databases/tdb/patches/patch-ab
Normal file
32
databases/tdb/patches/patch-ab
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2002/11/29 19:19:12 jmmv Exp $
|
||||
|
||||
--- Makefile.in.orig Tue Dec 11 05:08:49 2001
|
||||
+++ Makefile.in
|
||||
@@ -80,7 +80,6 @@ LDADD = libtdb.la
|
||||
@BUILD_TDBTORTURE_TRUE@TDBTORTURE = tdbtorture
|
||||
@BUILD_TDBTORTURE_FALSE@TDBTORTURE =
|
||||
|
||||
-noinst_PROGRAMS = tdbspeed tdbiterate $(TDBTEST) $(TDBTORTURE)
|
||||
bin_PROGRAMS = tdbtool tdbdump
|
||||
|
||||
lib_LTLIBRARIES = libtdb.la
|
||||
@@ -115,7 +114,7 @@ LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
libtdb_la_LIBADD =
|
||||
libtdb_la_OBJECTS = tdb.lo spinlock.lo
|
||||
-PROGRAMS = $(bin_PROGRAMS) $(noinst_PROGRAMS)
|
||||
+PROGRAMS = $(bin_PROGRAMS)
|
||||
|
||||
tdbtool_OBJECTS = tdbtool.o
|
||||
tdbtool_LDADD = $(LDADD)
|
||||
@@ -159,8 +158,8 @@ DISTFILES = $(DIST_COMMON) $(SOURCES) $(
|
||||
|
||||
TAR = tar
|
||||
GZIP_ENV = --best
|
||||
-SOURCES = $(libtdb_la_SOURCES) $(tdbtool_SOURCES) $(tdbdump_SOURCES) $(tdbspeed_SOURCES) $(tdbiterate_SOURCES) $(tdbtest_SOURCES) $(tdbtorture_SOURCES)
|
||||
-OBJECTS = $(libtdb_la_OBJECTS) $(tdbtool_OBJECTS) $(tdbdump_OBJECTS) $(tdbspeed_OBJECTS) $(tdbiterate_OBJECTS) $(tdbtest_OBJECTS) $(tdbtorture_OBJECTS)
|
||||
+SOURCES = $(libtdb_la_SOURCES) $(tdbtool_SOURCES) $(tdbdump_SOURCES)
|
||||
+OBJECTS = $(libtdb_la_OBJECTS) $(tdbtool_OBJECTS) $(tdbdump_OBJECTS)
|
||||
|
||||
all: all-redirect
|
||||
.SUFFIXES:
|
Loading…
Reference in a new issue