Changes 1.7:

- fixed config/Imakefile so 'configure' command would work
  under cygwin.  Tested clients/server under cygwin.

- corrected a possible race condition in auvoxware that could
  cause the server to hang under certain conditions.  I do not
  know why I haven't seen this problem before, but I could
  recreate it easily by killing auplay while playing a long
  tune.

  If the system restarts syscalls after a signal handler has
  run, a situation could arise where the previous timer was
  never disabled.  This could cause a previous ioctl(DSP_SYNC)
  called from setSampleRate() to be constantly interrupted and
  restarted, causing an apparent hang.

  Now we just turn off the timer as the first thing in
  setSampleRate() so DSP_SYNC can actually finish.

  We also turn off the timer when openDevice is called, so the
  'wait for device to become available' code can work too.

- Patch from Tobias Diedrich that allows mixer init to
  fail in the voxware server.

- redid the FAQ in an attempt to make it more useful.  I'll
  try to keep it up to date.

- updated libtool due to a problem(s) reported by Steve
  McIntyre.
This commit is contained in:
adam 2004-11-23 08:50:23 +00:00
parent 2ea17ce1c7
commit 11a9e22781
4 changed files with 15 additions and 16 deletions

View file

@ -1,11 +1,10 @@
# $NetBSD: Makefile,v 1.46 2004/10/28 13:38:52 wiz Exp $ # $NetBSD: Makefile,v 1.47 2004/11/23 08:50:23 adam Exp $
DISTNAME= nas-1.6.src DISTNAME= nas-1.7.src
PKGNAME= ${DISTNAME:S/.src//} PKGNAME= ${DISTNAME:S/.src//}
PKGREVISION= 3
CATEGORIES= audio CATEGORIES= audio
MASTER_SITES= http://nas.codebrilliance.com/nas/ \ MASTER_SITES= http://nas.codebrilliance.com/nas/ \
ftp://ftp.uni-duisburg.de/Sound/NAS/ \ ftp://ftp.uni-duisburg.de/Sound/NAS/
MAINTAINER= tech-pkg@NetBSD.org MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://radscan.com/nas.html HOMEPAGE= http://radscan.com/nas.html
@ -15,13 +14,12 @@ DEPENDS+= p5-perl-headers-${OS_VERSION}:../../devel/p5-perl-headers
PKG_INSTALLATION_TYPES= overwrite pkgviews PKG_INSTALLATION_TYPES= overwrite pkgviews
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV} WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
USE_BUILDLINK3= yes USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
USE_PKGINSTALL= yes USE_PKGINSTALL= yes
USE_IMAKE= yes USE_IMAKE= yes
USE_GNU_TOOLS+= make
PKG_SYSCONFSUBDIR= nas PKG_SYSCONFSUBDIR= nas
REPLACE_PERL= clients/audio/auscope/auscope REPLACE_PERL= clients/audio/auscope/auscope

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST.clients,v 1.4 2003/03/03 02:39:14 jschauma Exp $ @comment $NetBSD: PLIST.clients,v 1.5 2004/11/23 08:50:23 adam Exp $
bin/auconvert bin/auconvert
bin/auctl bin/auctl
bin/audemo bin/audemo
@ -33,6 +33,7 @@ include/audio/audiolib.h
include/audio/audioutil.h include/audio/audioutil.h
include/audio/fileutil.h include/audio/fileutil.h
include/audio/mutex.h include/audio/mutex.h
include/audio/release.h
include/audio/snd.h include/audio/snd.h
include/audio/sound.h include/audio/sound.h
include/audio/soundlib.h include/audio/soundlib.h

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.10 2003/10/28 00:49:48 grant Exp $ $NetBSD: distinfo,v 1.11 2004/11/23 08:50:23 adam Exp $
SHA1 (nas-1.6.src.tar.gz) = cba0fae4be38cdad9b84e79cbabb8cad2b44bbe0 SHA1 (nas-1.7.src.tar.gz) = a41adef84d0bf4c8e02b14d77bec0d284e7c9317
Size (nas-1.6.src.tar.gz) = 1099385 bytes Size (nas-1.7.src.tar.gz) = 1288569 bytes
SHA1 (patch-ab) = 777e5d1e9beaa1a4837a70e7dbc522eb1cb78f9c SHA1 (patch-ab) = 777e5d1e9beaa1a4837a70e7dbc522eb1cb78f9c
SHA1 (patch-ac) = 36f8ee0ec494e9d6a7994780c608c7a5fbf2114d SHA1 (patch-ac) = 36f8ee0ec494e9d6a7994780c608c7a5fbf2114d
SHA1 (patch-ad) = c8e77228282cdd4de5d9686e88a260e286c6bf80 SHA1 (patch-ad) = 5918e8188c8400fc7133c3ae4016d99c7c7594fa
SHA1 (patch-ae) = f8ec2cb1809937aa7366ab65bee294e8affce543 SHA1 (patch-ae) = f8ec2cb1809937aa7366ab65bee294e8affce543
SHA1 (patch-af) = 3dfd09dad97549c69e44aac042ed971534926cca SHA1 (patch-af) = 3dfd09dad97549c69e44aac042ed971534926cca

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.9 2002/11/28 11:40:46 markd Exp $ $NetBSD: patch-ad,v 1.10 2004/11/23 08:50:24 adam Exp $
--- server/dda/voxware/auvoxware.c.orig Thu Jul 25 12:42:28 2002 --- server/dda/voxware/auvoxware.c.orig 2004-10-22 21:44:47.000000000 +0000
+++ server/dda/voxware/auvoxware.c +++ server/dda/voxware/auvoxware.c
@@ -238,8 +238,13 @@ @@ -242,8 +242,13 @@ SndStat sndStatIn =
256, /* fragSize */ 256, /* fragSize */
3, /* minFrags */ 3, /* minFrags */
32, /* maxFrags */ 32, /* maxFrags */
@ -16,7 +16,7 @@ $NetBSD: patch-ad,v 1.9 2002/11/28 11:40:46 markd Exp $
#if defined(__CYGWIN__) #if defined(__CYGWIN__)
O_RDONLY, /* howToOpen */ O_RDONLY, /* howToOpen */
#else #else
@@ -260,7 +265,11 @@ @@ -264,7 +269,11 @@ SndStat sndStatIn =
256, /* fragSize */ 256, /* fragSize */
3, /* minFrags */ 3, /* minFrags */
32, /* maxFrags */ 32, /* maxFrags */