Update to 2.36.

Drop sed patch (applied upstream).

- 2.36 | 2012-11-22

  - portability fixes

    - import some procs explicitly (Guile 1.4.x)

	Guile 1.4.x does not implicitly provide, e.g., SRFI 13.

    - use appropriate u8 i/o procs

	The "compiler" (har har) build-aux/guile-baux/mm, in cahoots w/
	the configure script, now tries to DTRT for various versions of
	Guile.  Precisely:

	1.4.x -- custom procs based on ‘read-char’ / ‘display’
	1.8   -- uniform-vector-{read!,write} (the "normal" case)
	2.x   -- custom procs based on those in ‘(ice-9 binary-ports)’

	With this change, "make check" under Guile 2.0.6 no longer
	displays any deprecation warnings.  Any that you might encounter
	(for any Guile) is now considered a bug; please report it.

    - avoid ‘\n’ in sed ‘s’ RHS (FreeBSD)

	This was a problem in the "make check" prep (test harness).

    - less "values outside ‘call-with-values’ context"

	Another case was found, but this was internal.  Perhaps others
	lurk -- why doesn't Someone just do a formal audit already?!

  - bootstrap tools upgrade
    - GNU Automake 1.12.5
    - Guile-BAUX 20121120.1242.e233fad
This commit is contained in:
gdt 2012-11-23 01:17:40 +00:00
parent 18a48a9767
commit 11b5227af6
3 changed files with 6 additions and 28 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.31 2012/11/07 00:50:05 gdt Exp $
# $NetBSD: Makefile,v 1.32 2012/11/23 01:17:40 gdt Exp $
DISTNAME= guile-www-2.35
DISTNAME= guile-www-2.36
CATEGORIES= devel www
MASTER_SITES= http://download.savannah.nongnu.org/releases/guile-www/
EXTRACT_SUFX= .tar.xz

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.13 2012/11/21 01:49:54 gdt Exp $
$NetBSD: distinfo,v 1.14 2012/11/23 01:17:40 gdt Exp $
SHA1 (guile-www-2.35.tar.xz) = 31619996edd2dfd86286650a9db5298f579ac740
RMD160 (guile-www-2.35.tar.xz) = a75d79ae25a8dd23306a52b9bfa144a701820bd8
Size (guile-www-2.35.tar.xz) = 614004 bytes
SHA1 (patch-v_Makefile.in) = 6790ad019783b5a8c1ab7443b401fbf7f89ca2e7
SHA1 (guile-www-2.36.tar.xz) = 0cba2c7e0b31a7bcd37d5b120c4b5e782b8eb87e
RMD160 (guile-www-2.36.tar.xz) = 1286febe720fb1d4403350ec72ac2c163b281fd7
Size (guile-www-2.36.tar.xz) = 615860 bytes

View file

@ -1,21 +0,0 @@
$NetBSD: patch-v_Makefile.in,v 1.1 2012/11/21 01:49:54 gdt Exp $
guile-www assumes that sed treats \n in the RHS of a substitution as a
newline. However, POSIX says that is unspecified, and NetBSD sed treats \n
as n. Therefore, just use a space instead, as the form of whitespace does
not matter.
This was reported to the upstream author on 20121107, and is already
fixed in the upstream VCS.
--- v/Makefile.in.orig 2012-11-06 10:55:00.000000000 +0000
+++ v/Makefile.in
@@ -527,7 +527,7 @@ x000: all-modules.list
$(single): all-modules.list
@n=`echo $@ | sed 's/x0*//'` ; \
- sed -e "$${n}!d" -e 's/.*/(use-modules &)\n(exit #t)/' $< > $@
+ sed -e "$${n}!d" -e 's/.*/(use-modules &) (exit #t)/' $< > $@
clean-local:
-rm -rf all-modules.list .fake x000 $(single)