OpenOffice.org is an Open Source, community-developed, multi-platform office
productivity suite. It includes the key desktop applications, such as a word processor, spreadsheet, presentation manager, and drawing program, with a user interface and feature set similar to other office suites. This is a Linux binary version of misc/openoffice.
This commit is contained in:
parent
658a83fc72
commit
1212edb532
9 changed files with 3448 additions and 0 deletions
14
misc/openoffice-linux/DESCR
Normal file
14
misc/openoffice-linux/DESCR
Normal file
|
@ -0,0 +1,14 @@
|
|||
OpenOffice.org is an Open Source, community-developed, multi-platform office
|
||||
productivity suite. It includes the key desktop applications, such as a
|
||||
word processor, spreadsheet, presentation manager, and drawing program,
|
||||
with a user interface and feature set similar to other office suites.
|
||||
|
||||
Components include:
|
||||
* A universal word processing application for creating business
|
||||
letters, extensive text documents, professional layouts, and HTML
|
||||
documents.
|
||||
* A sophisticated application for performing advanced spreadsheet
|
||||
functions, such as analyzing figures, creating lists, and viewing data.
|
||||
* A tool for creating effective eye-catching presentations.
|
||||
* A vector-oriented draw module that enables the creation of 3D
|
||||
illustrations.
|
13
misc/openoffice-linux/MESSAGE
Normal file
13
misc/openoffice-linux/MESSAGE
Normal file
|
@ -0,0 +1,13 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2003/01/22 21:57:25 mrauch Exp $
|
||||
|
||||
OpenOffice has now been installed in ${PREFIX}/OpenOffice.org1.0.2.
|
||||
|
||||
Before you are able to use this package, on NetBSD the file
|
||||
/emul/linux/etc/mtab must exist, i.e. run
|
||||
"touch /emul/linux/etc/mtab" as root.
|
||||
|
||||
Additionally, each user has to run a setup program first, which is
|
||||
automatically invoked at the first start. Thereafter, OpenOffice can be
|
||||
started using the ${PREFIX}/bin/soffice command.
|
||||
===========================================================================
|
68
misc/openoffice-linux/Makefile
Normal file
68
misc/openoffice-linux/Makefile
Normal file
|
@ -0,0 +1,68 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/01/22 21:57:25 mrauch Exp $
|
||||
|
||||
DISTNAME= OOo_1.0.2_LinuxIntel_install
|
||||
PKGNAME= openoffice-linux-1.0.2
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= http://sf1.mirror.openoffice.org/stable/1.0.2/ \
|
||||
http://www.fs.tum.de/~mrauch/OpenOffice/download/
|
||||
|
||||
MAINTAINER= mrauch@netbsd.org
|
||||
HOMEPAGE= http://www.openoffice.org/
|
||||
COMMENT= Integrated office productivity suite (binary pkg)
|
||||
|
||||
NO_CONFIGURE= # defined
|
||||
WRKSRC= ${WRKDIR}/install/
|
||||
|
||||
CONFLICTS= staroffice-[0-9]* openoffice-[0-9]*
|
||||
|
||||
ONLY_FOR_PLATFORM= NetBSD-1.[6-9]*-i386 NetBSD-[2-9]*-i386
|
||||
|
||||
TEMP?= ${WRKSRC}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
DISPLAY?= #empty, if unset
|
||||
checkforx:
|
||||
.if ${DISPLAY}=="" || ${DISPLAY_OK:!${X11BASE}/bin/xdpyinfo >/dev/null 2>&1 && ${ECHO} YES || ${ECHO} NO!} == "NO"
|
||||
. if exists(${X11BASE}/bin/Xvfb)
|
||||
-${X11BASE}/bin/Xvfb :2 &
|
||||
DISPLAY= ':2'
|
||||
. else
|
||||
@${ECHO} "Error: Environment variable DISPLAY must be set"
|
||||
@${ECHO} " and point to a connectible X server."
|
||||
@${FALSE}
|
||||
. endif #Xvfb
|
||||
.endif #DISPLAY
|
||||
|
||||
do-build:
|
||||
|
||||
pre-install: checkforx
|
||||
${SH} -c "cd ${WRKSRC}; \
|
||||
${SED} -e 's#@@PREFIX@@#${PREFIX}#g' \
|
||||
<${FILESDIR}/oo_setup.resp \
|
||||
>oo_setup.resp"
|
||||
|
||||
do-install:
|
||||
-${SH} -c "cd ${WRKSRC}; \
|
||||
TEMP=${WRKSRC}; export TEMP; \
|
||||
DISPLAY=${DISPLAY}; export DISPLAY; \
|
||||
./setup -r:oo_setup.resp"
|
||||
@${SH} -c "if ! [ -x ${PREFIX}/OpenOffice.org1.0.2/setup ] ; \
|
||||
then ${ECHO} 'Installation was not successful.'; \
|
||||
${FALSE}; fi"
|
||||
${SED} -e 's#@@PREFIX@@#${PREFIX}#g' \
|
||||
<${FILESDIR}/soffice >${PREFIX}/bin/soffice
|
||||
${CHMOD} +x ${PREFIX}/bin/soffice
|
||||
${PATCH} -t -s ${PREFIX}/OpenOffice.org1.0.2/program/soffice \
|
||||
<${FILESDIR}/soffice.test.patch
|
||||
|
||||
# everything specific to your OS/Arch goes into it's own Makefile
|
||||
# group together i386, i486, i586 and i686 (for Linux)
|
||||
ARCH=${MACHINE_ARCH:C/i[3-6]86/i386/g}
|
||||
|
||||
.if exists(Makefile.${OPSYS}.${ARCH})
|
||||
. include "Makefile.${OPSYS}.${ARCH}"
|
||||
.else
|
||||
. include "../../mk/bsd.pkg.mk"
|
||||
.endif
|
||||
|
6
misc/openoffice-linux/Makefile.NetBSD.i386
Normal file
6
misc/openoffice-linux/Makefile.NetBSD.i386
Normal file
|
@ -0,0 +1,6 @@
|
|||
# $NetBSD: Makefile.NetBSD.i386,v 1.1.1.1 2003/01/22 21:57:53 mrauch Exp $
|
||||
|
||||
DEPENDS+= suse_compat>=7.3:../../emulators/${SUSE_DIR_PREFIX}_compat
|
||||
DEPENDS+= suse_x11>=7.3:../../emulators/${SUSE_DIR_PREFIX}_x11
|
||||
|
||||
.include "../../emulators/suse_linux/Makefile.application"
|
3278
misc/openoffice-linux/PLIST
Normal file
3278
misc/openoffice-linux/PLIST
Normal file
File diff suppressed because it is too large
Load diff
4
misc/openoffice-linux/distinfo
Normal file
4
misc/openoffice-linux/distinfo
Normal file
|
@ -0,0 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/01/22 21:57:25 mrauch Exp $
|
||||
|
||||
SHA1 (OOo_1.0.2_LinuxIntel_install.tar.gz) = 265dde9bb77266461d37b945388cd35edb7296cc
|
||||
Size (OOo_1.0.2_LinuxIntel_install.tar.gz) = 72667992 bytes
|
8
misc/openoffice-linux/files/oo_setup.resp
Normal file
8
misc/openoffice-linux/files/oo_setup.resp
Normal file
|
@ -0,0 +1,8 @@
|
|||
[Environment]
|
||||
InstallationMode = INSTALL_NETWORK
|
||||
InstallationType = STANDARD
|
||||
DestinationPath = @@PREFIX@@/OpenOffice.org1.0.2
|
||||
|
||||
[Java]
|
||||
JavaSupport = preinstalled_or_none
|
||||
|
45
misc/openoffice-linux/files/soffice
Executable file
45
misc/openoffice-linux/files/soffice
Executable file
|
@ -0,0 +1,45 @@
|
|||
#!/bin/sh
|
||||
#
|
||||
# $NetBSD: soffice,v 1.1.1.1 2003/01/22 21:57:53 mrauch Exp $
|
||||
#
|
||||
SOINST=@@PREFIX@@/OpenOffice.org1.0.2
|
||||
[ "$SOFFICE" = "" ] && SOFFICE=$HOME/OpenOffice.org1.0.2
|
||||
|
||||
if [ `uname -s`=="NetBSD" -a ! -r /emul/linux/etc/mtab ]; then
|
||||
echo 'ERROR: Before you are able to use this package, the file'
|
||||
echo ' /emul/linux/etc/mtab must exist.'
|
||||
echo ' Ask your system administrator to create this file,'
|
||||
echo ' e.g. by running "touch /emul/linux/etc/mtab".'
|
||||
exit 1
|
||||
fi
|
||||
|
||||
if [ ! -d "$SOFFICE" ]; then
|
||||
echo ""
|
||||
echo "-----------------------------------------------------------------"
|
||||
echo " OpenOffice has not yet been set up for `whoami`."
|
||||
echo " Starting setup ... "
|
||||
echo ""
|
||||
echo " (If OpenOffice has already been set up for `whoami` or you"
|
||||
echo " want to install it someplace other than $SOFFICE"
|
||||
echo " please abort the installation procedure now, set the \$SOFFICE "
|
||||
echo " environment variable accordingly and rerun $0.)"
|
||||
echo "-----------------------------------------------------------------"
|
||||
echo ""
|
||||
|
||||
# add an eventually existing java directory to $PATH to allow OO to
|
||||
# automatically find it
|
||||
export PATH=$PATH:@@PREFIX@@/java/bin
|
||||
|
||||
cd $SOINST
|
||||
./setup
|
||||
|
||||
echo ""
|
||||
echo "Done. Starting OpenOffice ..."
|
||||
echo ""
|
||||
fi
|
||||
|
||||
# We've got a large number of shared libraries and other single files which
|
||||
# have to be open for normal operation
|
||||
ulimit -n 1024
|
||||
|
||||
exec ${SOFFICE}/soffice $*
|
12
misc/openoffice-linux/files/soffice.test.patch
Normal file
12
misc/openoffice-linux/files/soffice.test.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: soffice.test.patch,v 1.1.1.1 2003/01/22 21:57:53 mrauch Exp $
|
||||
|
||||
--- soffice.old Tue Jan 21 23:24:27 2003
|
||||
+++ soffice.new Tue Jan 21 23:24:21 2003
|
||||
@@ -82,6 +82,7 @@
|
||||
case $sd_platform in
|
||||
SCO_SV) test=/bin/test ;;
|
||||
FreeBSD) test=/bin/test ;;
|
||||
+ NetBSD) test=/bin/test ;;
|
||||
*) test=/usr/bin/test ;;
|
||||
esac
|
||||
|
Loading…
Reference in a new issue