Update librsvg2 and librsvg2-gtk2 to 2.9.5:
2005-01-13 Dom Lachowicz <cinamod@hotmail.com> * rsvg.c: bug 163886/163947, from John Spray <jcs116@york.ac.uk> 2005-01-11 Dom Lachowicz <cinamod@hotmail.com> * configure.in: Install gtk docs in a standard place that devhelp knows about. From Stephane LOEUILLET <LeRoutier@leroutier.net> 2004-12-22 Dom Lachowicz <cinamod@hotmail.com> * moz-plugin/moz-plugin.c: Fix bug #161823 * Makefile.am: bug #158897, from <kou@cozmixng.org> 2004-11-29 Caleb Moore <c.moore@student.unsw.edu.au> * rsvg-shapes.c: made markers work again and inherit from the context that they were specified in, not where they were invoked. 2004-11-18 Dom Lachowicz <cinamod@hotmail.com> * test-display.c: rsvg-view now can optionally use the new GtkFileChooser instead of GtkFileSelection, depending on whether you have GTK 2.4 installed or not. 2004-11-17 Dom Lachowicz <cinamod@hotmail.com> * rsvg-file-util.c: RSVG's convenience API should now be able to transparently handle remote files via gnome-vfs, if available. * rsvg.c: Some Win32/Unix path portability changes 2004-11-17 Caleb Moore <c.moore@student.unsw.edu.au> * rsvg-defs.c: Interfile vfs linking now implemented. Utility api automatically gives contextual information. 2004-11-17 Dom Lachowicz <cinamod@hotmail.com> * rsvg-shapes.c: Refactored the image downloading code into a generic xlink:href downloading code. Caleb can now use this for linking. 2004-11-17 Caleb Moore <c.moore@student.unsw.edu.au> * rsvg-defs.c: Interfile linking now implemented. Can't yet use gnome-vfs 2004-11-17 Caleb Moore <c.moore@student.unsw.edu.au> * everywhere: split RsvgHandle into two parts. * rsvg.c: made the image be rendered when get_pixbuf is actually called. * rsvg-text.c: Large number of text improvements: formatting, alignment, whitespace handling and styling. * everywhere: Number if inheritance fixes * rsvg-pservers.c: made current-color determined by context * rsvg-private.h, rsvg.c: handle percentage widths more accurately (based on viewbox) 2004-10-20 Caleb Moore <c.moore@student.unsw.edu.au> * rsvg-defs.c: fixed memleak opened yesterday 2004-10-19 Caleb Moore <c.moore@student.unsw.edu.au> * rsvg-defs.c: stopped passing the hash table a destroy function 2004-10-15 Dom Lachowicz <cinamod@hotmail.com> * Makefile.am: bug 155530, ckelso@heliosphere.org (Chris Kelso) 2004-10-14 Dom Lachowicz <cinamod@hotmail.com> * rsvg.c: Push gnome_vfs_init() up to rsvg_init() * rsvg-shapes.c: ditto, bug #155433 2004-09-29 Dom Lachowicz <cinamod@hotmail.com> * moz-plugin/moz-plugin.c: Fix bug #154083 2004-09-26 Dom Lachowicz <cinamod@hotmail.com> * gdk-pixbuf-loader/io-svg.c: Sanity checks 2004-09-25 Dom Lachowicz <cinamod@hotmail.com> * rsvg.c Part of bug 153671 * *.c: Prepare for some gettext lovin' 2004-09-23 Caleb Moore <c.moore@student.unsw.edu.au> * rsvg-shapes.c, rsvg-paint-server.c: Made objectBoundingBox for pservers to be calculated in user coordinates instead of pixel coordinates, this allows for rotation and stuff.
This commit is contained in:
parent
e9259fdc12
commit
1225f19c14
9 changed files with 70 additions and 50 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.10 2004/10/03 00:14:55 tv Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2005/03/22 16:04:44 jmmv Exp $
|
||||
#
|
||||
|
||||
.include "../../graphics/librsvg2/Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/-/2-gtk2-/}
|
||||
PKGREVISION= 1
|
||||
COMMENT+= (GTK2 modules)
|
||||
|
||||
CONFIGURE_ARGS+= --enable-pixbuf-loader
|
||||
|
|
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.32 2004/12/05 23:26:16 recht Exp $
|
||||
# $NetBSD: Makefile,v 1.33 2005/03/22 16:04:44 jmmv Exp $
|
||||
#
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/-/2-/}
|
||||
PKGREVISION= 1
|
||||
|
||||
USE_DIRS+= xdg-1.1
|
||||
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile.common,v 1.8 2004/09/21 16:51:01 jmmv Exp $
|
||||
# $NetBSD: Makefile.common,v 1.9 2005/03/22 16:04:44 jmmv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= librsvg-2.8.1
|
||||
DISTNAME= librsvg-2.9.5
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/librsvg/2.8/}
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/librsvg/2.9/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= jmmv@NetBSD.org
|
||||
|
@ -19,6 +19,7 @@ USE_LIBTOOL= YES
|
|||
GNU_CONFIGURE= YES
|
||||
PKGCONFIG_OVERRIDE= librsvg-2.0.pc.in
|
||||
|
||||
CONFIGURE_ARGS+= --disable-gnome-vfs
|
||||
CONFIGURE_ARGS+= --disable-gtk-doc
|
||||
CONFIGURE_ARGS+= --with-gimp=no
|
||||
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc/librsvg2
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.9 2004/09/22 08:09:36 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.10 2005/03/22 16:04:44 jmmv Exp $
|
||||
bin/rsvg
|
||||
bin/rsvg-view
|
||||
include/librsvg-2/librsvg/librsvg-enum-types.h
|
||||
include/librsvg-2/librsvg/librsvg-features.h
|
||||
include/librsvg-2/librsvg/rsvg-gz.h
|
||||
include/librsvg-2/librsvg/rsvg.h
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.10 2005/02/24 08:45:09 agc Exp $
|
||||
$NetBSD: distinfo,v 1.11 2005/03/22 16:04:44 jmmv Exp $
|
||||
|
||||
SHA1 (librsvg-2.8.1.tar.bz2) = 483c760e8300f504506af31accbf03c113b2854a
|
||||
RMD160 (librsvg-2.8.1.tar.bz2) = b5c4613a0b51268350ecfd35786feb712130af90
|
||||
Size (librsvg-2.8.1.tar.bz2) = 361446 bytes
|
||||
SHA1 (patch-ab) = 0def1d4342c6ca4e99ea0acc8a9d2987799d1527
|
||||
SHA1 (patch-ac) = 7a04dd7c01a6adeb2de18d7a67ab2790c6392f9f
|
||||
SHA1 (patch-ad) = 70a8bcd0fdd644ea20af53ca78e5ac4eee67a4e3
|
||||
SHA1 (librsvg-2.9.5.tar.bz2) = 502338a1b42ec36fbca895b97a166e398e7e3018
|
||||
RMD160 (librsvg-2.9.5.tar.bz2) = 5c7d6ad1a543b4880d7c3bb02da7126ed9f5aa5e
|
||||
Size (librsvg-2.9.5.tar.bz2) = 392785 bytes
|
||||
SHA1 (patch-aa) = 9079ddca49e8aa3618d73aa781a5282dd9e819ed
|
||||
SHA1 (patch-ab) = 6f6d376192e6cf2f8c223be2270cbb932173449a
|
||||
SHA1 (patch-ac) = 11939435e00f04b58412b3d769297caa9ee585b9
|
||||
SHA1 (patch-ad) = e72e1e884a366199be9feeacde05815627393f1f
|
||||
|
|
20
graphics/librsvg2/patches/patch-aa
Normal file
20
graphics/librsvg2/patches/patch-aa
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-aa,v 1.6 2005/03/22 16:04:44 jmmv Exp $
|
||||
|
||||
--- configure.orig 2005-01-19 02:14:43.000000000 +0100
|
||||
+++ configure
|
||||
@@ -21874,6 +21874,7 @@ echo "${ECHO_T}$GNOME_PRINT_LIBS" >&6
|
||||
\
|
||||
have_gnome_print=no
|
||||
fi
|
||||
+ have_gnome_print=no
|
||||
|
||||
|
||||
if test "x$have_gnome_print" = "xyes"; then
|
||||
@@ -23633,6 +23634,7 @@ build_mozilla_plugin=no
|
||||
if test "x$MOZILLA_CFLAGS" != "x"; then
|
||||
build_mozilla_plugin=yes
|
||||
fi
|
||||
+build_mozilla_plugin=no
|
||||
|
||||
|
||||
if test "x$build_mozilla_plugin" = "xyes"; then
|
|
@ -1,26 +1,26 @@
|
|||
$NetBSD: patch-ab,v 1.4 2004/09/21 16:51:01 jmmv Exp $
|
||||
$NetBSD: patch-ab,v 1.5 2005/03/22 16:04:44 jmmv Exp $
|
||||
|
||||
--- gdk-pixbuf-loader/Makefile.in.orig 2004-09-12 21:16:37.000000000 +0200
|
||||
--- gdk-pixbuf-loader/Makefile.in.orig 2005-01-19 02:14:41.000000000 +0100
|
||||
+++ gdk-pixbuf-loader/Makefile.in
|
||||
@@ -52,7 +52,7 @@ LTLIBRARIES = $(loader_LTLIBRARIES)
|
||||
am__DEPENDENCIES_1 =
|
||||
svg_loader_la_DEPENDENCIES = $(am__DEPENDENCIES_1) \
|
||||
$(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
||||
- $(am__DEPENDENCIES_1) $(top_builddir)/librsvg-2.la
|
||||
+ $(am__DEPENDENCIES_1)
|
||||
am_svg_loader_la_OBJECTS = io-svg.lo
|
||||
svg_loader_la_OBJECTS = $(am_svg_loader_la_OBJECTS)
|
||||
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
|
||||
@@ -252,7 +252,7 @@ svg_loader_la_LDFLAGS = -avoid-version -
|
||||
@@ -220,7 +220,7 @@ svg_loader_la_LDFLAGS = -avoid-version -
|
||||
svg_loader_la_LIBADD = $(LIBRSVG_LIBS) \
|
||||
$(LIBGNOME_VFS_LIBS) \
|
||||
$(LIBGSF_LIBS) $(LIBCROCO_LIBS) \
|
||||
- $(top_builddir)/librsvg-2.la
|
||||
+ `pkg-config --libs librsvg-2.0`
|
||||
|
||||
|
||||
loader_LTLIBRARIES = $(target_pixbuf_loader)
|
||||
all: all-am
|
||||
@@ -534,10 +534,6 @@ uninstall-am: uninstall-info-am uninstal
|
||||
@@ -231,7 +231,7 @@ CONFIG_HEADER = $(top_builddir)/config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
LTLIBRARIES = $(loader_LTLIBRARIES)
|
||||
|
||||
-svg_loader_la_DEPENDENCIES = $(top_builddir)/librsvg-2.la
|
||||
+svg_loader_la_DEPENDENCIES =
|
||||
am_svg_loader_la_OBJECTS = io-svg.lo
|
||||
svg_loader_la_OBJECTS = $(am_svg_loader_la_OBJECTS)
|
||||
|
||||
@@ -522,10 +522,6 @@ uninstall-am: uninstall-info-am uninstal
|
||||
|
||||
|
||||
install-data-hook:
|
||||
|
|
|
@ -1,13 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.5 2004/09/21 16:51:01 jmmv Exp $
|
||||
$NetBSD: patch-ac,v 1.6 2005/03/22 16:04:44 jmmv Exp $
|
||||
|
||||
--- Makefile.in.orig 2004-09-12 21:16:35.000000000 +0200
|
||||
--- Makefile.in.orig 2005-01-19 02:14:40.000000000 +0100
|
||||
+++ Makefile.in
|
||||
@@ -307,7 +307,7 @@ sbindir = @sbindir@
|
||||
@@ -199,7 +199,7 @@ sbindir = @sbindir@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
sysconfdir = @sysconfdir@
|
||||
target_alias = @target_alias@
|
||||
-SUBDIRS = . gtk-engine gdk-pixbuf-loader moz-plugin doc data
|
||||
+SUBDIRS = . gdk-pixbuf-loader doc data
|
||||
@HAVE_GTK_FALSE@target_rsvg_view =
|
||||
|
||||
@HAVE_GTK_TRUE@target_rsvg_view = rsvg-view
|
||||
man_MANS = rsvg.1
|
||||
@HAVE_GTK_FALSE@target_rsvg_view =
|
||||
|
|
|
@ -1,23 +1,22 @@
|
|||
$NetBSD: patch-ad,v 1.2 2004/09/21 16:51:01 jmmv Exp $
|
||||
$NetBSD: patch-ad,v 1.3 2005/03/22 16:04:44 jmmv Exp $
|
||||
|
||||
--- gtk-engine/Makefile.in.orig 2004-09-12 21:16:38.000000000 +0200
|
||||
--- gtk-engine/Makefile.in.orig 2005-01-19 02:14:41.000000000 +0100
|
||||
+++ gtk-engine/Makefile.in
|
||||
@@ -51,8 +51,7 @@ engineLTLIBRARIES_INSTALL = $(INSTALL)
|
||||
LTLIBRARIES = $(engine_LTLIBRARIES)
|
||||
am__DEPENDENCIES_1 =
|
||||
libsvg_la_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
||||
- $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
|
||||
- $(top_builddir)/librsvg-2.la
|
||||
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1)
|
||||
am_libsvg_la_OBJECTS = svg-draw.lo svg-main.lo svg-render.lo \
|
||||
svg-rc-style.lo
|
||||
libsvg_la_OBJECTS = $(am_libsvg_la_OBJECTS)
|
||||
@@ -266,7 +265,7 @@ libsvg_la_SOURCES = \
|
||||
svg.h
|
||||
@@ -226,7 +226,7 @@ libsvg_la_SOURCES = \
|
||||
|
||||
|
||||
libsvg_la_LDFLAGS = -avoid-version -module $(no_undefined)
|
||||
-libsvg_la_LIBADD = $(GTK_LIBS) $(LIBRSVG_LIBS) $(LIBGNOME_VFS_LIBS) $(LIBCROCO_LIBS) $(top_builddir)/librsvg-2.la
|
||||
+libsvg_la_LIBADD = $(GTK_LIBS) $(LIBRSVG_LIBS) $(LIBGNOME_VFS_LIBS) $(LIBCROCO_LIBS) `pkg-config --libs librsvg-2.0`
|
||||
EXTRA_DIST = $(libsvg_la_SOURCES)
|
||||
all: all-recursive
|
||||
|
||||
EXTRA_DIST = $(libsvg_la_SOURCES)
|
||||
subdir = gtk-engine
|
||||
@@ -236,7 +236,7 @@ CONFIG_HEADER = $(top_builddir)/config.h
|
||||
CONFIG_CLEAN_FILES =
|
||||
LTLIBRARIES = $(engine_LTLIBRARIES)
|
||||
|
||||
-libsvg_la_DEPENDENCIES = $(top_builddir)/librsvg-2.la
|
||||
+libsvg_la_DEPENDENCIES =
|
||||
am_libsvg_la_OBJECTS = svg-draw.lo svg-main.lo svg-render.lo \
|
||||
svg-rc-style.lo
|
||||
libsvg_la_OBJECTS = $(am_libsvg_la_OBJECTS)
|
||||
|
|
Loading…
Reference in a new issue