fixes again, for the case pkgsrc openssl is prefered than builtin old openssl.

This commit is contained in:
obache 2014-05-10 04:32:36 +00:00
parent c4f9650db1
commit 122d4988ab
4 changed files with 24 additions and 6 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.13 2014/05/09 16:33:29 adam Exp $
$NetBSD: distinfo,v 1.14 2014/05/10 04:32:36 obache Exp $
SHA1 (Python-3.3.5.tar.xz) = 6683b26dd2cfd23af852abfcf1aedf25bbd44839
RMD160 (Python-3.3.5.tar.xz) = 77398ecd76824983ad92c859f633e26675bacb4b
@ -8,7 +8,7 @@ SHA1 (patch-aa) = 99ebcbbfc53b855a32b424dec27012e1e969c3d0
SHA1 (patch-ab) = 1c0a25bf7ec6ee76e84c799619ec7cd8910f16e1
SHA1 (patch-ah) = bb43aaab260935a5a0d5e7ce1ccc30f4832cab1d
SHA1 (patch-al) = e5438d1bbc20cc85521b3570710846cf4a070ae1
SHA1 (patch-am) = 7e963abceccdadb43c33ebc12191c65e811a65fa
SHA1 (patch-am) = fa84fd7eddd61dca4805325576c713c1bccd27f5
SHA1 (patch-an) = 933acde107b735931d26ace4eef251000b9f07ba
SHA1 (patch-ao) = dc524b08634c23c25227bd03e221dab0ff2a03f3
SHA1 (patch-au) = c892f1004eb32e9608f93c08ec6f94e16bdca182

View file

@ -1,4 +1,4 @@
$NetBSD: patch-am,v 1.7 2014/05/09 16:33:29 adam Exp $
$NetBSD: patch-am,v 1.8 2014/05/10 04:32:36 obache Exp $
--- setup.py.orig 2014-03-09 08:40:35.000000000 +0000
+++ setup.py
@ -58,6 +58,15 @@ $NetBSD: patch-am,v 1.7 2014/05/09 16:33:29 adam Exp $
if (ssl_incs is not None and
ssl_libs is not None):
@@ -774,7 +772,7 @@ class PyBuildExt(build_ext):
# look for the openssl version header on the compiler search path.
opensslv_h = find_file('openssl/opensslv.h', [],
- inc_dirs + search_for_ssl_incs_in)
+ search_for_ssl_incs_in + inc_dirs)
if opensslv_h:
name = os.path.join(opensslv_h[0], 'openssl/opensslv.h')
if host_platform == 'darwin' and is_macosx_sdk_path(name):
@@ -1138,6 +1136,30 @@ class PyBuildExt(build_ext):
dbm_order = ['gdbm']
# The standard Unix dbm module:

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2014/05/09 16:33:56 adam Exp $
$NetBSD: distinfo,v 1.5 2014/05/10 04:35:55 obache Exp $
SHA1 (Python-3.4.0.tar.xz) = f54d7cf6af5dbd9bddbe31cf4772f39711381dbe
RMD160 (Python-3.4.0.tar.xz) = f6b4664a4333a2010f8e168e252de7c22013e4a8
@ -7,7 +7,7 @@ SHA1 (patch-Lib_distutils_unixccompiler.py) = 39cb8d1e1e3e76e2b6b5dbc1a6b5e08153
SHA1 (patch-aa) = 14359f8d0527eff08073c0aea60dfe8961d9255d
SHA1 (patch-ah) = b3a1363f6d210f855f3769650e3891b0df5c531d
SHA1 (patch-al) = 0944fb5b807985723070ac44358505c3053f9997
SHA1 (patch-am) = 93bc44af2ae5a477c73adc49600280fd07014bd8
SHA1 (patch-am) = 3ccd51ecd8cae9577c66e4936fda5ac615223da6
SHA1 (patch-an) = c9b571eb54fdf0b1e93524a6de6780e8c4119221
SHA1 (patch-ao) = bc7bb76ca7b3b8302dd966fad85171236c1f06e6
SHA1 (patch-au) = 6e10e6fc484317447bdeaa833db5df073df98c5b

View file

@ -1,4 +1,4 @@
$NetBSD: patch-am,v 1.3 2014/05/09 16:33:56 adam Exp $
$NetBSD: patch-am,v 1.4 2014/05/10 04:35:55 obache Exp $
--- setup.py.orig 2014-03-17 02:31:31.000000000 +0000
+++ setup.py
@ -58,6 +58,15 @@ $NetBSD: patch-am,v 1.3 2014/05/09 16:33:56 adam Exp $
if (ssl_incs is not None and
ssl_libs is not None):
@@ -784,7 +782,7 @@ class PyBuildExt(build_ext):
# look for the openssl version header on the compiler search path.
opensslv_h = find_file('openssl/opensslv.h', [],
- inc_dirs + search_for_ssl_incs_in)
+ search_for_ssl_incs_in, + inc_dirs)
if opensslv_h:
name = os.path.join(opensslv_h[0], 'openssl/opensslv.h')
if host_platform == 'darwin' and is_macosx_sdk_path(name):
@@ -1148,6 +1146,30 @@ class PyBuildExt(build_ext):
dbm_order = ['gdbm']
# The standard Unix dbm module: