Update to 1.9.19. Notable changes:

- Rip out support for %latex2rtf: as a way of controlling parser.
- Initial code to support the pstricks-add package.
- Change how \, is translated.  Make it a small non-breaking space.
- Eliminate long-standing bug with spurious spaces before a paragraph.
This commit is contained in:
shattered 2012-10-16 17:23:33 +00:00
parent 8a36690d89
commit 124fe9d8f7
4 changed files with 17 additions and 17 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.23 2012/10/03 21:54:07 wiz Exp $
# $NetBSD: Makefile,v 1.24 2012/10/16 17:23:33 shattered Exp $
#
DISTNAME= latex2rtf-1.9.16a
PKGREVISION= 1
CATEGORIES= print
DISTNAME= latex2rtf-1.9.19
CATEGORIES= print converters textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=latex2rtf/} \
${MASTER_SITE_TEX_CTAN:=support/latex2rtf/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2009/06/14 17:39:09 joerg Exp $
@comment $NetBSD: PLIST,v 1.8 2012/10/16 17:23:33 shattered Exp $
bin/latex2png
bin/latex2rtf
info/latex2rtf.info
@ -46,6 +46,7 @@ share/latex2rtf/cfg/spanish.cfg
share/latex2rtf/cfg/style.cfg
share/latex2rtf/cfg/swedish.cfg
share/latex2rtf/cfg/turkish.cfg
share/latex2rtf/cfg/ukrainian.cfg
share/latex2rtf/cfg/usorbian.cfg
share/latex2rtf/cfg/welsh.cfg
share/doc/latex2rtf/latex2rtf.html

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.8 2009/12/17 21:56:22 abs Exp $
$NetBSD: distinfo,v 1.9 2012/10/16 17:23:33 shattered Exp $
SHA1 (latex2rtf-1.9.16a.tar.gz) = e4f522d600b0386fa544f0fe59a7024325d0b567
RMD160 (latex2rtf-1.9.16a.tar.gz) = 0bea62eafdbd6c240d76e3d7d6bac5cf7a14f8fe
Size (latex2rtf-1.9.16a.tar.gz) = 633884 bytes
SHA1 (patch-aa) = 5a8d2471631abc33e3e9668f96128f8b4fb02483
SHA1 (latex2rtf-1.9.19.tar.gz) = e6a97b18d605326691a0094704678e5a9d42fbb7
RMD160 (latex2rtf-1.9.19.tar.gz) = 00f5275153766ef3d81f4e5ef604d40de356ea14
Size (latex2rtf-1.9.19.tar.gz) = 1151240 bytes
SHA1 (patch-aa) = 8ce5846071fb623f7f645308206361fd6f49c41f

View file

@ -1,24 +1,24 @@
$NetBSD: patch-aa,v 1.6 2009/12/17 21:56:22 abs Exp $
$NetBSD: patch-aa,v 1.7 2012/10/16 17:23:33 shattered Exp $
--- Makefile.orig 2004-11-08 02:59:18.000000000 +0000
--- Makefile.orig 2007-11-18 06:10:57.000000000 +0000
+++ Makefile
@@ -2,3 +2,3 @@
-CC=gcc
+CC?=gcc
MKDIR=mkdir -p
@@ -20,3 +20,3 @@ CFLAGS:=-DUNIX
@@ -25,3 +25,3 @@ LINK_FLAGS = -lm
#Base directory - adapt as needed
-PREFIX=$(PREFIX_DRIVE)/usr/local
+PREFIX?=$(PREFIX_DRIVE)/usr/local
@@ -27,3 +27,3 @@ BINARY_NAME=latex2rtf$(EXE_SUFFIX)
@@ -32,3 +32,3 @@ BINARY_NAME=latex2rtf$(EXE_SUFFIX)
BIN_INSTALL=$(PREFIX)/bin
-MAN_INSTALL=$(PREFIX)/man/man1
+MAN_INSTALL=$(PREFIX)/$(PKGMANDIR)/man1
INFO_INSTALL=$(PREFIX)/info
@@ -170,13 +170,13 @@ doc: doc/latex2rtf.texi doc/Makefile
install: latex2rtf doc/latex2rtf.1 $(CFGS) scripts/latex2png
@@ -205,13 +205,13 @@ install: latex2rtf doc/latex2rtf.1 $(CFG
cd doc && $(MAKE)
- $(MKDIR) $(BIN_INSTALL)
- $(MKDIR) $(MAN_INSTALL)
- $(MKDIR) $(CFG_INSTALL)
@ -42,7 +42,7 @@ $NetBSD: patch-aa,v 1.6 2009/12/17 21:56:22 abs Exp $
+ cp doc/latex2rtf.pdf $(DESTDIR)$(PREFIX)/share/doc/latex2rtf
+# cp doc/latex2rtf.txt $(DESTDIR)$(SUPPORT_INSTALL)
@echo "******************************************************************"
@@ -197,5 +197,5 @@ install: latex2rtf doc/latex2rtf.1 $(CFG
@@ -232,5 +232,5 @@ install: latex2rtf doc/latex2rtf.1 $(CFG
install-info: doc/latex2rtf.info
- $(MKDIR) $(INFO_INSTALL)
- cp doc/latex2rtf.info $(INFO_INSTALL)