Don't bail out with Clang due to a unused private member. Fix infinite

loop. bump revision.
This commit is contained in:
joerg 2013-09-17 21:09:50 +00:00
parent a875b94ed2
commit 1261afb9ce
3 changed files with 23 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2013/09/17 11:58:57 fhajny Exp $
# $NetBSD: Makefile,v 1.24 2013/09/17 21:09:50 joerg Exp $
#
DISTNAME= rudiments-0.42
@ -17,6 +17,11 @@ USE_LANGUAGES= c c++
USE_LIBTOOL= YES
USE_PKGLOCALEDIR= YES
.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Mclang)
_WRAP_EXTRA_ARGS.CXX+= -Wno-error=unused-private-field
.endif
.include "../../devel/pcre/buildlink3.mk"
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.9 2013/09/17 11:58:57 fhajny Exp $
$NetBSD: distinfo,v 1.10 2013/09/17 21:09:50 joerg Exp $
SHA1 (rudiments-0.42.tar.gz) = 136faa5186d052dccb6616dbe40e5e10a52c0ffb
RMD160 (rudiments-0.42.tar.gz) = 46aa5d06d63faa8fb7319fd73d28c71f2dea3dc0
@ -6,3 +6,4 @@ Size (rudiments-0.42.tar.gz) = 1488133 bytes
SHA1 (patch-aa) = b3a49dd56808843d0e995a5c45df236abeb4c7d3
SHA1 (patch-include_rudiments_private_clientsocket.h) = bfc239e4eb5ca79c01e3a17837443ea329dd9d80
SHA1 (patch-src_charstring.cpp) = b385472b2340abd8090d75df9b272e6f1564061a
SHA1 (patch-src_xmldomnode.cpp) = 51fdc1a6a2fd5a23ee0a673d06d2bd4384b22780

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_xmldomnode.cpp,v 1.1 2013/09/17 21:09:50 joerg Exp $
Avoid infinite loop.
--- src/xmldomnode.cpp.orig 2013-09-17 20:33:44.000000000 +0000
+++ src/xmldomnode.cpp
@@ -707,7 +707,7 @@ stringbuffer *xmldomnode::getPath() cons
const char **names=new const char *[ancestors];
uint64_t *indices=new uint64_t[ancestors];
node=this;
- for (uint64_t index=ancestors-1; index>=0; index--) {
+ for (uint64_t index=ancestors; index-->0;) {
// get the name
names[index]=node->getName();