On Interix, use waitpid(-1, status, options) instead of

wait3(status, options, NULL).
This commit is contained in:
minskim 2004-08-21 05:50:44 +00:00
parent 088679d3e7
commit 1285f3b89d
2 changed files with 18 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.9 2003/11/27 16:19:22 recht Exp $
$NetBSD: distinfo,v 1.10 2004/08/21 05:50:44 minskim Exp $
SHA1 (tightvnc-1.2.9_unixsrc.tar.bz2) = 62b55237676bbdc7f08771e6ff72c0f70264f4ee
Size (tightvnc-1.2.9_unixsrc.tar.bz2) = 1738256 bytes
SHA1 (patch-aa) = 56346a71083a8565d034187fcabb28a965078d62
SHA1 (patch-ab) = e83466e362f78e4d1c88969c356d7ac3d2d617f6

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.1 2004/08/21 05:50:44 minskim Exp $
--- vncviewer/listen.c.orig Tue Jan 16 02:07:57 2001
+++ vncviewer/listen.c
@@ -124,7 +124,11 @@ listenForIncomingConnections(int *argc,
/* reap any zombies */
int status, pid;
+#ifdef __INTERIX
+ while ((pid= waitpid(-1, &status, WNOHANG))>0);
+#else
while ((pid= wait3(&status, WNOHANG, (struct rusage *)0))>0);
+#endif
/* discard any X events */
while (XCheckIfEvent(d, &ev, AllXEventsPredicate, NULL))