Fix build with png-1.5.

This commit is contained in:
wiz 2011-01-29 12:34:39 +00:00
parent d13d68fd9c
commit 1295ef346e
2 changed files with 17 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.19 2009/04/13 12:19:14 rh Exp $
$NetBSD: distinfo,v 1.20 2011/01/29 12:34:39 wiz Exp $
SHA1 (gnustep-gui-0.16.0.tar.gz) = cc0a14f700a3736b8e4113d3ad80ed6f979d60be
RMD160 (gnustep-gui-0.16.0.tar.gz) = 3083746b7bba1652d7522d5eb7e7a430b309a6f2
Size (gnustep-gui-0.16.0.tar.gz) = 1867264 bytes
SHA1 (patch-aa) = 6148d4fe06130d4585d4d4534182a305de9f9b70
SHA1 (patch-ab) = 731885b48f571237414072a72a9fcc878340cf9a
SHA1 (patch-ac) = ad486b1e2a751475c2f8bb118f8452c38273053a

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.5 2011/01/29 12:34:39 wiz Exp $
Fix build with png-1.5.
--- Source/NSBitmapImageRep+PNG.m.orig 2008-06-10 04:01:49.000000000 +0000
+++ Source/NSBitmapImageRep+PNG.m
@@ -225,7 +225,7 @@ static void reader_func(png_structp png_
initWithBytesNoCopy: buf
length: bytes_per_row * height];
- if (PNG_INFO_gAMA & png_info->valid)
+ if (png_get_valid(png_struct, png_info, PNG_INFO_gAMA))
{
double file_gamma = 2.2;
if (PNG_FLOATING_POINT)