Initial import of sarien, version 0.7.0. Description follows:

Adventure Game Interpreter (AGI) for Sierra On-Line games, including
Leisure Suit Larry 1, Space Quest I and II, Police Quest I, King's
Quest I, II, and III... You will still need the actual games: Sarien
just lets them run on your box under X11.

Package provided in PR pkg/19404 by mor@linex.com with some changes by me.
This commit is contained in:
jmmv 2003-01-10 16:16:33 +00:00
parent 3c33a92e56
commit 12ad0ab724
5 changed files with 67 additions and 0 deletions

4
games/sarien/DESCR Normal file
View file

@ -0,0 +1,4 @@
Adventure Game Interpreter (AGI) for Sierra On-Line games, including
Leisure Suit Larry 1, Space Quest I and II, Police Quest I, King's
Quest I, II, and III... You will still need the actual games: Sarien
just lets them run on your box under X11.

31
games/sarien/Makefile Normal file
View file

@ -0,0 +1,31 @@
# $NetBSD: Makefile,v 1.1.1.1 2003/01/10 16:16:33 jmmv Exp $
#
DISTNAME= sarien-0.7.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=sarien/}
MAINTAINER= mor@linex.com
HOMEPAGE= http://sarien.sourceforge.net/
COMMENT= Adventure Game Interpreter (AGI) for Sierra On-Line Titles
GNU_CONFIGURE= YES
USE_BUILDLINK2= YES
USE_GMAKE= YES
CONFIGURE_ARGS= --with-sdl
CFLAGS+= -DPKG_SYSCONFDIR=\"\\\"${PKG_SYSCONFDIR}\\\"\"
EGDIR= ${PREFIX}/share/examples/sarien
CONF_FILES= ${EGDIR}/sarien.conf ${PKG_SYSCONFDIR}/sarien.conf
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/sarien ${PREFIX}/bin
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/sarien
${INSTALL_DATA} ${WRKSRC}/doc/README* ${PREFIX}/share/doc/sarien
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/etc/sarien.cfg ${EGDIR}/sarien.conf
.include "../../devel/SDL/buildlink2.mk"
.include "../../mk/bsd.pkg.install.mk"
.include "../../mk/bsd.pkg.mk"

15
games/sarien/PLIST Normal file
View file

@ -0,0 +1,15 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2003/01/10 16:16:33 jmmv Exp $
bin/sarien
share/doc/sarien/README.agi
share/doc/sarien/README.djgpp
share/doc/sarien/README.macos
share/doc/sarien/README.pocketpc
share/doc/sarien/README.ports
share/doc/sarien/README.sdl
share/doc/sarien/README.svgalib
share/doc/sarien/README.turboc
share/doc/sarien/README.unix
share/doc/sarien/README.win32
share/examples/sarien/sarien.conf
@dirrm share/examples/sarien
@dirrm share/doc/sarien

5
games/sarien/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2003/01/10 16:16:36 jmmv Exp $
SHA1 (sarien-0.7.0.tar.gz) = f1c3236ed554cbde479fbbfa52cbc95cb9759fde
Size (sarien-0.7.0.tar.gz) = 284109 bytes
SHA1 (patch-aa) = 437bf3108d437f265c97a813a1a1d512003f20b4

View file

@ -0,0 +1,12 @@
$NetBSD: patch-aa,v 1.1.1.1 2003/01/10 16:16:36 jmmv Exp $
--- src/filesys/unix/path.c.orig Sun Aug 5 01:59:48 2001
+++ src/filesys/unix/path.c
@@ -46,6 +46,6 @@ char* get_config_file (void)
#endif
#endif
- return "/etc/sarien.conf";
+ return PKG_SYSCONFDIR "/sarien.conf";
}