mate-session-manager: update to 1.24.3

Change log:

mate-session-manager 1.24.3

  * Translations update
  * Follow freedesktop guidelines to disable autorun using Hidden key
  * capplet: use a function to set the visibility of treeview rows
  * Look for the location of the locking screen app using user's PATH
  * capplet: memory leak
This commit is contained in:
gutteridge 2021-05-04 02:36:26 +00:00
parent d5f1679b2e
commit 133a99c376
3 changed files with 7 additions and 53 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.27 2021/04/13 03:22:11 gutteridge Exp $
# $NetBSD: Makefile,v 1.28 2021/05/04 02:36:26 gutteridge Exp $
.include "../../meta-pkgs/mate/Makefile.common"
DISTNAME= mate-session-manager-${VERSION:R}.2
DISTNAME= mate-session-manager-${VERSION:R}.3
CATEGORIES= x11
COMMENT= MATE session manager

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.11 2021/04/13 03:22:11 gutteridge Exp $
$NetBSD: distinfo,v 1.12 2021/05/04 02:36:26 gutteridge Exp $
SHA1 (mate-session-manager-1.24.2.tar.xz) = b21501f4529046268f367f8efd9a247a825ad5fd
RMD160 (mate-session-manager-1.24.2.tar.xz) = 99a74590eb77c70b8e077c2f1aaf78d2b756e55c
SHA512 (mate-session-manager-1.24.2.tar.xz) = f474a76ebb77cf9f1370ccb48f1f7ce464f68ffc14086097dec2f37a23d589525cfc43da39286bf80383eb893fd85a6e9fd7074e94d75de51c01fa69338e059e
Size (mate-session-manager-1.24.2.tar.xz) = 712372 bytes
SHA1 (patch-capplet_gsm-properties-dialog.c) = ffb9d0fa89fe2367a96a5a0d0acd38146f5fb774
SHA1 (mate-session-manager-1.24.3.tar.xz) = f2797a18c933e1bd36247854172f847a391a05a7
RMD160 (mate-session-manager-1.24.3.tar.xz) = bcb6073083369f12bc2349613f1c76cd31b470e8
SHA512 (mate-session-manager-1.24.3.tar.xz) = ea43caa350e5f3abda65001829fa7b84d043a7e8851ff74d1d09671f868b3f0be37ae951acca84f1764b26ec9b187c56791010f1b48bd8195ff8dbd70635446f
Size (mate-session-manager-1.24.3.tar.xz) = 713004 bytes

View file

@ -1,45 +0,0 @@
$NetBSD: patch-capplet_gsm-properties-dialog.c,v 1.1 2021/04/13 03:22:11 gutteridge Exp $
autostart: fix disabling services in dialog
https://github.com/mate-desktop/mate-session-manager/pull/272
--- capplet/gsm-properties-dialog.c.orig 2021-03-27 10:41:10.000000000 +0000
+++ capplet/gsm-properties-dialog.c
@@ -179,10 +179,6 @@ append_app (GsmPropertiesDialog *dialog,
GspApp *app)
{
GtkTreeIter iter;
- if (find_by_app (GTK_TREE_MODEL (dialog->list_store),
- &iter, app)) {
- return;
- }
gtk_list_store_append (dialog->list_store, &iter);
_fill_iter_from_app (dialog->list_store, &iter, app);
@@ -196,7 +192,17 @@ _app_added (GsmPropertiesDialog *dialog,
GspApp *app,
GspAppManager *manager)
{
- append_app (dialog, app);
+ GtkTreeIter iter;
+ if (find_by_app (GTK_TREE_MODEL (dialog->list_store),
+ &iter, app)) {
+ return;
+ }
+
+ gtk_list_store_append (dialog->list_store, &iter);
+ _fill_iter_from_app (dialog->list_store, &iter, app);
+
+ g_signal_connect_swapped (app, "changed",
+ G_CALLBACK (_app_changed), dialog);
}
static void
@@ -694,7 +700,6 @@ setup_dialog (GsmPropertiesDialog *dialo
G_CALLBACK (_app_removed), dialog);
populate_model (dialog);
- update_tree_view (dialog);
}
static GObject *