Revert addition of patch for older macOS, breaks joyent bulk builds

This commit is contained in:
nia 2021-12-23 20:29:09 +00:00
parent 8545734a50
commit 13453cc05f
2 changed files with 1 additions and 19 deletions

View file

@ -1,9 +1,8 @@
$NetBSD: distinfo,v 1.161 2021/12/22 11:46:48 nia Exp $
$NetBSD: distinfo,v 1.162 2021/12/23 20:29:09 nia Exp $
BLAKE2s (mesa-20.0.6.tar.xz) = 84bdac00a14b37b598d9077448f0013439ee76db1a2f9cbc60b1b8b12838c61c
SHA512 (mesa-20.0.6.tar.xz) = a93dc3ed57ed7469b7c60cdbdcf4f29c5da4ec3986171c7b534e009e136ca21fec16207ffab38a6747437a9b1060e2e6c4b74c4e5cdc168b9aba0fc1940b5e90
Size (mesa-20.0.6.tar.xz) = 12275708 bytes
SHA1 (patch-include_c11_threads__posix.h) = 420cc3ee2f3846c448175d406e89ceb697689336
SHA1 (patch-src_amd_common_ac__debug.c) = 8233367c3b5bc344442ea8d19488fdd1e3791ae9
SHA1 (patch-src_compiler_builtin__type__macros.h) = e4868011711fb89a293580a12eb603b8e7162336
SHA1 (patch-src_egl_drivers_dri2_platform__drm.c) = 9230fbae2c04246ebca8437ecad694bbae857fbe

View file

@ -1,17 +0,0 @@
$NetBSD: patch-include_c11_threads__posix.h,v 1.3 2021/12/22 11:46:48 nia Exp $
Use compat version of timespec_get regardless on Darwin. The
meson configure test completes successfully even with clearly
bogus values on Catalina.
--- include/c11/threads_posix.h.orig 2020-04-29 22:48:24.000000000 +0000
+++ include/c11/threads_posix.h
@@ -382,7 +382,7 @@ tss_set(tss_t key, void *val)
/*-------------------- 7.25.7 Time functions --------------------*/
// 7.25.6.1
-#ifndef HAVE_TIMESPEC_GET
+#if !defined(HAVE_TIMESPEC_GET) || defined(__APPLE__)
static inline int
timespec_get(struct timespec *ts, int base)
{