Changes 3.7.6:
* Added the sqlite3_wal_checkpoint_v2() interface and enhanced the wal_checkpoint pragma to support blocking checkpoints. * Improvements to the query planner so that it makes better estimates of plan costs and hence does a better job of choosing the right plan, especially when SQLITE_ENABLE_STAT2 is used. * Fix a bug which prevented deferred foreign key constraints from being enforced when sqlite3_finalize() was not called by one statement with a failed foreign key constraint prior to another statement with foreign key constraints running. * Integer arithmetic operations that would have resulted in overflow are now performed using floating-point instead. * Increased the version number on the VFS object to 3 and added new methods xSetSysCall, xGetSysCall, and xNextSysCall used for doing full-coverage testing. * Increase the maximum value of SQLITE_MAX_ATTACHED from 30 to 62 (though the default value remains at 10). * Enhancements to FTS4: - Added the fts4aux table - Added support for compressed FTS4 content * Enhance the ANALYZE command to support the name of an index as its argument, in order to analyze just that one index. * Added the "unix-excl" built-in VFS on unix and unix-like platforms.
This commit is contained in:
parent
e19e7f02fd
commit
1384ff44a3
5 changed files with 19 additions and 17 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.21 2011/02/02 09:03:09 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.22 2011/04/12 19:00:50 adam Exp $
|
||||
|
||||
DISTNAME= sqlite-tea-3070500
|
||||
PKGNAME= sqlite3-tcl-3.7.5
|
||||
DISTNAME= sqlite-autoconf-3070600
|
||||
PKGNAME= sqlite3-tcl-3.7.6
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.hwaci.com/sw/sqlite/ \
|
||||
http://www.sqlite.org/
|
||||
|
@ -13,6 +13,8 @@ LICENSE= public-domain
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/tea
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-tcl=${BUILDLINK_PREFIX.tcl}/lib
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.11 2011/02/02 09:03:09 adam Exp $
|
||||
$NetBSD: distinfo,v 1.12 2011/04/12 19:00:50 adam Exp $
|
||||
|
||||
SHA1 (sqlite-tea-3070500.tar.gz) = 5790d00e376fb0543ca3ddd08180591c93cda52e
|
||||
RMD160 (sqlite-tea-3070500.tar.gz) = dde4da761db52e7310942014cbc7749c3ffc8228
|
||||
Size (sqlite-tea-3070500.tar.gz) = 1275046 bytes
|
||||
SHA1 (sqlite-autoconf-3070600.tar.gz) = 6b17cf7610437706fec6e21f29933c1ffd3a13e0
|
||||
RMD160 (sqlite-autoconf-3070600.tar.gz) = 81a5f55326c932f8bb9709a305621d54f181cfa7
|
||||
Size (sqlite-autoconf-3070600.tar.gz) = 1721938 bytes
|
||||
SHA1 (patch-aa) = d4d0424eec39ede995c2c408dcf51876072d3fea
|
||||
SHA1 (patch-ab) = 18b0fac8607da49b368a02d9cd881c5abc179176
|
||||
SHA1 (patch-ab) = 64a4352b9a8ed0518784837e390541cd4e1bc9aa
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-ab,v 1.1 2010/12/30 12:35:54 obache Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2011/04/12 19:00:51 adam Exp $
|
||||
|
||||
* treat DragonFly shlib handling same as NetBSD.
|
||||
|
||||
--- configure.orig 2010-12-08 12:53:41.000000000 +0000
|
||||
+++ configure
|
||||
@@ -9089,7 +9089,7 @@ fi
|
||||
@@ -9143,7 +9143,7 @@ fi
|
||||
UNSHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}.a'
|
||||
TCL_LIB_VERSIONS_OK=nodots
|
||||
;;
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.38 2011/02/02 09:03:09 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.39 2011/04/12 19:00:50 adam Exp $
|
||||
|
||||
DISTNAME= sqlite-autoconf-3070500
|
||||
PKGNAME= sqlite3-3.7.5
|
||||
DISTNAME= sqlite-autoconf-3070600
|
||||
PKGNAME= sqlite3-3.7.6
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.hwaci.com/sw/sqlite/ \
|
||||
http://www.sqlite.org/
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.57 2011/02/02 09:03:09 adam Exp $
|
||||
$NetBSD: distinfo,v 1.58 2011/04/12 19:00:50 adam Exp $
|
||||
|
||||
SHA1 (sqlite-autoconf-3070500.tar.gz) = 4e1338497b8da50b84307191bb3418e9ec5715d7
|
||||
RMD160 (sqlite-autoconf-3070500.tar.gz) = 8bec6a7bfec1c8786dde0586916b0b99e509b2ce
|
||||
Size (sqlite-autoconf-3070500.tar.gz) = 1551070 bytes
|
||||
SHA1 (sqlite-autoconf-3070600.tar.gz) = 6b17cf7610437706fec6e21f29933c1ffd3a13e0
|
||||
RMD160 (sqlite-autoconf-3070600.tar.gz) = 81a5f55326c932f8bb9709a305621d54f181cfa7
|
||||
Size (sqlite-autoconf-3070600.tar.gz) = 1721938 bytes
|
||||
|
|
Loading…
Reference in a new issue