Update to 1.2.17. From the changelog:

documentation:

* docs/overview.html: Add Abiword as an example use of --filter, based on patch
  from Frank J Bruzzaniti (fixes#383).

portability:

* Fix "no previous declaration" warning on platforms which don't have
  mkdtemp().

indexers:

* omindex:

  + Fix off-by-one when finding documents to delete which would sometimes cause
    omindex to fail to delete documents from the database when they weren't
    refound during an index update.

  + Decode dates in xlsx files.

  + Ignore extensions 'adm', 'cur', and 'ico' by default.

  + Group-readable files which are owner-readable but not world-readable should
    still get a "readable by owner" term added.  Reported by Emmanuel Garette.

build system:

* Compress source tarballs with xz instead of gzip.

* configure: Sync compiler warning flag machinery against xapian-core.  The
  changes are special handling for clang, passing -fshow-column where
  supported, and handling for new warning flags in GCC 4.6 and 4.7.
This commit is contained in:
schmonz 2014-02-20 19:15:43 +00:00
parent 33cc040739
commit 13878cb17f
3 changed files with 11 additions and 10 deletions

View file

@ -1,10 +1,11 @@
# $NetBSD: Makefile,v 1.21 2013/06/04 21:28:26 schmonz Exp $
# $NetBSD: Makefile,v 1.22 2014/02/20 19:15:43 schmonz Exp $
#
DISTNAME= xapian-omega-${VERSION}
VERSION= 1.2.15
VERSION= 1.2.17
CATEGORIES= textproc
MASTER_SITES= http://oligarchy.co.uk/xapian/${VERSION}/
EXTRACT_SUFX= .tar.xz
MAINTAINER= schmonz@NetBSD.org
HOMEPAGE= http://xapian.org/docs/omega/overview.html

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.11 2013/06/04 21:28:26 schmonz Exp $
$NetBSD: distinfo,v 1.12 2014/02/20 19:15:43 schmonz Exp $
SHA1 (xapian-omega-1.2.15.tar.gz) = a6aef085b1e63262c2f8ff7cd9419f28c8a53623
RMD160 (xapian-omega-1.2.15.tar.gz) = d9931283d9d6d174cc8136ed3e0df925e67e27cf
Size (xapian-omega-1.2.15.tar.gz) = 627733 bytes
SHA1 (patch-aa) = 033625ce1ac9797c8bf193fe3549a637410c1307
SHA1 (xapian-omega-1.2.17.tar.xz) = 245fb742042ff15d234dd68b1372837c4d5993ba
RMD160 (xapian-omega-1.2.17.tar.xz) = 4b0bac3194c4c1a48e12c1c5f2e07c2e979af145
Size (xapian-omega-1.2.17.tar.xz) = 417900 bytes
SHA1 (patch-aa) = f4cce1d8a5b535bf32c024b40eb24b66942299e3
SHA1 (patch-ab) = f84d1d457218186dff2a31e7d621085b58c891c8

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.4 2013/06/04 21:28:26 schmonz Exp $
$NetBSD: patch-aa,v 1.5 2014/02/20 19:15:44 schmonz Exp $
Call it "xapian-omega" and follow hier(7).
--- Makefile.in.orig 2013-04-17 00:14:08.000000000 +0000
--- Makefile.in.orig 2014-01-29 03:14:38.000000000 +0000
+++ Makefile.in
@@ -55,7 +55,7 @@ PRE_UNINSTALL = :
POST_UNINSTALL = :
@ -31,7 +31,7 @@ Call it "xapian-omega" and follow hier(7).
dist_omegadata_DATA = htdig2omega.script mbox2omega.script
dist_sysconf_DATA = omega.conf
@@ -714,8 +714,8 @@ htmlparsetest$(EXEEXT): $(htmlparsetest_
@@ -715,8 +715,8 @@ htmlparsetest$(EXEEXT): $(htmlparsetest_
md5test$(EXEEXT): $(md5test_OBJECTS) $(md5test_DEPENDENCIES) $(EXTRA_md5test_DEPENDENCIES)
@rm -f md5test$(EXEEXT)
$(CXXLINK) $(md5test_OBJECTS) $(md5test_LDADD) $(LIBS)