upgrade to 1.3.10 to fix security vulnerability
This commit is contained in:
parent
72136a8682
commit
138ed5880a
5 changed files with 32 additions and 58 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.138 2009/02/11 10:21:33 markd Exp $
|
||||
# $NetBSD: Makefile,v 1.139 2009/05/14 01:19:12 christos Exp $
|
||||
#
|
||||
# The CUPS author is very good about taking back changes into the main
|
||||
# CUPS distribution. The correct place to send patches or bug-fixes is:
|
||||
|
@ -6,10 +6,10 @@
|
|||
|
||||
DISTNAME= cups-${DIST_VERS}-source
|
||||
PKGNAME= cups-${VERS}
|
||||
BASE_VERS= 1.3.9
|
||||
BASE_VERS= 1.3.10
|
||||
DIST_VERS= ${BASE_VERS}
|
||||
VERS= ${DIST_VERS:S/-/./g}
|
||||
PKGREVISION= 2
|
||||
#PKGREVISION= 2
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://ftp.easysw.com/pub/cups/${BASE_VERS}/ \
|
||||
ftp://ftp.ntua.gr/pub/gnu/cups/${BASE_VERS}/ \
|
||||
|
|
|
@ -1,13 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.60 2009/02/11 10:21:33 markd Exp $
|
||||
$NetBSD: distinfo,v 1.61 2009/05/14 01:19:12 christos Exp $
|
||||
|
||||
SHA1 (cups-1.3.9-source.tar.bz2) = c1a596b355201320456b393446286fe3947bce16
|
||||
RMD160 (cups-1.3.9-source.tar.bz2) = ec8bd9fc6ee45648b6eb22949f44fc4cf2defd4e
|
||||
Size (cups-1.3.9-source.tar.bz2) = 3993875 bytes
|
||||
SHA1 (cups-1.3.10-source.tar.bz2) = 48689f07104106216d35198cc90ed56df33faf38
|
||||
RMD160 (cups-1.3.10-source.tar.bz2) = 9c8f5366f84b5f9087f7a29bace677db309a933f
|
||||
Size (cups-1.3.10-source.tar.bz2) = 3778970 bytes
|
||||
SHA1 (patch-aa) = 51ff6e66f881e445adca768d4cf2f6bd18fc36dd
|
||||
SHA1 (patch-ab) = 11936b2512fc4480a45a8efb01de0c5a29a7a6e8
|
||||
SHA1 (patch-ab) = 0b8c6662b836775c693da7ebc613ca7a5594840a
|
||||
SHA1 (patch-ac) = 02fab706563f7ba01d66530f9462759689c09f04
|
||||
SHA1 (patch-ad) = 6695c344453495cd960460733a80d50654786c60
|
||||
SHA1 (patch-ae) = 02f29abd78536fd2177042a0d7e308d418045448
|
||||
SHA1 (patch-an) = 5c12e6de5d83659011c6050786049756e4aa4b49
|
||||
SHA1 (patch-ao) = 4fc204e312bf8752f3f3b4fd73ec1e4f166ae2d3
|
||||
SHA1 (patch-ao) = c9f93c7d69d934677a605197959a162dfb1658eb
|
||||
SHA1 (patch-at) = eea32b989402c353f5f1644348c1042a3d4ddfa1
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
$NetBSD: patch-ab,v 1.18 2008/01/22 23:58:13 markd Exp $
|
||||
$NetBSD: patch-ab,v 1.19 2009/05/14 01:19:12 christos Exp $
|
||||
|
||||
--- Makefile.orig 2007-12-07 09:09:39.000000000 +1300
|
||||
+++ Makefile 2008-01-16 12:28:17.000000000 +1300
|
||||
--- Makefile.orig 2009-03-12 17:34:21.000000000 -0400
|
||||
+++ Makefile 2009-05-13 20:57:09.000000000 -0400
|
||||
@@ -22,7 +22,7 @@
|
||||
DIRS = cups backend berkeley cgi-bin filter locale man monitor \
|
||||
notifier $(PDFTOPS) scheduler systemv test \
|
||||
notifier scheduler systemv test \
|
||||
$(PHPDIR) \
|
||||
- conf data doc $(FONTS) ppd templates
|
||||
+ data doc $(FONTS) ppd templates
|
||||
|
||||
|
||||
#
|
||||
@@ -92,7 +92,9 @@
|
||||
@@ -107,7 +107,9 @@
|
||||
# Install object and target files...
|
||||
#
|
||||
|
||||
|
@ -22,7 +22,7 @@ $NetBSD: patch-ab,v 1.18 2008/01/22 23:58:13 markd Exp $
|
|||
for dir in $(DIRS); do\
|
||||
echo Installing in $$dir... ;\
|
||||
(cd $$dir; $(MAKE) $(MFLAGS) install) || exit 1;\
|
||||
@@ -100,6 +102,10 @@
|
||||
@@ -115,6 +117,10 @@
|
||||
echo Installing cups-config script...
|
||||
$(INSTALL_DIR) -m 755 $(BINDIR)
|
||||
$(INSTALL_SCRIPT) cups-config $(BINDIR)/cups-config
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.22 2009/02/11 10:21:33 markd Exp $
|
||||
|
||||
&data issue filed as http://www.cups.org/str.php?L3079 and fixed in
|
||||
cups svn 28 minutes later.
|
||||
|
||||
--- cups/http.c.orig 2008-08-01 14:33:16.000000000 -0400
|
||||
+++ cups/http.c
|
||||
@@ -1175,7 +1175,7 @@ httpInitialize(void)
|
||||
for (i = 0; i < sizeof(data); i ++)
|
||||
data[i] = rand(); /* Yes, this is a poor source of random data... */
|
||||
|
||||
- RAND_seed(&data, sizeof(data));
|
||||
+ RAND_seed(data, sizeof(data));
|
||||
#endif /* HAVE_LIBSSL */
|
||||
}
|
||||
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ao,v 1.8 2008/01/22 23:58:14 markd Exp $
|
||||
$NetBSD: patch-ao,v 1.9 2009/05/14 01:19:13 christos Exp $
|
||||
|
||||
--- config-scripts/cups-manpages.m4.orig 2007-07-12 09:46:42.000000000 +1200
|
||||
+++ config-scripts/cups-manpages.m4
|
||||
@@ -13,6 +13,8 @@ dnl which should have been included wi
|
||||
--- config-scripts/cups-manpages.m4.orig 2009-01-12 14:17:21.000000000 -0500
|
||||
+++ config-scripts/cups-manpages.m4 2009-05-13 21:07:50.000000000 -0400
|
||||
@@ -13,6 +13,8 @@
|
||||
dnl file is missing or damaged, see the license at "http://www.cups.org/".
|
||||
dnl
|
||||
|
||||
|
@ -11,16 +11,15 @@ $NetBSD: patch-ao,v 1.8 2008/01/22 23:58:14 markd Exp $
|
|||
dnl Fix "mandir" variable...
|
||||
if test "$mandir" = "\${datarootdir}/man" -a "$prefix" = "/"; then
|
||||
# New GNU "standards" break previous ones, so make sure we use
|
||||
@@ -50,41 +52,60 @@ AC_SUBST(AMANDIR)
|
||||
@@ -50,8 +52,33 @@
|
||||
AC_SUBST(PMANDIR)
|
||||
|
||||
dnl Setup manpage extensions...
|
||||
-case "$uname" in
|
||||
- *BSD* | Darwin*)
|
||||
- # *BSD
|
||||
- IRIX*)
|
||||
+if test x$manext = x; then
|
||||
+ case "$uname" in
|
||||
+ *BSD* | Darwin* | DragonFly*)
|
||||
+ *BSD* | DragonFly*)
|
||||
+ # *BSD and Darwin (MacOS X)
|
||||
+ manext=bsd
|
||||
+ ;;
|
||||
|
@ -32,7 +31,7 @@ $NetBSD: patch-ao,v 1.8 2008/01/22 23:58:14 markd Exp $
|
|||
+ # Solaris and HP-UX
|
||||
+ manext=sysv
|
||||
+ ;;
|
||||
+ Linux* | GNU*)
|
||||
+ Linux* | GNU* | Darwin*)
|
||||
+ # Linux and GNU Hurd
|
||||
+ manext=linux
|
||||
+ ;;
|
||||
|
@ -42,44 +41,36 @@ $NetBSD: patch-ao,v 1.8 2008/01/22 23:58:14 markd Exp $
|
|||
+ ;;
|
||||
+ esac
|
||||
+fi
|
||||
+
|
||||
+case "$manext" in
|
||||
+ bsd)
|
||||
MAN1EXT=1
|
||||
MAN5EXT=5
|
||||
MAN7EXT=7
|
||||
MAN8EXT=8
|
||||
MAN8DIR=8
|
||||
;;
|
||||
- IRIX*)
|
||||
- # SGI IRIX
|
||||
+ irix)
|
||||
# SGI IRIX
|
||||
MAN1EXT=1
|
||||
MAN5EXT=5
|
||||
MAN7EXT=7
|
||||
@@ -59,7 +86,7 @@
|
||||
MAN8EXT=1m
|
||||
MAN8DIR=1
|
||||
;;
|
||||
- SunOS* | HP-UX*)
|
||||
- # Solaris and HP-UX
|
||||
+ sysv)
|
||||
# Solaris and HP-UX
|
||||
MAN1EXT=1
|
||||
MAN5EXT=5
|
||||
MAN7EXT=7
|
||||
@@ -67,7 +94,7 @@
|
||||
MAN8EXT=1m
|
||||
MAN8DIR=1m
|
||||
;;
|
||||
- Linux* | GNU*)
|
||||
- # Linux and GNU Hurd
|
||||
- Linux* | GNU* | Darwin*)
|
||||
+ linux)
|
||||
# Linux, GNU Hurd, and Mac OS X
|
||||
MAN1EXT=1.gz
|
||||
MAN5EXT=5.gz
|
||||
MAN7EXT=7.gz
|
||||
@@ -75,7 +102,7 @@
|
||||
MAN8EXT=8.gz
|
||||
MAN8DIR=8
|
||||
;;
|
||||
- *)
|
||||
- # All others
|
||||
+ none|*)
|
||||
# All others
|
||||
MAN1EXT=1
|
||||
MAN5EXT=5
|
||||
MAN7EXT=7
|
||||
|
|
Loading…
Reference in a new issue