Make this package have better conformance to hier(8).
Move most files to share/rox and binary files to libexec/rox. This closes PR#17038 from Rui-Xiang Guo. Thanks!
This commit is contained in:
parent
007ead7ccc
commit
13d37e73f2
4 changed files with 71 additions and 61 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.2 2002/04/29 22:19:46 simonb Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2002/05/26 19:45:44 cjep Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rox-1.2.0
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=rox/}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
@ -14,12 +15,14 @@ DEPENDS+= rox-base>=1.0.2:../../sysutils/rox-base
|
|||
|
||||
DIST_SUBDIR= rox
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BUILDLINK_ONLY= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-gtk2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/ROX-Filer/src
|
||||
|
||||
post-patch:
|
||||
${SED} -e "s:APPDIR:"${PREFIX}/apps":g" < ${FILESDIR}/rox > \
|
||||
${SED} -e "s:APPDIR:"${PREFIX}/share/rox":g" < ${FILESDIR}/rox > \
|
||||
${WRKDIR}/${DISTNAME}/rox
|
||||
|
||||
post-build:
|
||||
|
@ -30,12 +33,19 @@ pre-install:
|
|||
${RM} -rf ${WRKSRC}
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/apps
|
||||
${CP} -Rf ${WRKDIR}/${DISTNAME}/ROX-Filer ${PREFIX}/apps
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/rox
|
||||
${INSTALL_PROGRAM_DIR} ${PREFIX}/libexec/rox
|
||||
${INSTALL} ${WRKDIR}/${DISTNAME}/ROX-Filer/ROX-Filer \
|
||||
${PREFIX}/libexec/rox
|
||||
${RM} -f ${WRKDIR}/${DISTNAME}/ROX-Filer/ROX-Filer
|
||||
${CP} -Rf ${WRKDIR}/${DISTNAME}/ROX-Filer ${PREFIX}/share/rox
|
||||
${SED} -e "s:@PREFIX@:"${PREFIX}":g" < \
|
||||
${WRKDIR}/${DISTNAME}/ROX-Filer/AppRun > \
|
||||
${PREFIX}/share/rox/ROX-Filer/AppRun
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME}/rox ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/rox.1 ${PREFIX}/man/man1
|
||||
|
||||
.include "../../graphics/gdk-pixbuf/buildlink.mk"
|
||||
.include "../../textproc/libxml/buildlink.mk"
|
||||
.include "../../x11/gtk/buildlink.mk"
|
||||
.include "../../textproc/libxml2/buildlink.mk"
|
||||
.include "../../x11/gtk2/buildlink.mk"
|
||||
.include "../../mk/x11.buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,48 +1,49 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2002/04/21 11:28:17 rh Exp $
|
||||
apps/ROX-Filer/Action.png
|
||||
apps/ROX-Filer/AppIcon.xpm
|
||||
apps/ROX-Filer/AppInfo.xml
|
||||
apps/ROX-Filer/AppRun
|
||||
apps/ROX-Filer/Help/COPYING
|
||||
apps/ROX-Filer/Help/Changes
|
||||
apps/ROX-Filer/Help/Manual-fr.html
|
||||
apps/ROX-Filer/Help/Manual.html
|
||||
apps/ROX-Filer/Help/README
|
||||
apps/ROX-Filer/Help/README-es
|
||||
apps/ROX-Filer/Help/TODO
|
||||
apps/ROX-Filer/Messages/README
|
||||
apps/ROX-Filer/Messages/de.gmo
|
||||
apps/ROX-Filer/Messages/fr.gmo
|
||||
apps/ROX-Filer/Messages/hu.gmo
|
||||
apps/ROX-Filer/Messages/it.gmo
|
||||
apps/ROX-Filer/Messages/nl.gmo
|
||||
apps/ROX-Filer/Messages/pl.gmo
|
||||
apps/ROX-Filer/Messages/ru.gmo
|
||||
apps/ROX-Filer/Messages/sp.gmo
|
||||
apps/ROX-Filer/Options.xml
|
||||
apps/ROX-Filer/ROX-Filer
|
||||
apps/ROX-Filer/Styles
|
||||
apps/ROX-Filer/pixmaps/application.xpm
|
||||
apps/ROX-Filer/pixmaps/close.xpm
|
||||
apps/ROX-Filer/pixmaps/details.xpm
|
||||
apps/ROX-Filer/pixmaps/dirs.xpm
|
||||
apps/ROX-Filer/pixmaps/error.xpm
|
||||
apps/ROX-Filer/pixmaps/help.xpm
|
||||
apps/ROX-Filer/pixmaps/hidden.xpm
|
||||
apps/ROX-Filer/pixmaps/home.xpm
|
||||
apps/ROX-Filer/pixmaps/mount.xpm
|
||||
apps/ROX-Filer/pixmaps/mounted.xpm
|
||||
apps/ROX-Filer/pixmaps/multiple.xpm
|
||||
apps/ROX-Filer/pixmaps/refresh.xpm
|
||||
apps/ROX-Filer/pixmaps/symlink.xpm
|
||||
apps/ROX-Filer/pixmaps/unknown.xpm
|
||||
apps/ROX-Filer/pixmaps/up.xpm
|
||||
apps/ROX-Filer/pixmaps/zoom.xpm
|
||||
apps/ROX-Filer/style.css
|
||||
@comment $NetBSD: PLIST,v 1.2 2002/05/26 19:45:44 cjep Exp $
|
||||
bin/rox
|
||||
man/man1/rox.1
|
||||
@dirrm apps/ROX-Filer/pixmaps
|
||||
@dirrm apps/ROX-Filer/Messages
|
||||
@dirrm apps/ROX-Filer/Help
|
||||
@dirrm apps/ROX-Filer
|
||||
@dirrm apps
|
||||
libexec/rox/ROX-Filer
|
||||
share/rox/ROX-Filer/Action.png
|
||||
share/rox/ROX-Filer/AppIcon.xpm
|
||||
share/rox/ROX-Filer/AppInfo.xml
|
||||
share/rox/ROX-Filer/AppRun
|
||||
share/rox/ROX-Filer/Help/COPYING
|
||||
share/rox/ROX-Filer/Help/Changes
|
||||
share/rox/ROX-Filer/Help/Manual-fr.html
|
||||
share/rox/ROX-Filer/Help/Manual.html
|
||||
share/rox/ROX-Filer/Help/README
|
||||
share/rox/ROX-Filer/Help/README-es
|
||||
share/rox/ROX-Filer/Help/TODO
|
||||
share/rox/ROX-Filer/Messages/README
|
||||
share/rox/ROX-Filer/Messages/de.gmo
|
||||
share/rox/ROX-Filer/Messages/fr.gmo
|
||||
share/rox/ROX-Filer/Messages/hu.gmo
|
||||
share/rox/ROX-Filer/Messages/it.gmo
|
||||
share/rox/ROX-Filer/Messages/nl.gmo
|
||||
share/rox/ROX-Filer/Messages/pl.gmo
|
||||
share/rox/ROX-Filer/Messages/ru.gmo
|
||||
share/rox/ROX-Filer/Messages/sp.gmo
|
||||
share/rox/ROX-Filer/Options.xml
|
||||
share/rox/ROX-Filer/Styles
|
||||
share/rox/ROX-Filer/pixmaps/application.xpm
|
||||
share/rox/ROX-Filer/pixmaps/close.xpm
|
||||
share/rox/ROX-Filer/pixmaps/details.xpm
|
||||
share/rox/ROX-Filer/pixmaps/dirs.xpm
|
||||
share/rox/ROX-Filer/pixmaps/error.xpm
|
||||
share/rox/ROX-Filer/pixmaps/help.xpm
|
||||
share/rox/ROX-Filer/pixmaps/hidden.xpm
|
||||
share/rox/ROX-Filer/pixmaps/home.xpm
|
||||
share/rox/ROX-Filer/pixmaps/mount.xpm
|
||||
share/rox/ROX-Filer/pixmaps/mounted.xpm
|
||||
share/rox/ROX-Filer/pixmaps/multiple.xpm
|
||||
share/rox/ROX-Filer/pixmaps/refresh.xpm
|
||||
share/rox/ROX-Filer/pixmaps/symlink.xpm
|
||||
share/rox/ROX-Filer/pixmaps/unknown.xpm
|
||||
share/rox/ROX-Filer/pixmaps/up.xpm
|
||||
share/rox/ROX-Filer/pixmaps/zoom.xpm
|
||||
share/rox/ROX-Filer/style.css
|
||||
@dirrm share/rox/ROX-Filer/pixmaps
|
||||
@dirrm share/rox/ROX-Filer/Messages
|
||||
@dirrm share/rox/ROX-Filer/Help
|
||||
@dirrm share/rox/ROX-Filer
|
||||
@dirrm share/rox
|
||||
@dirrm libexec/rox
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2002/04/21 11:28:16 rh Exp $
|
||||
$NetBSD: distinfo,v 1.2 2002/05/26 19:45:44 cjep Exp $
|
||||
|
||||
SHA1 (rox/rox-1.2.0.tgz) = 704301a6006920ff339e847aacb4bbdab7ee51a4
|
||||
Size (rox/rox-1.2.0.tgz) = 847897 bytes
|
||||
SHA1 (patch-aa) = 476bfa40012e9d43c0c577f69b552873bf56cc34
|
||||
SHA1 (patch-ab) = dc9d4996b383563b8a5776f86fff1e8e97569f12
|
||||
SHA1 (patch-ac) = 340ea4c70766912f935270c83741c4f0f8e93911
|
||||
SHA1 (patch-ac) = 3f60bcd1693ed66aa752d28ee2d8e0a82aeaa8de
|
||||
|
|
|
@ -1,13 +1,12 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2002/04/21 11:28:17 rh Exp $
|
||||
|
||||
--- ../AppRun.orig Thu Apr 11 21:58:15 2002
|
||||
+++ ../AppRun
|
||||
$NetBSD: patch-ac,v 1.2 2002/05/26 19:45:44 cjep Exp $
|
||||
--- ../AppRun.orig Sun May 26 16:30:50 2002
|
||||
+++ ../AppRun Sun May 26 16:34:31 2002
|
||||
@@ -39,7 +39,7 @@
|
||||
exit 1
|
||||
esac
|
||||
|
||||
-BIN="$APP_DIR/$PLATFORM/$PROG"
|
||||
+BIN="$APP_DIR/$PROG"
|
||||
+BIN="@PREFIX@/libexec/rox/$PROG"
|
||||
|
||||
if [ -x "$BIN" ]; then
|
||||
exec $DEBUGGER "$BIN" "$@"
|
||||
|
|
Loading…
Reference in a new issue