* use correct argument types for XParseGeometry and XReadBitmapFileData

* make sure the pixmap is found even if xteddy is launched via an absolute
  path
This commit is contained in:
schwarz 2006-09-10 13:39:40 +00:00
parent b40062d65b
commit 13e11da026
2 changed files with 44 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.5 2005/02/23 17:36:25 wiz Exp $
$NetBSD: distinfo,v 1.6 2006/09/10 13:39:40 schwarz Exp $
SHA1 (xteddy-1.1.tar.gz) = a681923333a4e2b2112290d601c167fd7e8e1302
RMD160 (xteddy-1.1.tar.gz) = b392d8385422198808ab02ccd0b6dc025512f7f2
Size (xteddy-1.1.tar.gz) = 117141 bytes
SHA1 (patch-aa) = b77f0b43a999f54b28602ab1fb66ed320a5632c1
SHA1 (patch-ab) = 260f836f4aab651c72caebac821e497b54d72cbd
SHA1 (patch-ac) = 28dce1fcdd1367c33159001bd5bba9cf4e7291a8

View file

@ -0,0 +1,42 @@
$NetBSD: patch-ac,v 1.1 2006/09/10 13:39:40 schwarz Exp $
--- xteddy.c.orig 1998-04-23 09:58:17.000000000 +0200
+++ xteddy.c 2006-09-10 15:22:31.000000000 +0200
@@ -69,7 +69,8 @@
/* Initializing filenames */
{
#define FBUFLEN 200
- int buflen, w, h, xhotret, yhotret;
+ int buflen, xhotret, yhotret;
+ unsigned int w, h;
char fbuf[FBUFLEN];
if ( !xteddy->teddy || !(strlen(xteddy->teddy)) ) return -1;
@@ -130,8 +131,8 @@
XSetWindowAttributes setwinattr;
XGCValues gcvalues;
unsigned long valuemask, gcvaluemask, inputmask;
- int x, y, geomflags, xw, xh;
- unsigned int border_width = 0;
+ int x, y, geomflags;
+ unsigned int xw, xh, border_width = 0;
unsigned int display_width, display_height, display_depth;
Pixmap icon_pixmap, background_pixmap, shape_pixmap;
XSizeHints size_hints;
@@ -168,14 +169,14 @@
int offs_x, offs_y, new_x, new_y, tmp_x, tmp_y;
unsigned int tmp_mask;
- teddy.teddy = argv[0];
-
/* Determine program name */
if ((progname = strrchr(argv[0],'/')) == NULL)
progname = argv[0];
else
progname++;
+ teddy.teddy = progname;
+
/* Option handling: "-wm", "-float", "-noquit", "-mono", "-geometry" */
/* and "-display" are recognized. See manual page for details. */
/* -F<name> ... Other pixmap name */