Do not undef/define __LITTLE_ENDIAN__, the compiler defined macro has a

value.
This commit is contained in:
joerg 2013-05-04 12:43:00 +00:00
parent 5bb49db77d
commit 1413a41a55
2 changed files with 18 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2012/07/09 19:16:33 joerg Exp $
$NetBSD: distinfo,v 1.9 2013/05/04 12:43:00 joerg Exp $
SHA1 (DevIL-1.7.8.tar.gz) = bc27e3e830ba666a3af03548789700d10561fcb1
RMD160 (DevIL-1.7.8.tar.gz) = a3cdb14fcca5e75ada240a53cbdc3e749a759da5
@ -9,3 +9,4 @@ SHA1 (patch-ac) = b540afa8baca5bb5e71edc63291ce49eb2fafd23
SHA1 (patch-ad) = c8885607457c9af2d89dcf2d9e163fd224e0fa35
SHA1 (patch-include_IL_il.h) = 553b2fbbd930ff6bab4b5bc790d13ebcccbfffba
SHA1 (patch-lib_Makefile.in) = a2ae8d1a97f2cbd9c46b2f5923be06839dd6c64f
SHA1 (patch-src-IL_include_il__endian.h) = 25ed5f24fc871ceebb685e1c242a4c7b724142a2

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src-IL_include_il__endian.h,v 1.1 2013/05/04 12:43:00 joerg Exp $
--- src-IL/include/il_endian.h.orig 2013-05-03 17:18:05.000000000 +0000
+++ src-IL/include/il_endian.h
@@ -39,8 +39,9 @@
#define BigDouble(d)
#else
#undef __BIG_ENDIAN__
- #undef __LITTLE_ENDIAN__ // Not sure if it's defined by any compiler...
- #define __LITTLE_ENDIAN__
+#ifndef __LITTLE_ENDIAN__
+#define __LITTLE_ENDIAN__
+#endif
#define Short(s)
#define UShort(s)
#define Int(i)