-fix some pointer typecast nonsense which breaks if time_t is not "long",
makes the select() main loop work again on NetBSD-current, bump PKGREVISION -use the libgnutls-config hack so that https works with gnutls-2.8
This commit is contained in:
parent
6f44f76a39
commit
14147dec78
4 changed files with 30 additions and 4 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.41 2009/05/20 00:58:29 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.42 2009/07/02 20:04:12 drochner Exp $
|
||||
|
||||
DISTNAME= elinks-0.12pre2
|
||||
PKGNAME= ${DISTNAME:S/pre/rc/}
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://elinks.or.cz/download/ \
|
||||
http://ftp.icm.edu.pl/packages/elinks/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.25 2008/11/06 08:33:31 bjs Exp $
|
||||
$NetBSD: distinfo,v 1.26 2009/07/02 20:04:12 drochner Exp $
|
||||
|
||||
SHA1 (elinks-0.12pre2.tar.bz2) = 7bb30f817cc053b87f80c32359dfccbc49e067eb
|
||||
RMD160 (elinks-0.12pre2.tar.bz2) = 94af523e31d24e09c9cb6a41e5d87456f288f234
|
||||
|
@ -9,3 +9,4 @@ SHA1 (patch-ac) = a7f4bacbdf4073a5a733fe565b1f51dc755c7e4d
|
|||
SHA1 (patch-ad) = 089e2455c64cbfb48907693a653e76cc97961622
|
||||
SHA1 (patch-ae) = a46c419ec3d96825958903459708b8b131862053
|
||||
SHA1 (patch-ag) = c31bede62a6baa1d43ab1dff639f9d7265d2bece
|
||||
SHA1 (patch-ah) = 25357fd0b0aa08f7ca55f3f8c262d2d1a4874710
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.9 2008/11/06 08:33:31 bjs Exp $
|
||||
# $NetBSD: options.mk,v 1.10 2009/07/02 20:04:12 drochner Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.elinks
|
||||
PKG_SUPPORTED_OPTIONS+= bittorrent nntp javascript finger gopher
|
||||
|
@ -67,6 +67,7 @@ CONFIGURE_ARGS+= --with-openssl=${BUILDLINK_PREFIX.openssl}
|
|||
.elif !empty(PKG_OPTIONS:Mgnutls)
|
||||
|
||||
.include "../../security/gnutls/buildlink3.mk"
|
||||
.include "../../security/gnutls/libgnutls-config.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --with-gnutls-includes=${BUILDLINK_PREFIX.gnutls}/include
|
||||
CONFIGURE_ARGS+= --with-gnutls-libs=${BUILDLINK_PREFIX.gnutls}/lib
|
||||
|
|
24
www/elinks/patches/patch-ah
Normal file
24
www/elinks/patches/patch-ah
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ah,v 1.1 2009/07/02 20:04:12 drochner Exp $
|
||||
|
||||
--- src/main/select.c.orig 2008-09-21 10:45:22.000000000 +0200
|
||||
+++ src/main/select.c
|
||||
@@ -223,7 +223,7 @@ select_loop(void (*init)(void))
|
||||
check_bottom_halves();
|
||||
|
||||
while (!program.terminate) {
|
||||
- struct timeval *timeout = NULL;
|
||||
+ struct timeval tos, *timeout = NULL;
|
||||
int n, i, has_timer;
|
||||
timeval_T t;
|
||||
|
||||
@@ -264,7 +264,9 @@ select_loop(void (*init)(void))
|
||||
if (has_timer) {
|
||||
/* Be sure timeout is not negative. */
|
||||
timeval_limit_to_zero_or_one(&t);
|
||||
- timeout = (struct timeval *) &t;
|
||||
+ tos.tv_sec = t.sec;
|
||||
+ tos.tv_usec = t.usec;
|
||||
+ timeout = &tos;
|
||||
}
|
||||
|
||||
n = select(w_max, &x_read, &x_write, &x_error, timeout);
|
Loading…
Reference in a new issue