Make it build on non Linux systems having alloca definedi, like DragonFly.

This commit is contained in:
hasso 2009-06-05 09:49:53 +00:00
parent 92e26cd069
commit 141cd0bf18
2 changed files with 15 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.2 2009/02/09 17:04:49 joerg Exp $
$NetBSD: distinfo,v 1.3 2009/06/05 09:49:53 hasso Exp $
SHA1 (synergy-1.2.7.tar.gz) = 5964460892fd9e9cb55c5bfe4e781f2bc08d0b76
RMD160 (synergy-1.2.7.tar.gz) = 6bdbe5adbc13c2f49afcb99ccaa20b96a12c2bcf
Size (synergy-1.2.7.tar.gz) = 707319 bytes
SHA1 (patch-aa) = 20747abe2f447adb5967a767ee5ec9d9f09c8fb4
SHA1 (patch-ab) = 2a4b8c368f0733f0c6e9d60b42660e459a2a55c1

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1 2009/06/05 09:49:53 hasso Exp $
--- lib/arch/CArchNetworkBSD.cpp.orig 2009-06-05 12:09:52 +0300
+++ lib/arch/CArchNetworkBSD.cpp 2009-06-05 12:11:02 +0300
@@ -50,6 +50,8 @@
#if HAVE_ALLOCA_H
# define freea(x_)
#else
+# undef alloca
+# undef freea
# define alloca(x_) malloc(x_)
# define freea(x_) free(x_)
#endif