Update to version 1.34. Changes since 1.32:

- The function whos() didn't work in the previous release,
  for which reason there is this early bug fix release now.

- Since introduction of KShallowObjectArray in 1.32, I forgot to
  increase the constant 12 to 13 in #define pair(ka,kb) ... in
  objarithm.C. Result: E.g., 2/x where x is undefined did not produce
  error message but silently evaluated to 0. There could be other much
  more obscure errors also. Now the constant 12 is no longer
  hard-coded but is defined to be int(Kundef)+1. This works as long as
  Kundef remains the last in enum Tkind (object.H).  There is comment
  telling it...  - in tela.C:FindMachineNan(), using switch()
  statement can cause compile-time error due to duplicate case labels,
  fixed now by rewriting switch() as nested if's (tela.C)
  (This is in code segment that was put in tela only in the previous
  release.)

- some changes to allow compilation with gcc-3.0 (contributed by Ch. Spiel)
This commit is contained in:
jtb 2002-05-03 23:32:12 +00:00
parent f8a0903fc5
commit 142a7dae3b
8 changed files with 68 additions and 76 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.9 2001/05/03 01:06:32 jtb Exp $
# $NetBSD: Makefile,v 1.10 2002/05/03 23:32:12 jtb Exp $
DISTNAME= tela-1.32
DISTNAME= tela-1.34
CATEGORIES= math
MASTER_SITES= ftp://ftp.funet.fi/pub/sci/math/tela/ \
ftp://sumppu.fmi.fi/pub/tela/
@ -9,31 +9,18 @@ MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.geo.fmi.fi/prog/tela_00.html
COMMENT= Tensor Language - a programming language for scientific computing
DEPENDS+= blas-[0-9]*:../../math/blas
DEPENDS+= lapack-[0-9]*:../../math/lapack
DEPENDS+= hdf-[0-9]*:../../devel/hdf
DEPENDS+= plotmtv-[0-9]*:../../graphics/plotmtv
DEPENDS+= readline-[0-9]*:../../devel/readline
BLAS_PREFIX_DEFAULT= ${LOCALBASE}
EVAL_PREFIX+= BLAS_PREFIX=blas
LAPACK_PREFIX_DEFAULT= ${LOCALBASE}
EVAL_PREFIX+= LAPACK_PREFIX=lapack
HDF_PREFIX_DEFAULT= ${LOCALBASE}
EVAL_PREFIX+= HDF_PREFIX=hdf
JPEG_PREFIX_DEFAULT= ${LOCALBASE}
EVAL_PREFIX+= JPEG_PREFIX=jpeg
READLINE_PREFIX_DEFAULT=${LOCALBASE}
EVAL_PREFIX+= READLINE_PREFIX=readline
GNU_CONFIGURE= yes
USE_FORTRAN= yes
USE_X11= yes
GNU_CONFIGURE= # defined
USE_FORTRAN= # defined
USE_X11= # defined
USE_BUILDLINK_ONLY= # defined
#USE_GNU_READLINE= # defined
INSTALL_TARGET= install installdocs
CONFIGURE_ENV+= INSTALLATION_PREFIX="${PREFIX}/share/tela"
CONFIGURE_ENV+= ARCHDEP_INSTALLATION_PREFIX="${PREFIX}/lib/tela"
CONFIGURE_ENV+= INSTALLATION_PREFIX=${PREFIX}/share/tela
CONFIGURE_ENV+= ARCHDEP_INSTALLATION_PREFIX=${PREFIX}/lib/tela
pre-configure:
@for f in ${WRKSRC}/t/demo.t ${WRKSRC}/t/docview.t \
@ -42,4 +29,10 @@ pre-configure:
$$f > $$f.tmp && ${MV} -f $$f.tmp $$f; \
done
.include "../../math/lapack/buildlink.mk"
.include "../../math/blas/buildlink.mk"
.include "../../devel/readline/buildlink.mk"
.include "../../devel/hdf/buildlink.mk"
.include "../../devel/zlib/buildlink.mk"
.include "../../graphics/jpeg/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,12 +1,13 @@
$NetBSD: distinfo,v 1.3 2001/04/24 23:43:03 jtb Exp $
$NetBSD: distinfo,v 1.4 2002/05/03 23:32:12 jtb Exp $
SHA1 (tela-1.32.tar.gz) = faa3aa1197c96f1d6e0ee09dde10a7b8d17f84f4
Size (tela-1.32.tar.gz) = 1845073 bytes
SHA1 (tela-1.34.tar.gz) = b600db15563be48418ea1a5ba90e30acc9dcadb5
Size (tela-1.34.tar.gz) = 1894352 bytes
SHA1 (patch-aa) = 2a2033c3d3bddbfcfaebb189223fc320fb82c4cc
SHA1 (patch-ab) = dc651797e20749605fea7c2eb78054a9be6752a2
SHA1 (patch-ac) = 0388b60f99712e33de82663560c7044c5af92c55
SHA1 (patch-ad) = 1276a6d1ef5876376a4dcd9a1dacfd7e09f106fd
SHA1 (patch-ab) = b8e60e92716c35432e3c991c0c871e29968e2df6
SHA1 (patch-ac) = 85511c1c32457a41a00b5557b650454f85040374
SHA1 (patch-ad) = fedad68bb459a1ef326c180db5e5016ef2f7f3eb
SHA1 (patch-ae) = ad36a0b3d6d9e4e48e3e266ea9d88c6d3e5d918d
SHA1 (patch-af) = a126910bd70b2f1fbde2f4609cace499795d0e0c
SHA1 (patch-ag) = 5090a139f0a7dfb04e0714db698d5f2e5680f8c1
SHA1 (patch-ah) = 4db7d142e30ee5d813e8a827ee49e72faacebd25
SHA1 (patch-ag) = b4c1dfb4de635d40fe07559c10f78056ad38689a
SHA1 (patch-ah) = 0547a73aa6c378715c9a06056ebe00a2e10f1f96
SHA1 (patch-ai) = 696eb355650b4dbfca3150e2352786b75e8b7a8b

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.4 2001/04/09 04:09:48 jtb Exp $
$NetBSD: patch-ab,v 1.5 2002/05/03 23:32:13 jtb Exp $
--- makeinc.in.orig Thu Mar 8 23:55:48 2001
+++ makeinc.in
@ -30,12 +30,12 @@ $NetBSD: patch-ab,v 1.4 2001/04/09 04:09:48 jtb Exp $
-HDFINCLUDE = @HDFDEF@
-HDFLIBS = @HDFLIBS@
-FLIBS = @FLIBS@
+READLINELIB = -Wl,-R${READLINE_PREFIX}/lib -L${READLINE_PREFIX}/lib -lreadline -ltermcap
+BLASLIB = -Wl,-R${BLAS_PREFIX}/lib -L${BLAS_PREFIX}/lib -lblas
+LAPACKLIB = -Wl,-R${LAPACK_PREFIX}/lib -L${LAPACK_PREFIX}/lib -llapack
+READLINELIB = -Wl,-R${BUILDLINK_PREFIX.readline}/lib -lreadline -ltermcap
+BLASLIB = -Wl,-R${BUILDLINK_PREFIX.blas}/lib -lblas
+LAPACKLIB = -Wl,-R${BUILDLINK_PREFIX.lapack}/lib -llapack
+DLDLIB =
+HDFINCLUDE = -I${HDF_PREFIX}/include/hdf -Dunix @HDFDEF@
+HDFLIBS = -Wl,-R${HDF_PREFIX}/lib -L${HDF_PREFIX}/lib -lmfhdf -ldf -R${JPEG_PREFIX}/lib -L${JPEG_PREFIX}/lib -ljpeg -lz -lm
+HDFINCLUDE = -Dunix @HDFDEF@
+HDFLIBS = -Wl,-R${BUILDLINK_PREFIX.hdf}/lib -lmfhdf -ldf -R${BUILDLINK_PREFIX.jpeg}/lib -ljpeg -lz -lm
+FLIBS = -lg2c
EXTRALIBS = @EXTRALIBS@
EXTRA_TARGETS = @EXTRA_TARGETS@

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ac,v 1.3 2001/04/24 23:43:03 jtb Exp $
$NetBSD: patch-ac,v 1.4 2002/05/03 23:32:13 jtb Exp $
--- tela.C.orig Tue Mar 20 14:41:02 2001
+++ tela.C
--- tela.C.orig Tue Sep 4 13:57:20 2001
+++ tela.C Wed May 1 16:00:57 2002
@@ -13,7 +13,7 @@
#include "d.y.h"
#include "d.l.h"
@ -11,7 +11,18 @@ $NetBSD: patch-ac,v 1.3 2001/04/24 23:43:03 jtb Exp $
//#include <unistd.h>
#if HAVE_IEEE754_H == 1
# include <ieee754.h>
@@ -45,9 +45,9 @@
@@ -31,7 +31,9 @@
#include <signal.h>
extern "C" {
-#include "readline/chardefs.h"
+#ifndef whitespace
+#define whitespace(c) (((c) == ' ') || ((c) == '\t'))
+#endif
extern Tchar *readline(...);
extern Tchar **completion_matches(...);
extern int rl_add_defun(...);
@@ -45,9 +47,9 @@
// MAIN__ which is supposed to be the Fortran main program. Since we
// do not have a Fortran main program here, we define it here. Hope
// it doesn't conflict with anything else.
@ -23,7 +34,7 @@ $NetBSD: patch-ac,v 1.3 2001/04/24 23:43:03 jtb Exp $
}
char *VersionString = VERSION;
@@ -229,8 +229,8 @@
@@ -220,8 +222,8 @@
return 0.0;
}
#else

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ad,v 1.7 2001/04/09 03:55:20 jtb Exp $
$NetBSD: patch-ad,v 1.8 2002/05/03 23:32:13 jtb Exp $
--- Makefile.orig Tue Mar 6 18:25:25 2001
+++ Makefile
@ -7,7 +7,7 @@ $NetBSD: patch-ad,v 1.7 2001/04/09 03:55:20 jtb Exp $
GNUZIP = gzip -9
-READLINEINCLUDE = -I/usr/local/include
+READLINEINCLUDE = -I${READLINE_PREFIX}/include
+READLINEINCLUDE =
SGML2PS = sgml2latex
#HDFLIBS = /usr/local/lib/libdf.a
#DLDINCLUDE =

View file

@ -1,22 +1,12 @@
$NetBSD: patch-ag,v 1.3 2001/03/04 17:15:19 jtb Exp $
$NetBSD: patch-ag,v 1.4 2002/05/03 23:32:13 jtb Exp $
--- t/docview.t.orig Thu Sep 7 14:05:06 2000
+++ t/docview.t
--- t/docview.t.orig Wed May 1 15:32:52 2002
+++ t/docview.t Wed May 1 15:33:25 2002
@@ -1,6 +1,6 @@
-choiceViewing = smenu("Choose viewing method","ASCII","xdvi","Xemacs");
+choiceViewing = smenu("Choose viewing method","ASCII","xdvi","Emacs");
choiceViewing = smenu("Choose viewing method","ASCII","xdvi","Xemacs");
-directory = "/usr/local/lib/tela";
+directory = "@PREFIX@/share/tela";
choiceDoc = smenu("Choose document to view",
"Basic help file",
@@ -19,7 +19,7 @@
system(#("less -Ms ",directory,"/",file,".txt"));
} else if (strstarteq(choiceViewing,"xdvi")) {
system(#("xdvi -geometry 847x570+0+0 -s 3 ",directory,"/",file,".dvi&"));
-} else if (strstarteq(choiceViewing,"Xemacs")) {
+} else if (strstarteq(choiceViewing,"Emacs")) {
system(#("emacs ",directory,"/",file,".txt&"));
};

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ah,v 1.3 2001/03/04 17:15:19 jtb Exp $
$NetBSD: patch-ah,v 1.4 2002/05/03 23:32:13 jtb Exp $
--- t/std.t.orig Thu Nov 30 11:06:14 2000
+++ t/std.t
@ -11,21 +11,3 @@ $NetBSD: patch-ah,v 1.3 2001/03/04 17:15:19 jtb Exp $
editor = "emacs";
pager = "less -Ms";
env = getenv("EDITOR");
@@ -109,7 +109,7 @@
"HTML/Xmosaic (requires X)",
"HTML/Lynx",
"Xdvi (requires X)",
- "Xemacs (requires X)",
+ "Emacs (requires X)",
"Cancel");
if (strstarteq(choiceViewing,"Cancel")) return;
choiceDoc = smenu("Choose document to view",
@@ -134,7 +134,7 @@
system(#("cd ",directory,"/html; lynx ",file,".html"))
else if (strstarteq(choiceViewing,"Xdvi"))
system(#("xdvi -geometry 847x570+0+0 -s 3 ",directory,"/",file,".dvi&"))
- else if (strstarteq(choiceViewing,"Xemacs"))
+ else if (strstarteq(choiceViewing,"Emacs"))
system(#(editor," ",directory,"/",file,".txt&"));
};

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ai,v 1.5 2002/05/03 23:32:13 jtb Exp $
--- files.ct.orig Wed May 1 15:38:51 2002
+++ files.ct Wed May 1 15:39:13 2002
@@ -24,8 +24,8 @@
# include "dfr8.h"
#else
extern "C" {
-# include "df.h"
-# include "mfhdf.h"
+# include "hdf/df.h"
+# include "hdf/mfhdf.h"
}
#endif
#ifndef __GNUC__