oksh: update to 6.5

Note release version goes backwards. Version now follows openbsd version
numbering.

No changes available.
Patched to eliminate compilation warnings on netbsd.
This commit is contained in:
maya 2019-07-24 11:15:41 +00:00
parent a5d34387ad
commit 143ce50d20
4 changed files with 45 additions and 9 deletions

View file

@ -1,16 +1,16 @@
# $NetBSD: Makefile,v 1.1 2018/11/09 22:15:12 maya Exp $
# $NetBSD: Makefile,v 1.2 2019/07/24 11:15:41 maya Exp $
DISTNAME= oksh-20181009
DISTNAME= oksh-6.5
CATEGORIES= shells
MASTER_SITES= ${MASTER_SITE_GITHUB:=ibara/}
GITHUB_TAG= ${PKGVERSION_NOREV}
GITHUB_TAG= ${DISTNAME}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/ibara/oksh/
COMMENT= Portable OpenBSD ksh(1)
LICENSE= original-bsd
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
WRKSRC= ${WRKDIR}/oksh-${PKGNAME_NOREV}
GNU_CONFIGURE= yes

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.1 2018/11/09 22:15:12 maya Exp $
$NetBSD: distinfo,v 1.2 2019/07/24 11:15:41 maya Exp $
SHA1 (oksh-20181009-20181009.tar.gz) = decc85574c362889f7f9eb74b1ae25eea0241f3c
RMD160 (oksh-20181009-20181009.tar.gz) = d2c8217d9271ac9ac9ed1f10a2884fdc3ba537a1
SHA512 (oksh-20181009-20181009.tar.gz) = ba4d5d00e5a45ed035da1e4129163e9043f84a662bd100972754fe330ee7811b8b448321d202e61a63b1cc36ceac8df005a17e1473ac842cb536b1e50122e29b
Size (oksh-20181009-20181009.tar.gz) = 301271 bytes
SHA1 (oksh-6.5.tar.gz) = 80ca09d09a430b70ad38d7b3098d642560f5323e
RMD160 (oksh-6.5.tar.gz) = d774a686fc76f6671cc9d6be542c6d4f0afcd07c
SHA512 (oksh-6.5.tar.gz) = 473fc21e829018d3dd2977ae2909d95488a0c8f7a293778fe1e73f8e047cf46da2e3afe4786e95ff650fc7d207da342e0b2a8f8ccd98aa5957765a25bb844f98
Size (oksh-6.5.tar.gz) = 301894 bytes
SHA1 (patch-io.c) = e231fe9fbef5df7f7a73facbedb0260134e8158c
SHA1 (patch-portable.h) = 9b4cdc1511db6093a0fe24c101bd4491c5df2f49

View file

@ -0,0 +1,12 @@
$NetBSD: patch-io.c,v 1.1 2019/07/24 11:15:41 maya Exp $
--- io.c.orig 2019-04-10 23:55:43.000000000 +0000
+++ io.c
@@ -10,6 +10,7 @@
#include <errno.h>
#include <fcntl.h>
#include <string.h>
+#include <stdlib.h>
#include <unistd.h>
#include "sh.h"

View file

@ -0,0 +1,22 @@
$NetBSD: patch-portable.h,v 1.1 2019/07/24 11:15:41 maya Exp $
Avoid re-defining timespecsub on netbsd, that already has it.
--- portable.h.orig 2019-04-10 23:55:43.000000000 +0000
+++ portable.h
@@ -151,6 +151,7 @@
((tsp)->tv_nsec cmp (usp)->tv_nsec) : \
((tsp)->tv_sec cmp (usp)->tv_sec))
+#ifndef timespecsub
#define timespecsub(tsp, usp, vsp) \
do { \
(vsp)->tv_sec = (tsp)->tv_sec - (usp)->tv_sec; \
@@ -160,6 +161,7 @@
(vsp)->tv_nsec += 1000000000L; \
} \
} while (0)
+#endif
#endif /* !__OpenBSD__ */
#if !defined(HAVE_ST_MTIM) && !defined(HAVE_ST_MTIMESPEC)