Initial import of mrproject-0.5.1, a program to manage project development.

This was provided by Martti Kuparinen, modified slightly by myself. This
also links the component plugins statically in mrproject, the idea taken
from the FreeBSD comments on the mrproject mailing lists by Joe Clarke.

Note that ORBit 0.5.13nb1 is necessary for this package to work properly
(so that a maximum of IOV_MAX iovecs are sent at a time to writev(2))

MrProject is a project management program that can help build project plans,
and track the progress of a project.
This commit is contained in:
agc 2002-03-23 10:59:08 +00:00
parent 610699adbb
commit 14560dc72f
6 changed files with 211 additions and 0 deletions

2
devel/mrproject/DESCR Normal file
View file

@ -0,0 +1,2 @@
MrProject is a project management program that can help build project plans,
and track the progress of a project.

38
devel/mrproject/Makefile Normal file
View file

@ -0,0 +1,38 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/03/23 10:59:08 agc Exp $
#
DISTNAME= mrproject-0.5.1
CATEGORIES= devel
MASTER_SITES= ftp://ftp.codefactory.se/pub/software/mrproject/source/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://mrproject.codefactory.se/
COMMENT= Project management program
USE_BUILDLINK_ONLY= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --sysconfdir=${LOCALBASE}/etc/mrproject
CONFIGURE_ARGS+= --without-python
CFLAGS+= -I${BUILDLINK_DIR}/include/gconf/1
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
post-extract:
# This is an ugly hack to fix the missing file error in 0.5.1
${TOUCH} ${WRKSRC}/libmrproject/Composer.h
post-patch:
cd ${WRKSRC}/client/components && \
for f in `${FIND} ${WRKSRC} -name '*.oaf' -print`; do \
${MV} $$f $$f.pre && \
${SED} -e 's|/opt/gnome|${PREFIX}|g' $$f.pre > $$f; \
done
.include "../../devel/GConf/buildlink.mk"
.include "../../devel/bonobo/buildlink.mk"
.include "../../devel/gal/buildlink.mk"
.include "../../devel/oaf/buildlink.mk"
.include "../../graphics/gdk-pixbuf/buildlink.mk"
.include "../../sysutils/gnome-vfs/buildlink.mk"
.include "../../x11/gnome-libs/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

126
devel/mrproject/PLIST Normal file
View file

@ -0,0 +1,126 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/03/23 10:59:08 agc Exp $
bin/mrproject
bin/mrproject-engine
bin/run-mrproject
lib/mrproject/components/libcalendar-component.a
lib/mrproject/components/libcalendar-component.la
lib/mrproject/components/libcalendar-component.so
lib/mrproject/components/libgantt-component.a
lib/mrproject/components/libgantt-component.la
lib/mrproject/components/libgantt-component.so
lib/mrproject/components/libmpx-file-filter.a
lib/mrproject/components/libmpx-file-filter.la
lib/mrproject/components/libmpx-file-filter.so
lib/mrproject/components/libnetwork-component.a
lib/mrproject/components/libnetwork-component.la
lib/mrproject/components/libnetwork-component.so
lib/mrproject/components/libresource-component.a
lib/mrproject/components/libresource-component.la
lib/mrproject/components/libresource-component.so
lib/mrproject/components/libtask-dialog-component.a
lib/mrproject/components/libtask-dialog-component.la
lib/mrproject/components/libtask-dialog-component.so
lib/mrproject/components/libxml-file-filter.a
lib/mrproject/components/libxml-file-filter.la
lib/mrproject/components/libxml-file-filter.so
man/man1/mrproject-engine.1
man/man1/mrproject.1
man/man1/run-mrproject.1
share/gnome/apps/Applications/mrproject.desktop
share/gnome/ui/GNOME_MrProject_CalendarComponent.ui
share/gnome/ui/GNOME_MrProject_Client.ui
share/gnome/ui/GNOME_MrProject_GanttComponent.ui
share/gnome/ui/GNOME_MrProject_ResourceComponent.ui
share/idl/GNOME_MrProject.idl
share/idl/GNOME_MrProject_AllocationManager.idl
share/idl/GNOME_MrProject_Common.idl
share/idl/GNOME_MrProject_Engine.idl
share/idl/GNOME_MrProject_FileFilter.idl
share/idl/GNOME_MrProject_Project.idl
share/idl/GNOME_MrProject_ResourceManager.idl
share/idl/GNOME_MrProject_Shell.idl
share/idl/GNOME_MrProject_TaskDialog.idl
share/idl/GNOME_MrProject_TaskManager.idl
share/images/mrproject/16_copy.png
share/images/mrproject/16_cut.png
share/images/mrproject/16_new.png
share/images/mrproject/16_paste.png
share/images/mrproject/16_print.png
share/images/mrproject/16_properties.png
share/images/mrproject/16_revert.png
share/images/mrproject/16_save.png
share/images/mrproject/16_save_as.png
share/images/mrproject/16_send_to.png
share/images/mrproject/24_add_resource.png
share/images/mrproject/24_add_task.png
share/images/mrproject/24_assign.png
share/images/mrproject/24_calendar.png
share/images/mrproject/24_chain.png
share/images/mrproject/24_delete_resource.png
share/images/mrproject/24_delete_task.png
share/images/mrproject/24_groups.png
share/images/mrproject/24_indent_task.png
share/images/mrproject/24_new.png
share/images/mrproject/24_open.png
share/images/mrproject/24_print.png
share/images/mrproject/24_save.png
share/images/mrproject/24_task_down.png
share/images/mrproject/24_task_up.png
share/images/mrproject/24_unchain.png
share/images/mrproject/24_unindent_task.png
share/images/mrproject/24_zoom_fit.png
share/images/mrproject/calendar.png
share/images/mrproject/cflogo_bw_67x87.png
share/images/mrproject/gantt.png
share/images/mrproject/network.png
share/images/mrproject/resources.png
share/locale/da/LC_MESSAGES/mrproject.mo
share/locale/de/LC_MESSAGES/mrproject.mo
share/locale/el/LC_MESSAGES/mrproject.mo
share/locale/es/LC_MESSAGES/mrproject.mo
share/locale/fr/LC_MESSAGES/mrproject.mo
share/locale/ja/LC_MESSAGES/mrproject.mo
share/locale/nn/LC_MESSAGES/mrproject.mo
share/locale/no/LC_MESSAGES/mrproject.mo
share/locale/pl/LC_MESSAGES/mrproject.mo
share/locale/pt/LC_MESSAGES/mrproject.mo
share/locale/ru/LC_MESSAGES/mrproject.mo
share/locale/sk/LC_MESSAGES/mrproject.mo
share/locale/sv/LC_MESSAGES/mrproject.mo
share/locale/tr/LC_MESSAGES/mrproject.mo
share/locale/zh_CN/LC_MESSAGES/mrproject.mo
share/locale/zh_TW/LC_MESSAGES/mrproject.mo
share/mime-info/mrproject.keys
share/mime-info/mrproject.mime
share/mrproject/gantt-component.etspec
share/mrproject/gantt-component.etstate
share/mrproject/gantt-timescale-dialog.glade
share/mrproject/gantt-zoom-dialog.glade
share/mrproject/group-dialog.glade
share/mrproject/new-project-dialog.glade
share/mrproject/preferences-dialog.glade
share/mrproject/project-properties-dialog.glade
share/mrproject/resource-component.etspec
share/mrproject/resource-component.etstate
share/mrproject/resource-filter-dialog-gui.glade
share/mrproject/resource-filter-table.etspec
share/mrproject/resource-filter-table.etstate
share/mrproject/task-dialog-alloc-table.etspec
share/mrproject/task-dialog-alloc-table.etstate
share/mrproject/task-dialog-gui.glade
share/oaf/GNOME_MrProject_CalendarComponent.oaf
share/oaf/GNOME_MrProject_GanttComponent.oaf
share/oaf/GNOME_MrProject_MpxFileFilter.oaf
share/oaf/GNOME_MrProject_NetworkComponent.oaf
share/oaf/GNOME_MrProject_ProjectEngine.oaf
share/oaf/GNOME_MrProject_ResourceComponent.oaf
share/oaf/GNOME_MrProject_TaskDialog.oaf
share/oaf/GNOME_MrProject_XmlFileFilter.oaf
share/pixmaps/gnome-application-x-mrproject.png
share/pixmaps/mrproject.png
@dirrm share/mrproject
@dirrm share/images/mrproject
@dirrm share/images
@dirrm share/gnome/apps/Applications
@dirrm lib/mrproject/components
@dirrm lib/mrproject

6
devel/mrproject/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2002/03/23 10:59:08 agc Exp $
SHA1 (mrproject-0.5.1.tar.gz) = 6ba92ea1a15b394f3cc4a2be68afff4e4377dbd6
Size (mrproject-0.5.1.tar.gz) = 854003 bytes
SHA1 (patch-aa) = 93a94ce463a8cd7cf94234063ba7e11377acd0b7
SHA1 (patch-ab) = 141e9aa53f12c4cf7de3e81cd56414c8843c1bea

View file

@ -0,0 +1,24 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/03/23 10:59:08 agc Exp $
--- run-mrproject.in 2002/03/19 12:45:48 1.1
+++ run-mrproject.in 2002/03/19 12:46:47
@@ -2,11 +2,14 @@
sysname=`uname -s`
-if [ "$sysname" = "SunOS" ]; then
- killcmd="pkill"
-else
- killcmd="killall"
-fi
+case "$sysname" in
+SunOS)
+ killcmd="pkill" ;;
+NetBSD)
+ killcmd="skill" ;;
+*)
+ killcmd="killall" ;;
+esac
if [ "@PREFIX@" != "NONE" ]; then
PATH=@PREFIX@/bin:$PATH

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1.1.1 2002/03/23 10:59:08 agc Exp $
--- client/Makefile.in 2002/03/22 14:06:14 1.1
+++ client/Makefile.in 2002/03/22 14:06:42
@@ -215,6 +215,10 @@
$(top_builddir)/util/libmrproject-utilx.la \
$(top_builddir)/util/libmrproject-corba-util.la \
$(top_builddir)/client/widgets/libwidgets.la \
+ $(top_builddir)/client/components/gantt/libgantt-component.la \
+ $(top_builddir)/client/components/network/libnetwork-component.la \
+ $(top_builddir)/client/components/resource/libresource-component.la \
+ $(top_builddir)/client/components/task-dialog/libtask-dialog-component.la \
$(top_builddir)/client/components/shell-component/libshell-component.la \
$(top_builddir)/client/manager-clients/libmanager-clients.la \
$(top_builddir)/libmrproject/libmrproject-interfaces.la