Update to 1.13.1:

Changes in version 1.13.1, released on August 10, 2014

    --- MAJOR NEW FEATURES ---
 * A complete apropos(1)/makewhatis(8)/man.cgi(8) suite
   based on SQLite3 is now included.
   CAVEAT: This also requires a working fts(3) implementation.
   If your system lacks that *and* you want apropos(1)/makewhatis(8),
   stay with 1.12.3 for now, then go to 1.12.4 and 1.13.2.
   [wiz: for this reason, the package does not enable these tools yet]
 * The roff(7) parser now provides an almost complete implementation
   of numerical expressions.
 * Warning and error messages have been improved in many ways.
   Almost all fatal errors were downgraded to normal errors and some
   even to warnings.  Almost all messages now mention the macro where
   the issue is detected and many indicate the workaround employed.
   The mandoc(1) manual now includes a list explaining all messages.
    --- MINOR NEW FEATURES ---
 * The roff(7) parser now supports the .ami (append to macro with
   indirectly specified name), .as (append to user-defined
   string), .dei (define macro with indirectly specified name),
   .ll (line length), and .rr (remove register) requests.
 * The roff(7) parser now supports string comparison and numerical
   conditionals in the .if and .ie requests.
 * The roff parser now fully supports the \B (validate numerical
   expression) and partially supports the \w (measure text width)
   escape sequences.
 * The terminal formatter now supports the \: (optional line break)
   escape sequence.
 * The roff parser now supports expansion of user-defined strings
   involving indirect references.
 * The roff(7) parser now handles some pre-defined read-only
   number registers that occur in the pod2man(1) preamble.
 * For backward compatibility, the mdoc(7) parser and formatters
   now support the obsolete macros .En, .Es, .Fr, and .Ot.
 * The mdoc(7) formatter non partially supports .Bd -centered.
 * tbl(7) now handles leading and trailing vertical lines.
 * The build system now provides fallback versions of strcasestr(3)
   and strsep(3) for systems lacking them.
 * The mdoc(7) manual now explains how various standards
   supported by the .St macro are related to each other.
    --- BUGFIXES ---
 * In the roff(7) parser, several bugs were fixed with respect
   to closing conditional blocks on macro lines.
 * Parsing of roff(7) identifiers and escape sequences was improved
   in multiple respects.
 * In the mdoc(7) parser, the handling of defective document
   prologues was improved in multiple ways.
 * The mdoc(7) parser no longer skips content before the first section
   header, and it no longer deletes non-.% content from .Rs blocks.
 * In the mdoc(7) parser, a crash was fixed related to weird .Sh headers.
 * In the mdoc(7) parser, handling of .Sm with missing or invalid
   arguments was corrected.
 * In the mdoc(7) parser, trailing punctuation at the end of partial
   implicit macros no longer triggers end-of-sentence spacing.
 * In the terminal formatter, two crashes were fixed: one triggered by
   excessive indentation and another by excessively long .Nm arguments.
 * In the terminal formatter, a floating point rounding bug was
   fixed that sometimes caused an off-by-one error in indentation.
 * In the UTF-8 formatter, rendering of accents, breakable hyphens,
   and non-breakable spaces was corrected.
 * In the HTML formatter, encoding of special characters was
   corrected in multiple respects.
 * In the mdoc(7) formatter, rendering of .Ex and .Rv was
   improved for various edge cases.
 * In the mdoc(7) formatter, handling of empty .Bl -inset item
   heads was improved.
 * In the man(7) formatter, some bugs were fixed with respect
   to same-line detection in the context of .TP and .nf macros,
   and the indentation of .IP and .TP blocks was improved.
 * The mandoc(3) library no longer prints to stderr.
    --- THANKS TO ---
   Abhinav Upadhyay (NetBSD), Andreas Voegele, Anthony Bentley (OpenBSD),
   Christian Weisgerber (OpenBSD), Havard Eidnes (NetBSD), Jan Stary,
   Jason McIntyre (OpenBSD), Jeremie Courreges-Anglas (OpenBSD),
   Joerg Sonnenberger (NetBSD), Juan Francisco Cantero Hurtado (OpenBSD),
   Marc Espie (OpenBSD), Matthias Scheler (NetBSD), Pascal Stumpf (OpenBSD),
   Paul Onyschuk (Alpine Linux), Sebastien Marie, Steffen Nurpmeso,
   Stuart Henderson (OpenBSD), Ted Unangst (OpenBSD), Theo de Raadt (OpenBSD),
   Thomas Klausner (NetBSD), and Ulrich Spoerlein (FreeBSD)
   for reporting bugs and missing features.
This commit is contained in:
wiz 2014-08-10 20:51:01 +00:00
parent 06c49b8882
commit 14a55b3f89
7 changed files with 35 additions and 91 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.42 2014/01/06 17:43:50 tez Exp $
# $NetBSD: Makefile,v 1.43 2014/08/10 20:51:01 wiz Exp $
DISTNAME= mdocml-1.12.3
PKGREVISION= 1
DISTNAME= mdocml-1.13.1
CATEGORIES= textproc devel
MASTER_SITES= http://mdocml.bsd.lv/snapshots/
@ -10,7 +9,7 @@ HOMEPAGE= http://mdocml.bsd.lv/
COMMENT= Convert man pages from mdoc, man, and tbl to txt, html, ps, or pdf
LICENSE= 2-clause-bsd # not exactly, but near enough
MAKE_FLAGS+= PREFIX=${PREFIX} DBLIB=${BDB_LIBS:Q}
MAKE_FLAGS+= PREFIX=${PREFIX}
CONFLICTS= man-pages-[0-9]*
@ -30,5 +29,10 @@ MAKE_FLAGS+= STATIC=
post-extract:
${CP} -p ${FILESDIR}/*.c ${WRKSRC}
.include "../../mk/bdb.buildlink3.mk"
post-install:
cd ${DESTDIR}${PREFIX}/bin && mv preconv mandoc-preconv
cd ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1 && mv preconv.1 mandoc-preconv.1
cd ${DESTDIR}${PREFIX}/${PKGMANDIR}/man7 && mv roff.7 mandoc-roff.7
.include "../../databases/sqlite3/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,15 +1,19 @@
@comment $NetBSD: PLIST,v 1.10 2014/03/19 21:48:54 wiz Exp $
@comment $NetBSD: PLIST,v 1.11 2014/08/10 20:51:01 wiz Exp $
bin/demandoc
bin/mandoc
bin/mandoc-preconv
include/mandoc/man.h
include/mandoc/mandoc.h
include/mandoc/mandoc_aux.h
include/mandoc/mdoc.h
lib/mandoc/libmandoc.a
man/man1/demandoc.1
man/man1/mandoc-preconv.1
man/man1/mandoc.1
man/man3/mandoc.3
man/man3/mandoc_escape.3
man/man3/mandoc_malloc.3
man/man3/mchars_alloc.3
man/man3/tbl.3
man/man7/eqn.7
man/man7/man.7

View file

@ -1,10 +1,8 @@
$NetBSD: distinfo,v 1.33 2014/01/06 17:43:50 tez Exp $
$NetBSD: distinfo,v 1.34 2014/08/10 20:51:01 wiz Exp $
SHA1 (mdocml-1.12.3.tar.gz) = 6a74b4e4b54a20b8022f05236e2294ad2915e5d7
RMD160 (mdocml-1.12.3.tar.gz) = 0a9a717ddf9d32c4ce1be8e51659932c5ccf2b8b
Size (mdocml-1.12.3.tar.gz) = 292544 bytes
SHA1 (patch-Makefile) = 569fdf24dff306c6c7222a3807e99d9ae1bb0ce6
SHA1 (patch-apropos__db.c) = efde1e020c84307e8549cf8b3e25668023fb4d34
SHA1 (patch-mdoc_validate.c) = 270d754613fa4f1e079cc047593d1eb05c9fc7a9
SHA1 (mdocml-1.13.1.tar.gz) = 50b12980e74eb705354775bd42a1a5d1910b8399
RMD160 (mdocml-1.13.1.tar.gz) = f517562dac1d8cdfd3df6b2dbb2e02b175fa25e2
Size (mdocml-1.13.1.tar.gz) = 317389 bytes
SHA1 (patch-Makefile) = f4a62a80c7d18c71ecd18e3c0c39a7071de408c7
SHA1 (patch-preconv.1) = 92787c58f451e1d247a25bbe136f188bf42e4c73
SHA1 (patch-roff.7) = 9b6033b5ec92c8e8c827fe79aff30228f7c2fc2f
SHA1 (patch-roff.7) = a975015fc4b0801f8c09c22ff4e27efdf585661a

View file

@ -1,25 +1,16 @@
$NetBSD: patch-Makefile,v 1.6 2013/10/11 14:45:18 wiz Exp $
$NetBSD: patch-Makefile,v 1.7 2014/08/10 20:51:01 wiz Exp $
Install preconv and roff with 'mandoc-' prefix to avoid conflict with groff.
Disable apropos, makewhatis, and man.cgi until mdocml includes a
portable fts implementation.
--- Makefile.orig 2013-10-05 14:09:07.000000000 +0000
--- Makefile.orig 2014-08-10 17:26:46.000000000 +0000
+++ Makefile
@@ -322,12 +322,15 @@ install: all
mkdir -p $(DESTDIR)$(MANDIR)/man1
mkdir -p $(DESTDIR)$(MANDIR)/man3
mkdir -p $(DESTDIR)$(MANDIR)/man7
- $(INSTALL_PROGRAM) mandoc preconv demandoc $(DESTDIR)$(BINDIR)
+ $(INSTALL_PROGRAM) mandoc demandoc $(DESTDIR)$(BINDIR)
+ $(INSTALL_PROGRAM) preconv $(DESTDIR)$(BINDIR)/mandoc-preconv
$(INSTALL_LIB) libmandoc.a $(DESTDIR)$(LIBDIR)
$(INSTALL_LIB) man.h mdoc.h mandoc.h $(DESTDIR)$(INCLUDEDIR)
- $(INSTALL_MAN) mandoc.1 preconv.1 demandoc.1 $(DESTDIR)$(MANDIR)/man1
+ $(INSTALL_MAN) mandoc.1 demandoc.1 $(DESTDIR)$(MANDIR)/man1
+ $(INSTALL_MAN) preconv.1 $(DESTDIR)$(MANDIR)/man1/mandoc-preconv.1
$(INSTALL_MAN) mandoc.3 tbl.3 $(DESTDIR)$(MANDIR)/man3
- $(INSTALL_MAN) man.7 mdoc.7 roff.7 eqn.7 tbl.7 mandoc_char.7 $(DESTDIR)$(MANDIR)/man7
+ $(INSTALL_MAN) man.7 mdoc.7 eqn.7 tbl.7 mandoc_char.7 $(DESTDIR)$(MANDIR)/man7
+ $(INSTALL_MAN) roff.7 $(DESTDIR)$(MANDIR)/man7/mandoc-roff.7
$(INSTALL_DATA) example.style.css $(DESTDIR)$(EXAMPLEDIR)
@@ -57,7 +57,7 @@ INSTALL_MAN = $(INSTALL_DATA)
# Be careful: the fts(3) implementation in glibc is broken on 32bit
# machines, see: https://sourceware.org/bugzilla/show_bug.cgi?id=15838
#
-BUILD_TARGETS += db-build
+#BUILD_TARGETS += db-build
installcgi: all
# The remaining settings in this section
# are only relevant if db-build is enabled.

View file

@ -1,21 +0,0 @@
$NetBSD: patch-apropos__db.c,v 1.4 2013/12/31 11:06:30 wiz Exp $
SunOS fix.
--- apropos_db.c.orig 2013-10-05 15:09:07.000000000 +0100
+++ apropos_db.c 2013-12-29 19:07:21.000000000 +0000
@@ -141,6 +146,14 @@
const struct expr *, size_t terms,
struct mchars *, int);
+#ifdef __sun
+#define strsep pkgsrc_strsep
+#define strcasestr pkgsrc_strcasestr
+
+#include "strsep.c"
+#include "strcasestr.c"
+#endif
+
/*
* Open the keyword mandoc-db database.
*/

View file

@ -1,32 +0,0 @@
$NetBSD: patch-mdoc_validate.c,v 1.1 2014/01/06 17:43:50 tez Exp $
Solaris, Mingw32 & OS X prior to 10.7 are missing strnlen
--- mdoc_validate.c.orig Mon Jan 6 10:25:04 2014
+++ mdoc_validate.c Mon Jan 6 10:36:31 2014
@@ -1863,6 +1863,15 @@
return(1);
}
+#if defined(__MINGW32__) ||defined(__sun) || defined(__APPLE__)
+static size_t p_strnlen(const char *s, size_t maxlen) {
+ const char *end = memchr(s, 0, maxlen);
+ return end ? (size_t)(end - s) : maxlen;
+}
+#else
+ # define p_strnlen strnlen
+#endif
+
/*
* For some arguments of some macros,
* convert all breakable hyphens into ASCII_HYPH.
@@ -1893,7 +1902,7 @@
if (MDOC_TEXT != nch->type)
continue;
cp = nch->string;
- if (3 > strnlen(cp, 3))
+ if (3 > p_strnlen(cp, 3))
continue;
while ('\0' != *(++cp))
if ('-' == *cp &&

View file

@ -1,13 +1,13 @@
$NetBSD: patch-roff.7,v 1.3 2013/12/31 11:06:30 wiz Exp $
$NetBSD: patch-roff.7,v 1.4 2014/08/10 20:51:01 wiz Exp $
Install preconv and roff with 'mandoc-' prefix to avoid conflict with groff.
--- roff.7.orig 2013-12-28 23:28:23.000000000 +0000
--- roff.7.orig 2014-08-08 20:40:44.000000000 +0000
+++ roff.7
@@ -16,10 +16,10 @@
.\" OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
.\"
.Dd $Mdocdate: December 26 2013 $
.Dd $Mdocdate: July 7 2014 $
-.Dt ROFF 7
+.Dt MANDOC-ROFF 7
.Os