Update www/squid package to 3.0.17 (3.0.STABLE17).
Changes to squid-3.0.STABLE17 (27 Jul 2009): - Bug 2680 regression: Crash after rotate with no helpers running - Bug 2710: squid_kerb_auth non-terminated string - Bug 2679: strsep and strtoll detection failure - Bug 2674: Remove limit on HTTP headers read. - Bug 2659: String length overflows on append, leading to segfaults - Bug 2620: Invalid HTTP response codes causes segfault - Bug 2080: wbinfo_group.pl - false positive under certain conditions - Bug 1087: ESI processor not quoting attributes correctly. - Fix: issue with AUFS/UFS/DiskD writing objects to disk cache - Several small build issues with previous release.
This commit is contained in:
parent
b8c580e554
commit
14c9240704
3 changed files with 6 additions and 23 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.13 2009/07/01 02:17:46 taca Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2009/07/27 16:13:26 taca Exp $
|
||||
|
||||
DISTNAME= squid-3.0.STABLE16
|
||||
DISTNAME= squid-3.0.STABLE17
|
||||
PKGNAME= ${DISTNAME:S/STABLE//}
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${SQUID_MASTER_SITES} \
|
||||
|
|
|
@ -1,9 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.11 2009/07/20 10:49:16 tron Exp $
|
||||
$NetBSD: distinfo,v 1.12 2009/07/27 16:13:26 taca Exp $
|
||||
|
||||
SHA1 (squid-3.0.STABLE16.tar.bz2) = d4438516e63a8ef232eac8526b7b4be27fdeca1f
|
||||
RMD160 (squid-3.0.STABLE16.tar.bz2) = 0f99505962a8ea2cedca57b134828b94ba8b7426
|
||||
Size (squid-3.0.STABLE16.tar.bz2) = 1796458 bytes
|
||||
SHA1 (patch-aa) = a9ca6f8536262a7645f8efdcbcd05b9c190b57df
|
||||
SHA1 (squid-3.0.STABLE17.tar.bz2) = 9c619fcf7d2d62baaff1c718bf4f388b920675fb
|
||||
RMD160 (squid-3.0.STABLE17.tar.bz2) = 9d12a9df21b041d7d171691c076324f90b195ae6
|
||||
Size (squid-3.0.STABLE17.tar.bz2) = 1798957 bytes
|
||||
SHA1 (patch-ad) = 5e126ffb1427f986484c3c32baf5ae3da409262d
|
||||
SHA1 (patch-ae) = bc38307f8039a7bc63f1e1572df30d20ee161b8a
|
||||
SHA1 (patch-ah) = ab3b9add2a8836a5d5307645eb547d732e6496d0
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.6 2009/07/20 10:49:16 tron Exp $
|
||||
|
||||
Build fix for NetBSD/amd64 taken from here:
|
||||
http://www.squid-cache.org/Versions/v3/3.1/changesets/b9648.patch
|
||||
|
||||
--- src/client_side.cc.orig 2009-07-19 06:11:13.000000000 +0100
|
||||
+++ src/client_side.cc 2009-07-20 11:29:30.000000000 +0100
|
||||
@@ -2222,7 +2222,7 @@
|
||||
// when we read chunked requests, the entire body is buffered
|
||||
// XXX: this check ignores header size and its limits.
|
||||
if (conn->in.dechunkingState == ConnStateData::chunkParsing)
|
||||
- return conn->in.notYetUsed < Config.maxChunkedRequestBodySize;
|
||||
+ return ((int64_t)conn->in.notYetUsed) < Config.maxChunkedRequestBodySize;
|
||||
|
||||
return conn->in.notYetUsed >= Config.maxRequestHeaderSize ? 0 : 1;
|
||||
}
|
Loading…
Reference in a new issue