Initial import of FreeBSD's netpbm port into the NetBSD

packages system.
This commit is contained in:
agc 1997-10-15 15:12:12 +00:00
parent 6a3b8142d2
commit 14ca5ed644
12 changed files with 1052 additions and 0 deletions

21
graphics/netpbm/Makefile Normal file
View file

@ -0,0 +1,21 @@
# New ports collection makefile for: netpbm
# Version required: 1mar1994
# Date created: ?
# Whom: jmz (original)
#
# FreeBSD Id: Makefile,v 1.8 1996/11/18 11:28:55 asami Exp
#
DISTNAME= netpbm
PKGNAME= netpbm-94.3.1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.x.org/R5contrib/
DISTFILES= netpbm-1mar1994.tar.gz
MAINTAINER= asami@FreeBSD.ORG
LIB_DEPENDS= tiff\\.3\\.:${PORTSDIR}/graphics/tiff
USE_IMAKE= yes
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (netpbm-1mar1994.tar.gz) = 55f505b09e69a5db8f08844435282dfb

View file

@ -0,0 +1,91 @@
*** Imakefile.orig Mon Dec 13 13:01:21 1993
--- Imakefile Wed Sep 21 21:26:49 1994
***************
*** 22,64 ****
#endif
all::
! stamp-date
MakeSubdirs($(SUBDIRS))
DependSubdirs($(SUBDIRS))
World::
! @echo ""
! @echo "Building PBMPLUS"
! @echo ""
! @date
! @echo ""
$(MAKE) $(MFLAGS) Makefiles
! $(MAKE) $(MFLAGS) clean
! $(MAKE) $(MFLAGS) includes
! $(MAKE) $(MFLAGS) depend
! $(MAKE) $(MFLAGS)
! @echo ""
! @date
! @echo ""
! @echo "Full build of PBMPLUS complete."
! @echo ""
Everything::
! @echo ""
! @echo "Rebuilding PBMPLUS"
! @echo ""
! @date
! @echo ""
! $(MAKE) $(MFLAGS) Makefiles
! $(MAKE) $(MFLAGS) includes
! $(MAKE) $(MFLAGS) depend
! $(MAKE) $(MFLAGS)
! @echo ""
! @date
! @echo ""
! @echo "Rebuild of PBMPLUS complete."
! @echo ""
#if InstallIncludes
InstallMultipleFlags(pbmplus.h,$(PBMPLUSDIR)$(PBMPLUSINCDIR),$(INSTINCFLAGS))
--- 22,64 ----
#endif
all::
! ./stamp-date
MakeSubdirs($(SUBDIRS))
DependSubdirs($(SUBDIRS))
World::
! @echo ""
! @echo "Building PBMPLUS"
! @echo ""
! @date
! @echo ""
$(MAKE) $(MFLAGS) Makefiles
! $(MAKE) $(MFLAGS) clean
! $(MAKE) $(MFLAGS) includes
! $(MAKE) $(MFLAGS) depend
! $(MAKE) $(MFLAGS)
! @echo ""
! @date
! @echo ""
! @echo "Full build of PBMPLUS complete."
! @echo ""
Everything::
! @echo ""
! @echo "Rebuilding PBMPLUS"
! @echo ""
! @date
! @echo ""
! $(MAKE) $(MFLAGS) Makefiles
! $(MAKE) $(MFLAGS) includes
! $(MAKE) $(MFLAGS) depend
! $(MAKE) $(MFLAGS)
! @echo ""
! @date
! @echo ""
! @echo "Rebuild of PBMPLUS complete."
! @echo ""
#if InstallIncludes
InstallMultipleFlags(pbmplus.h,$(PBMPLUSDIR)$(PBMPLUSINCDIR),$(INSTINCFLAGS))

View file

@ -0,0 +1,19 @@
*** pbm/libpbm1.c.orig Mon Jan 10 09:37:22 1994
--- pbm/libpbm1.c Fri Oct 14 17:01:15 1994
***************
*** 332,338 ****
char* reason;
{
#ifndef A_STRERROR
! extern char* sys_errlist[];
#endif /* A_STRERROR */
extern int errno;
char* e;
--- 332,338 ----
char* reason;
{
#ifndef A_STRERROR
! /* extern char* sys_errlist[]; */
#endif /* A_STRERROR */
extern int errno;
char* e;

View file

@ -0,0 +1,28 @@
*** pbm/pbmtext.c~ Wed Oct 27 08:27:04 1993
--- pbm/pbmtext.c Thu Nov 24 23:59:38 1994
***************
*** 105,114 ****
else
{ /* Read text from stdin. */
lines = 0;
! while ( gets( buf ) != NULL )
{
int l;
fix_control_chars( buf );
l = strlen( buf );
if ( lines >= maxlines )
--- 105,117 ----
else
{ /* Read text from stdin. */
lines = 0;
! while ( fgets( buf , 5000, stdin) != NULL )
{
int l;
+ char *nl = strchr (buf, '\n');
+ if (nl)
+ *nl = 0;
fix_control_chars( buf );
l = strlen( buf );
if ( lines >= maxlines )

View file

@ -0,0 +1,243 @@
--- ./pnm/Imakefile.org Sun Feb 5 22:37:44 1995
+++ ./pnm/Imakefile Sun Feb 5 22:37:46 1995
@@ -20,7 +20,7 @@
#if BuildLibTiff
CURRENTLIBS = $(LIBTIFF) $(LIBPNM) $(LIBPPM) $(LIBPGM) $(LIBPBM)
CURRENTDEPLIBS = $(DEPLIBTIFF) $(DEPLIBPNM) $(DEPLIBPPM) $(DEPLIBPGM) $(DEPLIBPBM)
- INCLUDES = -I.. -I$(PBMDIR) -I$(PGMDIR) -I$(PPMDIR) -I$(TIFFDIR)
+ INCLUDES = -I.. -I$(PBMDIR) -I$(PGMDIR) -I$(PPMDIR) -I$(TIFFINCDIR)
DEFINES = -DLIBTIFF
MERGE = pnmmerge
TIFFMAN1 = tifftopnm.1 pnmtotiff.1
@@ -60,6 +60,7 @@
pnmtoddif.c pnmtofits.c pnmtops.c pnmtorast.c pnmtosgi.c \
pnmtosir.c pnmtoxwd.c \
rasttopnm.c sgitopnm.c sirtopnm.c xwdtopnm.c zeisstopnm.c \
+ pnmgamma.c pnmrotate.c pnmshear.c \
$(TIFFSRCS)
OBJS = fitstopnm.o giftopnm.o \
@@ -70,6 +71,7 @@
pnmtoddif.o pnmtofits.o pnmtops.o pnmtorast.o pnmtosgi.o \
pnmtosir.o pnmtoxwd.o \
rasttopnm.o sgitopnm.o sirtopnm.o xwdtopnm.o zeisstopnm.o \
+ pnmgamma.o pnmrotate.o pnmshear.o \
$(TIFFOBJS)
BINS = fitstopnm giftopnm \
@@ -80,6 +82,7 @@
pnmtoddif pnmtofits pnmtops pnmtorast pnmtosgi \
pnmtosir pnmtoxwd \
rasttopnm sgitopnm sirtopnm xwdtopnm zeisstopnm \
+ pnmgamma pnmrotate pnmshear \
$(TIFFBINS)
includes:: anytopnm.script pnmindex.script pnmmargin.script pnmsmooth.script \
@@ -168,9 +168,9 @@
#endif
#if InstallManuals
-InstallMultipleMan($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1)
-InstallMultipleMan($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3)
-InstallMultipleMan($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5)
+InstallMultipleManSuff($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1,1)
+InstallMultipleManSuff($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3,3)
+InstallMultipleManSuff($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5,5)
#endif
#if InstallLibraries
--- ./Imakefile.org Sun Feb 5 22:36:43 1995
+++ ./Imakefile Sun Feb 5 22:37:45 1995
@@ -16,7 +16,7 @@
#define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS)'
#if BuildLibTiff
-SUBDIRS = TiffDir PbmDir PgmDir PpmDir PnmDir
+SUBDIRS = PbmDir PgmDir PpmDir PnmDir
#else
SUBDIRS = PbmDir PgmDir PpmDir PnmDir
#endif
--- Pbmplus.tmpl.orig Mon Oct 4 02:13:09 1993
+++ Pbmplus.tmpl Sun Feb 5 23:34:38 1995
/* Imake template and rules for PBMPLUS
*
* Copyright (C) 1991 Rainer Klute
@@ -28,6 +28,10 @@
* By the way, you must have at least version 2.4 of libtiff. Earlier
* versions will not work.
*/
+/*
+ * Note: I changed this file and some Imakefiles to use the installed
+ * libtiff in /usr/local instad FreeBSD. - Satoshi
+ */
#ifndef BuildLibTiff
#define BuildLibTiff YES
#endif
@@ -43,10 +47,10 @@
#define InstallManuals YES
#endif
#ifndef InstallLibraries
-#define InstallLibraries NO
+#define InstallLibraries YES
#endif
#ifndef InstallIncludes
-#define InstallIncludes NO
+#define InstallIncludes YES
#endif
/* CONFIGURE: Normally the Imakefiles build and install separate binaries for
@@ -63,7 +67,7 @@
* until you do the install.
*/
#ifndef InstallMerged
-#define InstallMerged NO
+#define InstallMerged YES
#endif
@@ -75,7 +79,7 @@
#define PbmplusBinDir $(BINDIR)
#endif
#ifndef PbmplusManDir
-#define PbmplusManDir $(MANDIR)
+#define PbmplusManDir $(MANPATH)
#endif
#ifndef PbmplusLibDir
#define PbmplusLibDir $(USRLIBDIR)
@@ -100,7 +104,10 @@
#define PnmDir TOPDIR/pnm
#endif
#ifndef TiffDir
-#define TiffDir TOPDIR/libtiff
+#define TiffDir /usr/local/lib
+#endif
+#ifndef TiffIncDir
+#define TiffIncDir /usr/local/include
#endif
/* Libraries: */
@@ -117,7 +124,7 @@
#define LibPnm $(PNMDIR)/libpnm.a
#endif
#ifndef LibTiff
-#define LibTiff $(TIFFDIR)/libtiff.a
+#define LibTiff -L$(TIFFDIR) -ltiff
#endif
/* Dependency libraries: */
@@ -134,7 +141,7 @@
#define DepLibPnm LibPnm
#endif
#ifndef DepLibTiff
-#define DepLibTiff LibTiff
+#define DepLibTiff $(TIFFDIR)/libtiff.a
#endif
PBMPLUSDIR = PbmplusDir
@@ -148,6 +155,7 @@
PPMDIR = PpmDir
PNMDIR = PnmDir
TIFFDIR = TiffDir
+ TIFFINCDIR = TiffIncDir
LIBPBM = LibPbm
LIBPGM = LibPgm
@@ -166,7 +174,7 @@
#define InstallPbmplusPrograms(list,dest,flags) @@\
install:: list @@\
MakeDir($(DESTDIR)dest) @@\
- @case '${MFLAGS}' in *[i]*) set +e;; esac; \ @@\
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; @@\
for i in list; do \ @@\
(set -x; cd $(DESTDIR)dest; $(RM) $$i; \ @@\
$(LN) $(MERGE) $$i); \ @@\
@@ -181,14 +189,14 @@
#endif /* NormalPbmplusProgramTarget */
#ifndef NormalPbmplusMathProgramTarget
-#define NormalPbmplusMathProgramTarget(program) \ @@\
+#define NormalPbmplusMathProgramTarget(program) @@\
NormalPbmplusProgramTarget(program)
#endif /* NormalPbmplusMathProgramTarget */
#else
#ifndef NormalPbmplusProgramTarget
-#define NormalPbmplusProgramTarget(program) \ @@\
+#define NormalPbmplusProgramTarget(program) @@\
NormalProgramTarget(program,program.o,$(CURRENTDEPLIBS),$(CURRENTLIBS),)
#endif /* NormalPbmplusProgramTarget */
@@ -201,7 +209,7 @@
#define InstallPbmplusPrograms(list,dest,flags) @@\
install:: list @@\
MakeDir($(DESTDIR)dest) @@\
- @case '${MFLAGS}' in *[i]*) set +e;; esac; \ @@\
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; @@\
for i in list; do \ @@\
(set -x; $(RM) $(DESTDIR)dest/$$i; \ @@\
$(INSTALL) -c flags $$i $(DESTDIR)dest); \ @@\
@@ -217,3 +223,18 @@
#endif /* InstallPbmplusPrograms */
#endif /* InstallMerged */
+
+#ifndef InstallMultipleManSuff
+#define InstallMultipleManSuff(list,dest,suff) @@\
+install.man:: list @@\
+ MakeDir($(DESTDIR)dest) @@\
+ @case '${MFLAGS}' in *[i]*) set +e;; esac; \ @@\
+ for i in list; do \ @@\
+ (set -x; \ @@\
+ MNAME=`echo $$i | cut -f1 -d.`; \ @@\
+ $(RM) $(DESTDIR)dest/$${MNAME}*; \ @@\
+ $(INSTALL) -c $(INSTMANFLAGS) $$i \ @@\
+ $(DESTDIR)dest/$${MNAME}.suff; \ @@\
+ $(COMPRESSMANCMD) $(DESTDIR)dest/$${MNAME}.suff); \ @@\
+ done
+#endif
--- ./pbm/Imakefile.org Wed Nov 3 01:31:55 1993
+++ ./pbm/Imakefile Mon Feb 6 00:16:49 1995
@@ -142,9 +142,9 @@
#endif
#if InstallManuals
-InstallMultipleMan($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1)
-InstallMultipleMan($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3)
-InstallMultipleMan($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5)
+InstallMultipleManSuff($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1,1)
+InstallMultipleManSuff($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3,3)
+InstallMultipleManSuff($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5,5)
#endif
#if InstallLibraries
--- ./pgm/Imakefile.org Mon Feb 21 01:14:01 1994
+++ ./pgm/Imakefile Mon Feb 6 00:17:04 1995
@@ -99,9 +99,9 @@
#endif
#if InstallManuals
-InstallMultipleMan($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1)
-InstallMultipleMan($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3)
-InstallMultipleMan($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5)
+InstallMultipleManSuff($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1,1)
+InstallMultipleManSuff($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3,3)
+InstallMultipleManSuff($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5,5)
#endif
#if InstallLibraries
--- ./ppm/Imakefile.org Mon Jan 31 08:44:33 1994
+++ ./ppm/Imakefile Mon Feb 6 00:17:24 1995
@@ -184,9 +184,9 @@
#endif
#if InstallManuals
-InstallMultipleMan($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1)
-InstallMultipleMan($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3)
-InstallMultipleMan($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5)
+InstallMultipleManSuff($(MAN1),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man1,1)
+InstallMultipleManSuff($(MAN3),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man3,3)
+InstallMultipleManSuff($(MAN5),$(PBMPLUSDIR)$(PBMPLUSMANDIR)/man5,5)
#endif
#if InstallLibraries

View file

@ -0,0 +1,68 @@
--- ./pnm/anytopnm.org Mon Oct 4 02:11:29 1993
+++ ./pnm/anytopnm Sat Aug 12 15:05:58 1995
@@ -53,7 +53,7 @@
;;
*GIF* )
- giftoppm "$file"
+ giftopnm "$file"
break
;;
@@ -130,7 +130,7 @@
fitstopgm "$file"
;;
*.gif | *.gif.* )
- giftoppm "$file"
+ giftopnm "$file"
;;
*.iff | *.iff.* | *.ilbm | *.ilbm.* )
ilbmtoppm "$file"
--- ./ppm/ppm.5.org Mon Oct 4 02:12:19 1993
+++ ./ppm/ppm.5 Sat Aug 12 15:06:18 1995
@@ -73,7 +73,7 @@
it will automatically fall back on the slower but more general plain
format.
.SH "SEE ALSO"
-giftoppm(1), gouldtoppm(1), ilbmtoppm(1), imgtoppm(1), mtvtoppm(1),
+giftopnm(1), gouldtoppm(1), ilbmtoppm(1), imgtoppm(1), mtvtoppm(1),
pcxtoppm(1), pgmtoppm(1), pi1toppm(1), picttoppm(1), pjtoppm(1), qrttoppm(1),
rawtoppm(1), rgb3toppm(1), sldtoppm(1), spctoppm(1), sputoppm(1), tgatoppm(1),
ximtoppm(1), xpmtoppm(1), yuvtoppm(1),
--- ./ppm/ppmtoicr.1.org Mon Oct 4 02:12:38 1993
+++ ./ppm/ppmtoicr.1 Sat Aug 12 15:06:36 1995
@@ -83,7 +83,7 @@
the displayed image by a factor of 2, and
run-length encode the data:
.nf
- giftoppm giffile | ppmtoicr -w giffile -r -e 2
+ giftopnm giffile | ppmtoicr -w giffile -r -e 2
.fi
.SH BUGS
.PP
--- ./ppm/ppmtogif.1.org Sat Aug 12 15:08:41 1995
+++ ./ppm/ppmtogif.1 Sat Aug 12 15:06:51 1995
@@ -54,7 +54,7 @@
.PP
All flags can be abbreviated to their shortest unique prefix.
.SH "SEE ALSO"
-giftoppm(1), ppmquant(1), ppm(5)
+giftopnm(1), ppmquant(1), ppm(5)
.SH AUTHOR
Based on GIFENCOD by David Rowley <mgardi@watdcsu.waterloo.edu>.
Lempel-Ziv compression based on "compress".
--- pnm/pnmarith.c~ Wed Jan 5 04:04:53 1994
+++ pnm/pnmarith.c Mon Aug 19 14:20:21 1996
@@ -142,9 +142,9 @@
break;
case '*':
- r1 = r1 * r2 / maxval3;
- g1 = g1 * g2 / maxval3;
- b1 = b1 * b2 / maxval3;
+ r1 = (unsigned) r1 * r2 / maxval3;
+ g1 = (unsigned)g1 * g2 / maxval3;
+ b1 =(unsigned) b1 * b2 / maxval3;
break;
case 'D':

View file

@ -0,0 +1,10 @@
--- ./pnm/pnmmerge.c.org Mon Jan 31 03:31:47 1994
+++ ./pnm/pnmmerge.c Tue Jun 3 01:16:17 1997
@@ -53,6 +53,7 @@
TRY("pnmhistmap", pnmhistmap_main);
TRY("pnmnlfilt", pnmnlfilt_main);
TRY("pnmnoraw", pnmnoraw_main);
+ TRY("pnmpad", pnmpad_main);
TRY("pnmpaste", pnmpaste_main);
TRY("pnmrotate", pnmrotate_main);
TRY("pnmscale", pnmscale_main);

View file

@ -0,0 +1 @@
A toolkit for conversion of images between different formats

183
graphics/netpbm/pkg/DESCR Normal file
View file

@ -0,0 +1,183 @@
Netpbm is a toolkit for conversion of images between a variety of
different formats, as well as to allow a few basic image operations.
Netpbm is based on the widely spread Pbmplus package (release: 10 Dec
91). On top of that, a lot of improvements and additions have been
made. After the latest release of Pbmplus, a lot of additional filters
have been circulating on the net. The aim of Netpbm was, to collect
these and to turn them into a package. This work has been performed by
a group of programmers all over the world.
anytopnm - attempt to convert an unknown type of image file to a portable anymap
asciitopgm - convert ASCII graphics into a portable graymap
atktopbm - convert Andrew Toolkit raster object to portable bitmap
bioradtopgm - convert a Biorad confocal file into a portable graymap
bmptoppm - convert a BMP file into a portable pixmap
brushtopbm - convert a doodle brush file into a portable bitmap
cmuwmtopbm - convert a CMU window manager bitmap into a portable bitmap
fitstopnm - convert a FITS file into a portable anymap
fstopgm - convert a Usenix FaceSaver(tm) file into a portable graymap
g3topbm - convert a Group 3 fax file into a portable bitmap
gemtopbm - convert a GEM .img file into a portable bitmap
giftopnm - convert a GIF file into a portable anymap
gouldtoppm - convert Gould scanner file into a portable pixmap
hipstopgm - convert a HIPS file into a portable graymap
hpcdtoppm v0.3 - convert a Photo-CD file into a portable pixmap
icontopbm - convert a Sun icon into a portable bitmap
ilbmtoppm - convert an ILBM file into a portable pixmap
imgtoppm - convert an Img-whatnot file into a portable pixmap
lispmtopgm - convert a Lisp Machine bitmap file into pgm format
macptopbm - convert a MacPaint file into a portable bitmap
mgrtopbm - convert a MGR bitmap into a portable bitmap
mtvtoppm - convert output from the MTV or PRT ray tracers into a portable pixmap
pbmclean - flip isolated pixels in portable bitmap
pbmlife - apply Conway's rules of Life to a portable bitmap
pbmmake - create a blank bitmap of a specified size
pbmmask - create a mask bitmap from a regular bitmap
pbmpscale - enlarge a portable bitmap with edge smoothing
pbmreduce - read a portable bitmap and reduce it N times
pbmtext - render text into a bitmap
pbmto10x - convert a portable bitmap into Gemini 10X printer graphics
pbmto4425 - Display PBM images on an AT&T 4425 terminal
pbmtoascii - convert a portable bitmap into ASCII graphics
pbmtoatk - convert portable bitmap to Andrew Toolkit raster object
pbmtobg - convert a portable bitmap into BitGraph graphics
pbmtocmuwm - convert a portable bitmap into a CMU window manager bitmap
pbmtoepsi - convert a portable bitmap into an encapsulated PostScript
pbmtoepson - convert a portable bitmap into Epson printer graphics
pbmtog3 - convert a portable bitmap into a Group 3 fax file
pbmtogem - convert a portable bitmap into a GEM .img file
pbmtogo - convert a portable bitmap into compressed GraphOn graphics
pbmtoicon - convert a portable bitmap into a Sun icon
pbmtolj - convert a portable bitmap into HP LaserJet format
pbmtoln03 - convert protable bitmap to DEC LN03+ Sixel output
pbmtolps - convert portable bitmap to PostScript
pbmtomacp - convert a portable bitmap into a MacPaint file
pbmtomgr - convert a portable bitmap into a MGR bitmap
pbmtopgm - convert portable bitmap to portable graymap by averaging areas
pbmtopi3 - convert a portable bitmap into an Atari Degas .pi3 file
pbmtopk - convert a portable bitmap into a packed (PK) format font
pbmtoplot - convert a portable bitmap into a Unix plot(5) file
pbmtoptx - convert a portable bitmap into Printronix printer graphics
pbmtox10bm - convert a portable bitmap into an X10 bitmap
pbmtoxbm - convert a portable bitmap into an X11 bitmap
pgmtoybm - convert a portable bitmap into a Bennet Yee "face" file
pbmtozinc - convert a portable bitmap into a Zinc bitmap
pbmupc - create a Universal Product Code bitmap
pcxtoppm - convert a PCX file into a portable pixmap
pgmbentley - Bentleyize a portable graymap
pgmcrater - create cratered terrain by fractal forgery
pgmedge - edge-detect a portable graymap
pgmenhance - edge-enhance a portable graymap
pgmhist - print a histogram of the values in a portable graymap
pgmkernel - generate a convolution kernel
pgmnoise - create a graymap made up of white noise
pgmnorm - normalize the contrast in a portable graymap
pgmoil - turn a portable graymap into an oil painting
pgmramp - generate a grayscale ramp
pgmtexture - calculate textural features on a portable graymap
pgmtofs - convert portable graymap to Usenix FaceSaver(tm) format
pgmtolispm - convert a portable graymap into Lisp Machine format
pgmtopbm - convert a portable graymap into a portable bitmap
pgmtoppm - colorize a portable graymap into a portable pixmap
pi1toppm - convert an Atari Degas .pi1 into a portable pixmap
pi3topbm - convert an Atari Degas .pi3 file into a portable bitmap
picttoppm - convert a Macintosh PICT file into a portable pixmap
pjtoppm - convert an HP PaintJet file to a portable pixmap
pktopbm - convert packed (PK) format font into portable bitmap(s)
pnmalias - antialias a portable anyumap.
pnmarith - perform arithmetic on two portable anymaps
pnmcat - concatenate portable anymaps
pnmcomp - composite two portable anymap files together
pnmconvol - general MxN convolution on a portable anymap
pnmcrop - crop a portable anymap
pnmcut - cut a rectangle out of a portable anymap
pnmdepth - change the maxval in a portable anymap
pnmenlarge - read a portable anymap and enlarge it N times
pnmfile - describe a portable anymap
pnmflip - perform one or more flip operations on a portable anymap
pnmgamma - perform gamma correction on a portable anymap
pnmhistmap - draw a histogram for a PGM or PPM file
pnmindex - build a visual index of a bunch of anymaps
pnminvert - invert a portable anymap
pnmmargin - add a border to a portable anymap
pnmnlfilt - non-linear filters: smooth, alpha trim mean, optimal
pnmnoraw - force a portable anymap into plain format
pnmpad - add borders to portable anymap
pnmpaste - paste a rectangle into a portable anymap
pnmrotate - rotate a portable anymap by some angle
pnmscale - scale a portable anymap
pnmshear - shear a portable anymap by some angle
pnmsmooth - smooth out an image
pnmtile - replicate a portable anymap into a specified size
pnmtoddif - Convert a portable anymap to DDIF format
pnmtofits - convert a portable anymap into FITS format
pnmtops - convert portable anymap to PostScript
pnmtorast - convert a portable pixmap into a Sun rasterfile
pnmtosgi - convert a portable anymap to a SGI image file
pnmtosir - convert a portable anymap into a Solitaire format
pnmtotiff - convert a a portable anymap into a TIFF file
pnmtoxwd - convert a portable anymap into an X11 window dump
ppm3d - convert two portable pixmap into a red/blue 3d glasses pixmap
ppmbrighten - change an images Saturation and Value from an HSV map
ppmchange - change all pixels of one color to another in a portable pixmap
ppmdim - dim a portable pixmap down to total blackness
ppmdist - simplistic grayscale assignment for machine generated, color images
ppmdither - ordered dither for color images
ppmflash - brighten a picture up to complete white-out
ppmforge - fractal forgeries of clouds, planets, and starry skies
ppmhist - print a histogram of a portable pixmap
ppmmake - create a pixmap of a specified size and color
ppmmix - blend together two portable pixmaps
ppmnorm - normalize the contrast in a portable pixmap
ppmntsc - make a portable pixmap look like taken from an American TV
ppmpat - make a pretty pixmap
ppmquant - quantize the colors in a portable pixmap down to a specified number
ppmquantall - run ppmquant on a bunch of files all at once, so they share a common colormap
ppmqvga - 8 plane quantization
ppmrelief - run a Laplacian relief filter on a portable pixmap
ppmshift - shift lines of a portable pixmap left or right by a random amount
ppmspread - displace a portable pixmap's pixels by a random amount
ppmtoacad - convert portable pixmap to AutoCAD database or slide
ppmtobmp - convert a portable pixmap into a BMP file
ppmtogif - convert a portable pixmap into a GIF file
ppmtoicr - convert a portable pixmap into NCSA ICR format
ppmtoilbm - convert a portable pixmap into an ILBM file
ppmtomap - extract all colors from a portable pixmap
ppmtomitsu - convert a portable pixmap to a Mitsubishi S340-10 file
ppmtopcx - convert a portable pixmap into a PCX file
ppmtopgm - convert a portable pixmap into a portable graymap
ppmtopi1 - convert a portable pixmap into an Atari Degas .pi1 file
ppmtopict - convert a portable pixmap into a Macintosh PICT file
ppmtopj - convert a portable pixmap to an HP PaintJet file
ppmtopjxl - convert a portable pixmap into an HP PaintJet XL PCL file
ppmtopuzz - convert a portable pixmap into an X11 "puzzle" file
ppmtorgb3 - separate a portable pixmap into three portable graymaps
ppmtosixel - convert a portable pixmap into DEC sixel format
ppmtotga - convert portable pixmap into a TrueVision Targa file
ppmtouil - convert a portable pixmap into a Motif UIL icon file
ppmtoxpm - convert a portable pixmap into an X11 pixmap
ppmtoyuv - convert a portable pixmap into an Abekas YUV file
ppmtoyuvsplit - convert a portable pixmap into 3 subsampled raw YUV files
psidtopgm - convert PostScript "image" data into a portable graymap
qrttoppm - convert output from the QRT ray tracer into a portable pixmap
rasttopnm - convert a Sun rasterfile into a portable anymap
rawtopgm - convert raw grayscale bytes into a portable graymap
rawtoppm - convert raw RGB bytes into a portable pixmap
rgb3toppm - combine three portable graymaps into one portable pixmap
sgitopnm - convert a SGI image file to a portable anymap
sirtopnm - convert a Solitaire file into a portable anymap
sldtoppm - convert an AutoCAD slide file into a portable pixmap
spctoppm - convert an Atari compressed Spectrum file into a portable pixmap
spottopgm - convert SPOT satellite images to Portable Greymap format
sputoppm - convert an Atari uncompressed Spectrum file into a portable pixmap
tgatoppm - convert TrueVision Targa file into a portable pixmap
tifftopnm - convert a TIFF file into a portable anymap
xbmtopbm - convert an X11 or X10 bitmap into a portable bitmap
ximtoppm - convert an Xim file into a portable pixmap
xpmtoppm - convert an X11 pixmap into a portable pixmap
xvminitoppm - convert a XV "thumbnail" picture to PPM
xwdtopnm - convert a X11 or X10 window dump file into a portable anymap
ybmtopbm - convert a Bennet Yee "face" file into a portable bitmap
yuvplittoppm - convert a Y- an U- and a V-file into a portable pixmap.
yuvtoppm - convert Abekas YUV bytes into a portable pixmap
zeisstopnm - convert a Zeiss confocal file into a portable anymap

370
graphics/netpbm/pkg/PLIST Normal file
View file

@ -0,0 +1,370 @@
bin/anytopnm
bin/asciitopgm
bin/atktopbm
bin/bioradtopgm
bin/bmptoppm
bin/brushtopbm
bin/cmuwmtopbm
bin/fitstopnm
bin/fstopgm
bin/g3topbm
bin/gemtopbm
bin/giftopnm
bin/gouldtoppm
bin/hipstopgm
bin/hpcdtoppm
bin/icontopbm
bin/ilbmtoppm
bin/imgtoppm
bin/lispmtopgm
bin/macptopbm
bin/mgrtopbm
bin/mtvtoppm
bin/pbmclean
bin/pbmlife
bin/pbmmake
bin/pbmmask
bin/pbmmerge
bin/pbmpscale
bin/pbmreduce
bin/pbmtext
bin/pbmto10x
bin/pbmto4425
bin/pbmtoascii
bin/pbmtoatk
bin/pbmtobbnbg
bin/pbmtocmuwm
bin/pbmtoepsi
bin/pbmtoepson
bin/pbmtog3
bin/pbmtogem
bin/pbmtogo
bin/pbmtoicon
bin/pbmtolj
bin/pbmtoln03
bin/pbmtolps
bin/pbmtomacp
bin/pbmtomgr
bin/pbmtopgm
bin/pbmtopi3
bin/pbmtopk
bin/pbmtoplot
bin/pbmtoptx
bin/pbmtox10bm
bin/pbmtoxbm
bin/pbmtoybm
bin/pbmtozinc
bin/pbmupc
bin/pcxtoppm
bin/pgmbentley
bin/pgmcrater
bin/pgmedge
bin/pgmenhance
bin/pgmhist
bin/pgmkernel
bin/pgmmerge
bin/pgmnoise
bin/pgmnorm
bin/pgmoil
bin/pgmramp
bin/pgmtexture
bin/pgmtofs
bin/pgmtolispm
bin/pgmtopbm
bin/pgmtoppm
bin/pi1toppm
bin/pi3topbm
bin/picttoppm
bin/pjtoppm
bin/pktopbm
bin/pnmalias
bin/pnmarith
bin/pnmcat
bin/pnmcomp
bin/pnmconvol
bin/pnmcrop
bin/pnmcut
bin/pnmdepth
bin/pnmenlarge
bin/pnmfile
bin/pnmflip
bin/pnmgamma
bin/pnmhistmap
bin/pnmindex
bin/pnminvert
bin/pnmmargin
bin/pnmmerge
bin/pnmnlfilt
bin/pnmnoraw
bin/pnmpad
bin/pnmpaste
bin/pnmrotate
bin/pnmscale
bin/pnmshear
bin/pnmsmooth
bin/pnmtile
bin/pnmtoddif
bin/pnmtofits
bin/pnmtops
bin/pnmtorast
bin/pnmtosgi
bin/pnmtosir
bin/pnmtotiff
bin/pnmtoxwd
bin/ppm3d
bin/ppmbrighten
bin/ppmchange
bin/ppmdim
bin/ppmdist
bin/ppmdither
bin/ppmflash
bin/ppmforge
bin/ppmhist
bin/ppmmake
bin/ppmmerge
bin/ppmmix
bin/ppmnorm
bin/ppmntsc
bin/ppmpat
bin/ppmquant
bin/ppmquantall
bin/ppmqvga
bin/ppmrelief
bin/ppmshift
bin/ppmspread
bin/ppmtoacad
bin/ppmtobmp
bin/ppmtogif
bin/ppmtoicr
bin/ppmtoilbm
bin/ppmtomap
bin/ppmtomitsu
bin/ppmtopcx
bin/ppmtopgm
bin/ppmtopi1
bin/ppmtopict
bin/ppmtopj
bin/ppmtopjxl
bin/ppmtopuzz
bin/ppmtorgb3
bin/ppmtosixel
bin/ppmtotga
bin/ppmtouil
bin/ppmtoxpm
bin/ppmtoyuv
bin/ppmtoyuvsplit
bin/psidtopgm
bin/pstopnm
bin/qrttoppm
bin/rasttopnm
bin/rawtopgm
bin/rawtoppm
bin/rgb3toppm
bin/sgitopnm
bin/sirtopnm
bin/sldtoppm
bin/spctoppm
bin/spottopgm
bin/sputoppm
bin/tgatoppm
bin/tifftopnm
bin/xbmtopbm
bin/ximtoppm
bin/xpmtoppm
bin/xvminitoppm
bin/xwdtopnm
bin/ybmtopbm
bin/yuvsplittoppm
bin/yuvtoppm
bin/zeisstopnm
include/pbm.h
include/pbmplus.h
include/pgm.h
include/pnm.h
include/ppm.h
lib/libpbm.a
lib/libpgm.a
lib/libpnm.a
lib/libppm.a
man/man1/anytopnm.1.gz
man/man1/asciitopgm.1.gz
man/man1/atktopbm.1.gz
man/man1/bioradtopgm.1.gz
man/man1/bmptoppm.1.gz
man/man1/brushtopbm.1.gz
man/man1/cmuwmtopbm.1.gz
man/man1/fitstopnm.1.gz
man/man1/fstopgm.1.gz
man/man1/g3topbm.1.gz
man/man1/gemtopbm.1.gz
man/man1/giftopnm.1.gz
man/man1/gouldtoppm.1.gz
man/man1/hipstopgm.1.gz
man/man1/hpcdtoppm.1.gz
man/man1/icontopbm.1.gz
man/man1/ilbmtoppm.1.gz
man/man1/imgtoppm.1.gz
man/man1/lispmtopgm.1.gz
man/man1/macptopbm.1.gz
man/man1/mgrtopbm.1.gz
man/man1/mtvtoppm.1.gz
man/man1/pbmclean.1.gz
man/man1/pbmlife.1.gz
man/man1/pbmmake.1.gz
man/man1/pbmmask.1.gz
man/man1/pbmpscale.1.gz
man/man1/pbmreduce.1.gz
man/man1/pbmtext.1.gz
man/man1/pbmto10x.1.gz
man/man1/pbmto4425.1.gz
man/man1/pbmtoascii.1.gz
man/man1/pbmtoatk.1.gz
man/man1/pbmtobbnbg.1.gz
man/man1/pbmtocmuwm.1.gz
man/man1/pbmtoepsi.1.gz
man/man1/pbmtoepson.1.gz
man/man1/pbmtog3.1.gz
man/man1/pbmtogem.1.gz
man/man1/pbmtogo.1.gz
man/man1/pbmtoicon.1.gz
man/man1/pbmtolj.1.gz
man/man1/pbmtoln03.1.gz
man/man1/pbmtolps.1.gz
man/man1/pbmtomacp.1.gz
man/man1/pbmtomgr.1.gz
man/man1/pbmtopgm.1.gz
man/man1/pbmtopi3.1.gz
man/man1/pbmtopk.1.gz
man/man1/pbmtoplot.1.gz
man/man1/pbmtoptx.1.gz
man/man1/pbmtox10bm.1.gz
man/man1/pbmtoxbm.1.gz
man/man1/pbmtoybm.1.gz
man/man1/pbmtozinc.1.gz
man/man1/pbmupc.1.gz
man/man1/pcxtoppm.1.gz
man/man1/pgmbentley.1.gz
man/man1/pgmcrater.1.gz
man/man1/pgmedge.1.gz
man/man1/pgmenhance.1.gz
man/man1/pgmhist.1.gz
man/man1/pgmkernel.1.gz
man/man1/pgmnoise.1.gz
man/man1/pgmnorm.1.gz
man/man1/pgmoil.1.gz
man/man1/pgmramp.1.gz
man/man1/pgmtexture.1.gz
man/man1/pgmtofs.1.gz
man/man1/pgmtolispm.1.gz
man/man1/pgmtopbm.1.gz
man/man1/pgmtoppm.1.gz
man/man1/pi1toppm.1.gz
man/man1/pi3topbm.1.gz
man/man1/picttoppm.1.gz
man/man1/pjtoppm.1.gz
man/man1/pktopbm.1.gz
man/man1/pnmalias.1.gz
man/man1/pnmarith.1.gz
man/man1/pnmcat.1.gz
man/man1/pnmcomp.1.gz
man/man1/pnmconvol.1.gz
man/man1/pnmcrop.1.gz
man/man1/pnmcut.1.gz
man/man1/pnmdepth.1.gz
man/man1/pnmenlarge.1.gz
man/man1/pnmfile.1.gz
man/man1/pnmflip.1.gz
man/man1/pnmgamma.1.gz
man/man1/pnmhistmap.1.gz
man/man1/pnmindex.1.gz
man/man1/pnminvert.1.gz
man/man1/pnmmargin.1.gz
man/man1/pnmnlfilt.1.gz
man/man1/pnmnoraw.1.gz
man/man1/pnmpad.1.gz
man/man1/pnmpaste.1.gz
man/man1/pnmrotate.1.gz
man/man1/pnmscale.1.gz
man/man1/pnmshear.1.gz
man/man1/pnmsmooth.1.gz
man/man1/pnmtile.1.gz
man/man1/pnmtoddif.1.gz
man/man1/pnmtofits.1.gz
man/man1/pnmtops.1.gz
man/man1/pnmtorast.1.gz
man/man1/pnmtosgi.1.gz
man/man1/pnmtosir.1.gz
man/man1/pnmtotiff.1.gz
man/man1/pnmtoxwd.1.gz
man/man1/ppm3d.1.gz
man/man1/ppmbrighten.1.gz
man/man1/ppmchange.1.gz
man/man1/ppmdim.1.gz
man/man1/ppmdist.1.gz
man/man1/ppmdither.1.gz
man/man1/ppmflash.1.gz
man/man1/ppmforge.1.gz
man/man1/ppmhist.1.gz
man/man1/ppmmake.1.gz
man/man1/ppmmix.1.gz
man/man1/ppmnorm.1.gz
man/man1/ppmntsc.1.gz
man/man1/ppmpat.1.gz
man/man1/ppmquant.1.gz
man/man1/ppmquantall.1.gz
man/man1/ppmqvga.1.gz
man/man1/ppmrelief.1.gz
man/man1/ppmshift.1.gz
man/man1/ppmspread.1.gz
man/man1/ppmtoacad.1.gz
man/man1/ppmtobmp.1.gz
man/man1/ppmtogif.1.gz
man/man1/ppmtoicr.1.gz
man/man1/ppmtoilbm.1.gz
man/man1/ppmtomap.1.gz
man/man1/ppmtomitsu.1.gz
man/man1/ppmtopcx.1.gz
man/man1/ppmtopgm.1.gz
man/man1/ppmtopi1.1.gz
man/man1/ppmtopict.1.gz
man/man1/ppmtopj.1.gz
man/man1/ppmtopjxl.1.gz
man/man1/ppmtopuzz.1.gz
man/man1/ppmtorgb3.1.gz
man/man1/ppmtosixel.1.gz
man/man1/ppmtotga.1.gz
man/man1/ppmtouil.1.gz
man/man1/ppmtoxpm.1.gz
man/man1/ppmtoyuv.1.gz
man/man1/ppmtoyuvsplit.1.gz
man/man1/psidtopgm.1.gz
man/man1/qrttoppm.1.gz
man/man1/rasttopnm.1.gz
man/man1/rawtopgm.1.gz
man/man1/rawtoppm.1.gz
man/man1/rgb3toppm.1.gz
man/man1/sgitopnm.1.gz
man/man1/sirtopnm.1.gz
man/man1/sldtoppm.1.gz
man/man1/spctoppm.1.gz
man/man1/spottopgm.1.gz
man/man1/sputoppm.1.gz
man/man1/tgatoppm.1.gz
man/man1/tifftopnm.1.gz
man/man1/xbmtopbm.1.gz
man/man1/ximtoppm.1.gz
man/man1/xpmtoppm.1.gz
man/man1/xvminitoppm.1.gz
man/man1/xwdtopnm.1.gz
man/man1/ybmtopbm.1.gz
man/man1/yuvsplittoppm.1.gz
man/man1/yuvtoppm.1.gz
man/man1/zeisstopnm.1.gz
man/man3/libpbm.3.gz
man/man3/libpgm.3.gz
man/man3/libpnm.3.gz
man/man3/libppm.3.gz
man/man5/pbm.5.gz
man/man5/pgm.5.gz
man/man5/pnm.5.gz
man/man5/ppm.5.gz

17
graphics/netpbm/scripts/configure vendored Normal file
View file

@ -0,0 +1,17 @@
#!/bin/sh
cd $WRKSRC || exit 1;
H=libtiff/tiffconf.h
chmod +w $H || exit 1
echo "#define MMAP_SUPPORT" >> $H || exit 1
mv Pbmplus.tmpl Pbmplus.tmpl.orig || exit 1;
cat >Pbmplus.tmpl<<EOF
#define PbmplusBinDir $PREFIX/bin
#define PbmplusManDir $PREFIX/man
#define PbmplusLibDir $PREFIX/lib
#define PbmplusIncDir $PREFIX/include
EOF
cat Pbmplus.tmpl.orig >> Pbmplus.tmpl
exit 0