Freenet Tools, a set of tools usable against a Freenet or Entropy node

to insert/retrieve content by the native FCP protocol rather than the
WWW proxy.  From the DESCR:

=====

The most important tools for those who want to insert their own content as a
website into Freenet or Entropy, are the Freenet Tools (or similiar tools
from other authors :). For Freenet, there are some such programs linked from
their http://freenetproject.org) pages. Not many of them will work with
Entropy out-of-the-box, as they sometimes specialize on minor deviations in
the FCP interface. Specificially the newer tools, supporting the FEC FCP
v1.1 will fail with Entropy, as Entropy does not yet fully support the
changes to the Freenet Client Protocol. So I suggest you use ft for Entropy
for now, since I can help you there with problems or questions.
This commit is contained in:
tv 2004-03-29 18:43:47 +00:00
parent 8923a4f447
commit 14d2d51127
6 changed files with 77 additions and 0 deletions

9
net/freenet-tools/DESCR Normal file
View file

@ -0,0 +1,9 @@
The most important tools for those who want to insert their own content as a
website into Freenet or Entropy, are the Freenet Tools (or similiar tools
from other authors :). For Freenet, there are some such programs linked from
their http://freenetproject.org) pages. Not many of them will work with
Entropy out-of-the-box, as they sometimes specialize on minor deviations in
the FCP interface. Specificially the newer tools, supporting the FEC FCP
v1.1 will fail with Entropy, as Entropy does not yet fully support the
changes to the Freenet Client Protocol. So I suggest you use ft for Entropy
for now, since I can help you there with problems or questions.

11
net/freenet-tools/MESSAGE Normal file
View file

@ -0,0 +1,11 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2004/03/29 18:43:47 tv Exp $
See the "Freenet Tools" section of the Web page
http://entropy.stop1984.com/de/clients.html (Deutsch)
http://entropy.stop1984.com/en/clients.html (English)
for further information; currently, there is no bundled documentation.
===========================================================================

View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/03/29 18:43:47 tv Exp $
#
DISTNAME= ft-0.2.21
PKGNAME= ${DISTNAME:S/ft-/freenet-tools-/}
WRKSRC= ${WRKDIR}/ft
CATEGORIES= net www
MASTER_SITES= http://entropy.stop1984.com/files/ \
http://www.duh.org/extropy/files/
EXTRACT_SUFX= .tgz
MAINTAINER= tv@duh.org
HOMEPAGE= http://entropy.stop1984.com/
COMMENT= Freenet Tools, freesite manipulation tools for Freenet and Entropy
USE_BUILDLINK3= yes
USE_GNU_TOOLS+= make
MAKE_FLAGS+= CC=${CC:Q} LD=${CC:Q} CFLAGS=${CFLAGS:Q} LDFLAGS=${LDFLAGS:Q}
CFLAGS+= -DFT_BIN=\"${PREFIX}/bin\"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ft ${PREFIX}/bin/ft
.for f in fcpchk fcpget fcpgetsite fcphello fcpinv fcpkey fcpput fcpputsite
${LN} -s -f ft ${PREFIX}/bin/$f
.endfor
.include "../../mk/bsd.pkg.mk"

10
net/freenet-tools/PLIST Normal file
View file

@ -0,0 +1,10 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/03/29 18:43:47 tv Exp $
bin/fcpchk
bin/fcpget
bin/fcpgetsite
bin/fcphello
bin/fcpinv
bin/fcpkey
bin/fcpput
bin/fcpputsite
bin/ft

View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/03/29 18:43:47 tv Exp $
SHA1 (ft-0.2.21.tgz) = 6cbb427a51bc05340987713de5bbaf03cbace027
Size (ft-0.2.21.tgz) = 40132 bytes
SHA1 (patch-aa) = 12fb2c63b24a06f43f03466f16f994e911367189

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/03/29 18:43:47 tv Exp $
--- ftmain.c.orig Wed Sep 24 22:56:49 2003
+++ ftmain.c
@@ -248,8 +248,7 @@ int main(int argc, char **argv)
} else {
progname = strdup(argv[0]);
free(progpath);
- progpath = calloc(256, 1);
- getcwd(progpath, 256);
+ progpath = FT_BIN;
}
ext = strrchr(progname, '.');
if (NULL == ext) {