Import gdmap-0.8.1 as sysutils/gdmap
GdMap is a tool which allows you to visualize disk space in a novel way. Files and directories are displayed in rectangular areas. The larger the file, the larger the rectangle that represents it.
This commit is contained in:
parent
2762b9455e
commit
14d84862e8
6 changed files with 114 additions and 0 deletions
3
sysutils/gdmap/DESCR
Normal file
3
sysutils/gdmap/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
GdMap is a tool which allows you to visualize disk space in a novel way. Files
|
||||
and directories are displayed in rectangular areas. The larger the file, the
|
||||
larger the rectangle that represents it.
|
22
sysutils/gdmap/Makefile
Normal file
22
sysutils/gdmap/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# $NetBSD: Makefile,v 1.1 2015/12/12 15:31:26 kamil Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gdmap-0.8.1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gdmap/}
|
||||
|
||||
MAINTAINER= dhowland@users.sourceforge.net
|
||||
HOMEPAGE= http://gdmap.sourceforge.net/
|
||||
COMMENT= Tool to visualize disk space
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_TOOLS+= gmake pkg-config msgfmt xgettext perl intltool
|
||||
|
||||
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
19
sysutils/gdmap/PLIST
Normal file
19
sysutils/gdmap/PLIST
Normal file
|
@ -0,0 +1,19 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2015/12/12 15:31:26 kamil Exp $
|
||||
bin/gdmap
|
||||
man/man1/gdmap.1
|
||||
share/applications/gdmap.desktop
|
||||
share/gdmap/pixmaps/gdmap_icon.png
|
||||
share/locale/bg/LC_MESSAGES/GdMap.mo
|
||||
share/locale/de/LC_MESSAGES/GdMap.mo
|
||||
share/locale/dk/LC_MESSAGES/GdMap.mo
|
||||
share/locale/es/LC_MESSAGES/GdMap.mo
|
||||
share/locale/fr/LC_MESSAGES/GdMap.mo
|
||||
share/locale/he/LC_MESSAGES/GdMap.mo
|
||||
share/locale/hr/LC_MESSAGES/GdMap.mo
|
||||
share/locale/it/LC_MESSAGES/GdMap.mo
|
||||
share/locale/nb/LC_MESSAGES/GdMap.mo
|
||||
share/locale/no/LC_MESSAGES/GdMap.mo
|
||||
share/locale/ru/LC_MESSAGES/GdMap.mo
|
||||
share/locale/sv/LC_MESSAGES/GdMap.mo
|
||||
share/locale/tr/LC_MESSAGES/GdMap.mo
|
||||
share/pixmaps/gdmap_icon.png
|
7
sysutils/gdmap/distinfo
Normal file
7
sysutils/gdmap/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2015/12/12 15:31:26 kamil Exp $
|
||||
|
||||
SHA1 (gdmap-0.8.1.tar.gz) = d97cc7c107dbaf9f3f3ed22ee6cef6172c115295
|
||||
RMD160 (gdmap-0.8.1.tar.gz) = 72744f1d25b3409d6609b7afa982669f17f4e8b5
|
||||
Size (gdmap-0.8.1.tar.gz) = 190823 bytes
|
||||
SHA1 (patch-aa) = 55be92ca22eb8f92755bdbe32686337924366c18
|
||||
SHA1 (patch-gui_support.c) = 930a280666ab86faab34a83cd4e962a3831618f4
|
18
sysutils/gdmap/patches/patch-aa
Normal file
18
sysutils/gdmap/patches/patch-aa
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-aa,v 1.1 2015/12/12 15:31:26 kamil Exp $
|
||||
|
||||
Include sys/statvfs.h instead of sys/vfs.h on NetBSD.
|
||||
|
||||
--- src/gui_main.c.orig 2005-12-27 09:29:51.000000000 -0500
|
||||
+++ src/gui_main.c
|
||||
@@ -11,7 +11,11 @@
|
||||
# include <config.h>
|
||||
#endif
|
||||
|
||||
+#if defined(__NetBSD__)
|
||||
+#include <sys/statvfs.h>
|
||||
+#else
|
||||
#include <sys/vfs.h>
|
||||
+#endif
|
||||
#include <stdlib.h>
|
||||
#include <math.h>
|
||||
#include <string.h>
|
45
sysutils/gdmap/patches/patch-gui_support.c
Normal file
45
sysutils/gdmap/patches/patch-gui_support.c
Normal file
|
@ -0,0 +1,45 @@
|
|||
$NetBSD: patch-gui_support.c,v 1.1 2015/12/12 15:31:26 kamil Exp $
|
||||
|
||||
Adapt to newer GTK+ API.
|
||||
|
||||
Imported from: https://projects.archlinux.org/svntogit/community.git/plain/trunk/gtk-fix.patch?h=packages/gdmap
|
||||
|
||||
--- src/gui_support.c.orig 2008-05-23 14:54:28.000000000 +0000
|
||||
+++ src/gui_support.c
|
||||
@@ -85,7 +85,11 @@ on_ebox_enter(GtkWidget* box, GdkEventCr
|
||||
const char* text;
|
||||
|
||||
(void)event;
|
||||
+#if GTK_CHECK_VERSION(2,20,0)
|
||||
+ if (gtk_widget_get_sensitive(GTK_WIDGET(label))) {
|
||||
+#else
|
||||
if (GTK_WIDGET_SENSITIVE(label)) {
|
||||
+#endif
|
||||
char* temp;
|
||||
|
||||
text = g_object_get_data(G_OBJECT(label), "label");
|
||||
@@ -129,7 +133,11 @@ static void on_clear_label(GtkWidget* wi
|
||||
void ui_event_label_set_sensitive(GtkWidget* ebox, gboolean set) {
|
||||
gpointer callback = g_object_get_data(G_OBJECT(ebox), "callback");
|
||||
GtkWidget* child = GTK_BIN(ebox)->child;
|
||||
+#if GTK_CHECK_VERSION(2,20,0)
|
||||
+ if (gtk_widget_get_sensitive(child) == set) return;
|
||||
+#else
|
||||
if (GTK_WIDGET_SENSITIVE(child) == set) return;
|
||||
+#endif
|
||||
|
||||
if (set && !callback) return;
|
||||
gtk_widget_set_sensitive(child, set);
|
||||
@@ -164,8 +172,11 @@ GtkWidget* ui_create_event_label(const c
|
||||
// GDK_FOCUS_CHANGE_MASK |
|
||||
GDK_ENTER_NOTIFY_MASK |
|
||||
GDK_LEAVE_NOTIFY_MASK);
|
||||
+#if GTK_CHECK_VERSION(2,22,0)
|
||||
+ gtk_widget_set_can_focus(ebox, TRUE);
|
||||
+#else
|
||||
GTK_WIDGET_SET_FLAGS(ebox, GTK_CAN_FOCUS);
|
||||
-
|
||||
+#endif
|
||||
gtk_widget_show(ebox);
|
||||
|
||||
temp = g_strdup_printf(EVENT_FMT, text);
|
Loading…
Reference in a new issue