Introduce a new variable KJS_USE_PCRE that controls the regex library
used in KJS (javascript) for kdelibs2. This fixes PR/13018 from Greg A. Woods <woods@weird.com>
This commit is contained in:
parent
1d95063aab
commit
1517a4c70f
4 changed files with 40 additions and 9 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: mk.conf.example,v 1.212 2001/05/24 19:58:35 dmcmahill Exp $
|
||||
# $NetBSD: mk.conf.example,v 1.213 2001/05/24 22:18:21 skrll Exp $
|
||||
#
|
||||
|
||||
# Sample /etc/mk.conf file, which can be used to set specific values
|
||||
|
@ -546,6 +546,12 @@
|
|||
# Possible: YES, yes, not defined
|
||||
# Default: not defined
|
||||
|
||||
#KJS_USE_PCRE=
|
||||
# Used in kdelibs2 to determine if kjs (javascript) should use Perl
|
||||
# Compatible Regular Expressions (pcre)
|
||||
# Possible: yes, not defined
|
||||
# Default: not defined
|
||||
|
||||
#KNEWS_DOMAIN_FILE=
|
||||
# Used in the knews package to set the domain name from the contents
|
||||
# of this file.
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2001/05/01 09:46:37 skrll Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2001/05/24 22:18:22 skrll Exp $
|
||||
#
|
||||
|
||||
DISTNAME= kdelibs-2.1
|
||||
|
@ -11,13 +11,19 @@ DEPENDS+= tiff-*:../../graphics/tiff
|
|||
DEPENDS+= qt2-libs>=2.2.4:../../x11/qt2-libs
|
||||
DEPENDS+= libaudiofile-*:../../audio/libaudiofile
|
||||
DEPENDS+= jade>=1.2.1:../../textproc/jade
|
||||
|
||||
.include "../../x11/kde2/Makefile.part2"
|
||||
|
||||
USE_LTDL= yes
|
||||
LTCONFIG_OVERRIDE+= ${WRKSRC}/ksgmltools/ltconfig
|
||||
|
||||
CONFIGURE_ENV+= LIBS="-Wl,--export-dynamic"
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
.if (defined(KJS_USE_PCRE) && ${KJS_USE_PCRE} == yes)
|
||||
DEPENDS+= pcre>=3.4:../../devel/pcre
|
||||
.endif
|
||||
|
||||
CONFIGURE_ENV+= LIBS="-Wl,--export-dynamic" \
|
||||
KJS_USE_PCRE="${KJS_USE_PCRE}"
|
||||
|
||||
MKDIRS= share/kde/icons/locolor/32x32/actions/kde \
|
||||
share/kde/icons/locolor/22x22/mimetypes \
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.3 2001/05/21 05:27:59 tron Exp $
|
||||
$NetBSD: distinfo,v 1.4 2001/05/24 22:18:22 skrll Exp $
|
||||
|
||||
SHA1 (kdelibs-2.1.tar.bz2) = 5941037de8b47fb2d992ae780c28a8583f07d83c
|
||||
Size (kdelibs-2.1.tar.bz2) = 5020838 bytes
|
||||
SHA1 (patch-aa) = de413d73ae7a4359e49a4f29f4242017f098a6ea
|
||||
SHA1 (patch-ab) = d8fd5a336e7a0c22af4d4bf771c4f96261001b84
|
||||
SHA1 (patch-ac) = 11ac5f520e21ff403c6a3d04b61dfbd2d4036fae
|
||||
SHA1 (patch-ad) = 345e5116fb414ea11c67ec549182367f1912a0ba
|
||||
SHA1 (patch-ad) = 902e30cfd7e4ee8a91fe9899ef188bfa8ad23bff
|
||||
SHA1 (patch-ae) = 1eae84672f4f792b7d56d9c958be585f30f9f056
|
||||
SHA1 (patch-af) = 542431463c9716001ebf17ea7a3b2506ed83f825
|
||||
SHA1 (patch-ag) = 750f4868cd2c81ec0317898ef1761a40016a86a8
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2001/03/14 15:59:48 skrll Exp $
|
||||
$NetBSD: patch-ad,v 1.2 2001/05/24 22:18:22 skrll Exp $
|
||||
|
||||
--- configure.orig Thu Feb 22 18:17:52 2001
|
||||
+++ configure
|
||||
|
@ -23,7 +23,26 @@ $NetBSD: patch-ad,v 1.1.1.1 2001/03/14 15:59:48 skrll Exp $
|
|||
|
||||
|
||||
|
||||
@@ -13183,7 +13184,7 @@
|
||||
@@ -12406,6 +12407,9 @@
|
||||
fi
|
||||
|
||||
|
||||
+if test $KJS_USE_PCRE = yes; then
|
||||
+pcre_save_CPPFLAGS="$CPPFLAGS"
|
||||
+CPPFLAGS="$CPPFLAGS -I${LOCALBASE}/include"
|
||||
for ac_hdr in pcreposix.h
|
||||
do
|
||||
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
|
||||
@@ -12445,6 +12449,8 @@
|
||||
echo "$ac_t""no" 1>&6
|
||||
fi
|
||||
done
|
||||
+CPPFLAGS="$pcre_save_CPPFLAGS"
|
||||
+fi
|
||||
|
||||
|
||||
|
||||
@@ -13183,7 +13189,7 @@
|
||||
|
||||
|
||||
|
||||
|
@ -32,7 +51,7 @@ $NetBSD: patch-ad,v 1.1.1.1 2001/03/14 15:59:48 skrll Exp $
|
|||
|
||||
|
||||
CXXFLAGS="$CXXFLAGS -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST"
|
||||
@@ -14140,7 +14141,7 @@
|
||||
@@ -14140,7 +14146,7 @@
|
||||
esac
|
||||
done
|
||||
|
||||
|
|
Loading…
Reference in a new issue