Fix build with gcc4.3

This commit is contained in:
markd 2011-01-29 21:48:41 +00:00
parent 3a64d76f4b
commit 1569f038b9
9 changed files with 110 additions and 2 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2009/07/17 18:26:30 hasso Exp $
$NetBSD: distinfo,v 1.9 2011/01/29 21:48:41 markd Exp $
SHA1 (dbxml-1.2.1.tar.gz) = cc6ce354b3fb2e00d5b424c0b15ecee4ec340842
RMD160 (dbxml-1.2.1.tar.gz) = 162f3e14e509aefd764bb97af80d5bbf06151df7
@ -8,3 +8,9 @@ SHA1 (patch-ab) = 4e124704238d4d3c6fc753d28ce3cb0bd5e3731f
SHA1 (patch-ac) = b19ca080112614634660a8d77303bbdc0a4b7adc
SHA1 (patch-ad) = dfbfa3fe27f8da99b35964223a754f8223a5b7e9
SHA1 (patch-ae) = 75a640c3d00541891ff46096096d434d37c28669
SHA1 (patch-af) = 57894e4e5735d13e660e363e03584b47aa3db542
SHA1 (patch-ag) = 9353901e470ae6ba793218ae1f782cadb05c02d9
SHA1 (patch-ah) = 12472b2fc40b348c7e98c9d0f094ee731486fa82
SHA1 (patch-ai) = 51c28a08a59f2b7348e7f9a37fb91c6a321198f7
SHA1 (patch-aj) = 1e28fe0c1df2e86362438883aded7ac5691d3226
SHA1 (patch-ak) = 27c90d33fcaedb91615bce884eed353ee8419963

View file

@ -0,0 +1,16 @@
$NetBSD: patch-af,v 1.1 2011/01/29 21:48:41 markd Exp $
fix build with gcc4.3
--- ../lib/antlr/lib/cpp/antlr/CharScanner.hpp.orig 2003-04-11 02:04:00.000000000 +0000
+++ ../lib/antlr/lib/cpp/antlr/CharScanner.hpp
@@ -17,6 +17,9 @@
#else
#include <cctype>
#endif
+#include <cstdio>
+#include <cstdlib>
+#include <cstring>
#include <antlr/TokenStream.hpp>
#include <antlr/RecognitionException.hpp>

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ag,v 1.1 2011/01/29 21:48:41 markd Exp $
fix build with gcc4.3
--- ../lib/antlr/lib/cpp/src/Parser.cpp.orig 2003-04-11 02:04:08.000000000 +0000
+++ ../lib/antlr/lib/cpp/src/Parser.cpp
@@ -12,6 +12,7 @@
#include "antlr/MismatchedTokenException.hpp"
//#include "antlr/ASTFactory.hpp"
#include <iostream>
+#include <cstdlib>
#ifdef ANTLR_CXX_SUPPORTS_NAMESPACE
namespace antlr {

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ah,v 1.1 2011/01/29 21:48:41 markd Exp $
fix build with gcc4.3
--- ../lib/antlr/lib/cpp/src/TreeParser.cpp.orig 2003-04-11 02:04:09.000000000 +0000
+++ ../lib/antlr/lib/cpp/src/TreeParser.cpp
@@ -10,6 +10,7 @@
#include "antlr/MismatchedTokenException.hpp"
#include <iostream>
#include <stdio.h>
+#include <cstdlib>
#ifdef ANTLR_CXX_SUPPORTS_NAMESPACE
namespace antlr {

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ai,v 1.1 2011/01/29 21:48:41 markd Exp $
fix build with gcc4.3
--- ../src/dbxml/Buffer.cpp.orig 2003-05-09 00:01:43.000000000 +0000
+++ ../src/dbxml/Buffer.cpp
@@ -13,6 +13,7 @@ static const char revid[] = "$Id: Buffer
#include <sstream>
#include <cassert>
+#include <cstring>
using namespace std;
using namespace DbXml;

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aj,v 1.1 2011/01/29 21:48:41 markd Exp $
fix build with gcc4.3
--- ../src/dbxml/IndexSpecification.hpp.orig 2003-09-17 13:08:51.000000000 +0000
+++ ../src/dbxml/IndexSpecification.hpp
@@ -12,6 +12,7 @@
#include <vector>
#include <string>
+#include <cstring>
#include <map>
#include "ID.hpp"
#include "Name.hpp"

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ak,v 1.1 2011/01/29 21:48:41 markd Exp $
fix build with gcc4.3
--- ../src/dbxml/XmlException.cpp.orig 2003-05-09 00:01:57.000000000 +0000
+++ ../src/dbxml/XmlException.cpp
@@ -15,6 +15,8 @@ static const char revid[] = "$Id: XmlExc
#include <string>
#include <sstream>
+#include <cstring>
+#include <cstdlib>
using namespace DbXml;

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2007/06/30 18:42:24 joerg Exp $
$NetBSD: distinfo,v 1.3 2011/01/29 21:52:51 markd Exp $
SHA1 (koverartist-0.5.tar.bz2) = 2fff3824c7b72a769dd2960bdc38d4dd5ff9e263
RMD160 (koverartist-0.5.tar.bz2) = 63ee6623b04dabdf8661e2f7eea162b1f15e9802
@ -6,3 +6,4 @@ Size (koverartist-0.5.tar.bz2) = 748401 bytes
SHA1 (patch-aa) = 11873caa4b0bea8a58bc8f336b29550af1ff0058
SHA1 (patch-ab) = 96600feb023b1adaa6ad0001c8c657c25bb9a9c8
SHA1 (patch-ac) = fafcbbe0a9373dc0782345bf47fb81c4c7afe23f
SHA1 (patch-ad) = f21fa915130c7c2e0765f87456c824e483a4f2c4

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ad,v 1.1 2011/01/29 21:52:52 markd Exp $
fix build with gcc4.3
--- src/cddbquery.cpp.orig 2006-11-01 10:42:59.000000000 +0000
+++ src/cddbquery.cpp
@@ -34,6 +34,7 @@
#include <iostream>
#include <errno.h>
#include <string.h>
+#include <cstdlib>