miniupnpc: Update to 2.2.0

VERSION 2.2.0 : released 2020/11/09

2020/09/24:
  Check properly for reserved IP addresses

2020/09/23:
  prevent infinite loop in upnpDiscover()

2020/02/16:
  Add Haiku support

2019/10/22:
  testminiwget.sh can use either "ip addr" or "ifconfig -a

2019/10/13:
  fix UPNP_GetValidIGD() when several devices are found
  which are reachable from != local address

2019/08/24:
  Allow Remote Host on upnpc command line
  fix error 708 description in strupnperror()

2019/04/05:
  Fix memory leak in upnpreplyparse.c with NewPortListing element

2019/03/10:
  connecthostport.c: Code simplification, error trace fix

2019/01/23:
  set timeout for select() in connecthostport()

2018/10/31:
  miniupnpcmodule.c: check return of WSAStartup()

2018/07/14:
  Fix and improve MSVC project :
    Add Dll configurations
    improve genminiupnpcstrings.vbs

2018/06/18:
  Fixes for windows 64-bits.
This commit is contained in:
nia 2020-11-23 20:15:19 +00:00
parent a7a7efb4c6
commit 15781a79cd
4 changed files with 39 additions and 7 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.4 2018/10/03 22:37:09 nia Exp $
# $NetBSD: Makefile,v 1.5 2020/11/23 20:15:19 nia Exp $
DISTNAME= miniupnpc-2.1
DISTNAME= miniupnpc-2.2.0
CATEGORIES= net
MASTER_SITES= http://miniupnp.free.fr/files/download.php?file=

View file

@ -1,8 +1,10 @@
$NetBSD: distinfo,v 1.3 2018/10/03 22:27:05 nia Exp $
$NetBSD: distinfo,v 1.4 2020/11/23 20:15:19 nia Exp $
SHA1 (miniupnpc-2.1.tar.gz) = 7abef19a5460afad704814d8db0d998781799825
RMD160 (miniupnpc-2.1.tar.gz) = 5f5eb86988f8e5ac5c9542525ac9cfa4350ad61e
SHA512 (miniupnpc-2.1.tar.gz) = 0af5c573206e0147f8e20cd84c394164a784cf385f3978b7ca414cc2b2e530d6af40a21de5c9d8459d31db249e06667757e723767b1d4cd0a4ec5497ad239c23
Size (miniupnpc-2.1.tar.gz) = 91914 bytes
SHA1 (miniupnpc-2.2.0.tar.gz) = f02f49d29518b157f370b7f59188f7f0d8e77a58
RMD160 (miniupnpc-2.2.0.tar.gz) = 69d4d46c34bf2d2608af66765a049d247f2e5eb7
SHA512 (miniupnpc-2.2.0.tar.gz) = b5bb674f162cae3d9e0205a9cdf6acc1fb334ab8ac5330be924411a8fd46833fb916d09f947d1e40d05224df7df1ecf6d812037185690e5022287c2024eb183f
Size (miniupnpc-2.2.0.tar.gz) = 98348 bytes
SHA1 (patch-Makefile) = 646f3747de66e8451667411ad605877e61fd6c32
SHA1 (patch-minissdpc.c) = 183fcebe7a94acb596db6ef03ee7663532808108
SHA1 (patch-miniwget.c) = 6bf80bc09af904c10a9ad1dc226115070860cf11
SHA1 (patch-upnpc.c) = 65a0f801de3ce41aa74a143c112e0dbd4a972dcb

View file

@ -0,0 +1,15 @@
$NetBSD: patch-miniwget.c,v 1.1 2020/11/23 20:15:19 nia Exp $
ctype arguments must be unsigned char.
--- miniwget.c.orig 2020-11-09 19:43:34.000000000 +0000
+++ miniwget.c
@@ -249,7 +249,7 @@ getHTTPResponse(SOCKET s, int * size, in
if(buf[i] == '\r') i++;
if(i<n && buf[i] == '\n') i++;
}
- while(i<n && isxdigit(buf[i])
+ while(i<n && isxdigit((unsigned char)buf[i])
&& chunksize_buf_index < (sizeof(chunksize_buf)-1))
{
chunksize_buf[chunksize_buf_index++] = buf[i];

View file

@ -0,0 +1,15 @@
$NetBSD: patch-upnpc.c,v 1.1 2020/11/23 20:15:19 nia Exp $
ctype arguments must be unsigned char.
--- upnpc.c.orig 2020-11-09 19:43:35.000000000 +0000
+++ upnpc.c
@@ -53,7 +53,7 @@ int is_int(char const* s)
return 0;
while(*s) {
/* #define isdigit(c) ((c) >= '0' && (c) <= '9') */
- if(!isdigit(*s))
+ if(!isdigit((unsigned char)*s))
return 0;
s++;
}