Add editors/hexer.

The hexer utility is a multi-buffer editor for binary files for Unix-like
systems that displays its buffer(s) as a hex dump. The user interface is
kept similar to vi/ex.
This commit is contained in:
nia 2020-12-12 13:32:51 +00:00
parent d9396fdf5c
commit 15cc776bff
7 changed files with 84 additions and 1 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.214 2020/11/28 15:56:45 maya Exp $
# $NetBSD: Makefile,v 1.215 2020/12/12 13:32:51 nia Exp $
#
COMMENT= Editors
@ -59,6 +59,7 @@ SUBDIR+= gummi
SUBDIR+= heme
SUBDIR+= hexcurse
SUBDIR+= hexedit
SUBDIR+= hexer
SUBDIR+= hnb
SUBDIR+= javascript-mode
SUBDIR+= jde

3
editors/hexer/DESCR Normal file
View File

@ -0,0 +1,3 @@
The hexer utility is a multi-buffer editor for binary files for Unix-like
systems that displays its buffer(s) as a hex dump. The user interface is
kept similar to vi/ex.

15
editors/hexer/Makefile Normal file
View File

@ -0,0 +1,15 @@
# $NetBSD: Makefile,v 1.1 2020/12/12 13:32:51 nia Exp $
DISTNAME= hexer-1.0.6
CATEGORIES= editors
MASTER_SITES= https://devel.ringlet.net/files/editors/hexer/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://devel.ringlet.net/editors/hexer/
COMMENT= Vi-like binary editor
LICENSE= hexer-license
MAKE_ENV+= MANDIR=${PREFIX}/${PKGMANDIR}
.include "../../mk/curses.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
editors/hexer/PLIST Normal file
View File

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2020/12/12 13:32:51 nia Exp $
bin/hexer
man/hexer.1

7
editors/hexer/distinfo Normal file
View File

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2020/12/12 13:32:51 nia Exp $
SHA1 (hexer-1.0.6.tar.gz) = a4569854b2991d6c74098a4d8663e38dab8386b5
RMD160 (hexer-1.0.6.tar.gz) = 98840d75640a5d2e41f1a3a9beee6e93297e7b49
SHA512 (hexer-1.0.6.tar.gz) = fc34037fa815b6f360572aa488a0a19d831d7f4d8a4d71f8882c75f727752b5381a84338a0eba077487e468f443ce954f854e80df710802ea94d6a23ee871630
Size (hexer-1.0.6.tar.gz) = 129486 bytes
SHA1 (patch-tio.c) = dc76324d87394dd111a3579c2f02d0bd96d3cb5d

View File

@ -0,0 +1,14 @@
$NetBSD: patch-tio.c,v 1.1 2020/12/12 13:32:51 nia Exp $
Include stdarg.h for va_list.
--- tio.c.orig 2020-04-24 13:06:48.000000000 +0000
+++ tio.c
@@ -59,6 +59,7 @@
#include <stdio.h>
#include <ctype.h>
#include <string.h>
+#include <stdarg.h>
#include <stdlib.h>
#include <errno.h>
#include <assert.h>

40
licenses/hexer-license Normal file
View File

@ -0,0 +1,40 @@
Copyright (c) 1995,1996 Sascha Demetrio
All rights reserved.
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions
are met:
1. Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.
If you modify any part of HEXER and redistribute it, you must add
a notice to the `README' file and the modified source files containing
information about the changes you made. I do not want to take
credit or be blamed for your modifications.
2. Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.
If you modify any part of HEXER and redistribute it in binary form,
you must supply a `README' file containing information about the
changes you made.
3. The name of the developer may not be used to endorse or promote
products derived from this software without specific prior written
permission.
HEXER WAS DEVELOPED BY SASCHA DEMETRIO.
THIS SOFTWARE SHOULD NOT BE CONSIDERED TO BE A COMMERCIAL PRODUCT.
THE DEVELOPER URGES THAT USERS WHO REQUIRE A COMMERCIAL PRODUCT
NOT MAKE USE OF THIS WORK.
DISCLAIMER:
THIS SOFTWARE IS PROVIDED BY THE DEVELOPER ``AS IS'' AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE DEVELOPER BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
SUCH DAMAGE.