Update to 2.61, and obey USE_INET6. Change highlights:
* Fixed two format string vulnerabilities (die() and log_event()) (Closes: #243945) * Segfaults when trying to send mail with authenticated smtp (Closes: #261975) * Make address rewriting possible to disable (Closes: #146238) * Add AuthUser, AuthPass, AuthMethod to configuration file (Closes: #249905) * Logic to choose cram-md5 authentication is backwards (Closes: #249907) * SSMTP builds with MD5 support but during the exchange it segfaults (Closes: #249203) * The source compilaton fails if ./configure --enable-logfile is selected (Closes: #242905) * SSL/TLS support cannot handle STARTTLS (Closes: #244666) * Creates bad date headers on some systems (Closes: #230864) * Fix 'MAIL FROM' problems with cron and the like setting bad 'From:' address when FromLineOverride=YES is set (Closes: #205513) * Update version string in ssmtp.c (Closes: #198763) * Work around missing spaces in headers (Closes: #192445)
This commit is contained in:
parent
73d1e9cd64
commit
15f2a20edc
3 changed files with 22 additions and 15 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.10 2004/10/03 00:12:54 tv Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2004/10/22 14:45:47 tv Exp $
|
||||
# FreeBSD Id: ports/mail/ssmtp/Makefile,v 1.10 2003/04/14 08:41:04 leeym Exp
|
||||
#
|
||||
# TLS functionality needs testing. Please let me know the result,
|
||||
|
@ -7,9 +7,8 @@
|
|||
# pkg@pop.707.to
|
||||
# Toru TAKAMIZU
|
||||
|
||||
DISTNAME= ssmtp_2.60.3
|
||||
PKGNAME= ssmtp-2.60.3
|
||||
PKGREVISION= 3
|
||||
DISTNAME= ssmtp_2.61.orig
|
||||
PKGNAME= ssmtp-2.61
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/s/ssmtp/}
|
||||
|
||||
|
@ -17,13 +16,18 @@ MAINTAINER= pkg@pop.707.to
|
|||
HOMEPAGE= http://packages.debian.org/testing/mail/ssmtp.html
|
||||
COMMENT= Extremely simple MTA to forward mail to a mail hub
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGBASE}-${PKGVERSION:C/([0-9]+.[0-9]+)(.[0-9]+)(nb[0-9]+)?$/\1/}
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV:S/.orig$//}
|
||||
USE_BUILDLINK3= YES
|
||||
USE_PKGINSTALL= YES
|
||||
|
||||
USE_GNU_TOOLS+= make
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --enable-ssl --enable-inet6
|
||||
CONFIGURE_ARGS+= --enable-ssl
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.if !empty(USE_INET6:M[Yy][Ee][Ss])
|
||||
CONFIGURE_ARGS+= --enable-inet6
|
||||
.endif
|
||||
|
||||
PKG_SYSCONFSUBDIR= ${PKGBASE}
|
||||
EGDIR= ${PREFIX}/share/examples/${PKGBASE}
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.2 2004/06/17 11:35:28 grant Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/10/22 14:45:47 tv Exp $
|
||||
|
||||
SHA1 (ssmtp_2.60.3.tar.gz) = 09aad88a61f3ee014b52e0daa3e8749d612ceaef
|
||||
Size (ssmtp_2.60.3.tar.gz) = 159289 bytes
|
||||
SHA1 (ssmtp_2.61.orig.tar.gz) = bc4b6c20bf8c2c9e66b359e3c24545a2615a1988
|
||||
Size (ssmtp_2.61.orig.tar.gz) = 53341 bytes
|
||||
SHA1 (patch-aa) = 73681fd5585fe520fb9620e2f8358c41ad42cfd8
|
||||
SHA1 (patch-ab) = 76b2669443ff3ac488c18f3c7877cf621f7b3708
|
||||
SHA1 (patch-ab) = fd4fb2e5baeacd9f1e60c04cd6c4229c39fa2641
|
||||
SHA1 (patch-ac) = c42d3fbfc3054cd1cc730c9fdde57f2d9498bcb4
|
||||
SHA1 (patch-ad) = 92c666b84e8fa20103103f6d24f887a587d57a4c
|
||||
SHA1 (patch-ae) = ef626358229731e6afff2e194928780e5fc908a3
|
||||
|
|
|
@ -1,10 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2003/06/19 20:39:10 jlam Exp $
|
||||
$NetBSD: patch-ab,v 1.2 2004/10/22 14:45:47 tv Exp $
|
||||
|
||||
--- ssmtp.c.orig Sun Dec 8 18:26:20 2002
|
||||
+++ ssmtp.c Mon Apr 7 01:24:52 2003
|
||||
@@ -14,6 +14,7 @@
|
||||
--- ssmtp.c.orig Fri Jul 23 01:58:48 2004
|
||||
+++ ssmtp.c
|
||||
@@ -12,8 +12,9 @@
|
||||
See COPYRIGHT for the license
|
||||
|
||||
*/
|
||||
#define VERSION "2.60.1"
|
||||
-#define VERSION "2.60.4"
|
||||
+#define VERSION "2.61"
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
|
|
Loading…
Reference in a new issue