Update ruby-httpclient to 2.2.0.
switch to use gem. = Changes in 2.2.0 = Apr 8, 2011 - version 2.2.0 * Features * Add HTTPClient#cookies as an alias of #cookie_manager.cookies. * Add res.cookies method. It returns parsed cookie in response header. It's different from client.cookie_manager.cookies. Manager keeps persistent cookies in it. * Add res.headers method which returns a Hash of headers. Hash key and value are both String. Each key has a single value so you can't extract exact value when a message has multiple headers like 'Set-Cookie'. Use header['Set-Cookie'] for that purpose. (It returns an Array always) * Allow keyword style argument for HTTPClient#get, post, etc. Introduced keywords are: :body, :query, and :header. You can write HTTPClient.get(uri, :header => {'X-custom' => '1'}) instead of; HTTPClient.get(uri, nil, {'X-custom' => '1'}) * Add new keyword argument :follow_redirect to get/post. Now you can follow redirection response with passing :follow_redirect => true. * [INCOMPAT] Rename HTTPClient::HTTP::Message#body to #http_body, then add #body as an alias of #content. It's incompatible change though users rarely depends on this method. (I've never seen such a case) Users who are using req.body and/or res.body should follow this change. (req.http_body and res.http_body) * Bug fixes * Reenable keep-alive for chunked response. This feature was disabled by c206b687952e1ad3e20c20e69bdbd1a9cb38609e at 2008-12-09. I should have written a test for keep-alive. Now I added it. Thanks Takahiro Nishimura(@dr_taka_n) for finding this bug. = Changes in 2.1.7 = Mar 22, 2011 - version 2.1.7 * Features * Add MD5-sess auth support. Thanks to wimm-dking. (#47) * Add SNI support. (Server Name Indication of HTTPS connection) (#49) * Add GSSAPI auth support using gssapi gem. Thanks to zenchild. (#50) * NTLM logon to exchange Web Services. [experimental] Thanks to curzonj and mccraigmccraig (#52) * Add HTTPOnly cookie support. Thanks to nbrosnahan. (#55) * Add HTTPClient#socket_local for specifying local binding hostname and port of TCP socket. Thanks to icblenke.
This commit is contained in:
parent
6b3fdc261b
commit
160f402c85
4 changed files with 36 additions and 48 deletions
|
@ -1,10 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/02/25 02:25:59 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.2 2011/04/15 11:06:51 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= httpclient-2.1.6.1
|
||||
DISTNAME= httpclient-2.2.0
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://dev.ctor.org/download/ \
|
||||
http://dev.ctor.org/download/archive/
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= https://github.com/nahi/httpclient
|
||||
|
@ -15,10 +13,5 @@ PKG_DESTDIR_SUPPORT= user-destdir
|
|||
|
||||
USE_LANGUAGES= # none
|
||||
|
||||
USE_RUBY_INSTALL= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
INSTALLATION_DIRS= ${RUBY_VENDORLIB}
|
||||
|
||||
.include "../../lang/ruby/modules.mk"
|
||||
.include "../../lang/ruby/gem.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,16 +1,29 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/02/25 02:25:59 obache Exp $
|
||||
${RUBY_VENDORLIB}/hexdump.rb
|
||||
${RUBY_VENDORLIB}/http-access2.rb
|
||||
${RUBY_VENDORLIB}/http-access2/cookie.rb
|
||||
${RUBY_VENDORLIB}/http-access2/http.rb
|
||||
${RUBY_VENDORLIB}/httpclient.rb
|
||||
${RUBY_VENDORLIB}/httpclient/auth.rb
|
||||
${RUBY_VENDORLIB}/httpclient/cacert.p7s
|
||||
${RUBY_VENDORLIB}/httpclient/connection.rb
|
||||
${RUBY_VENDORLIB}/httpclient/cookie.rb
|
||||
${RUBY_VENDORLIB}/httpclient/http.rb
|
||||
${RUBY_VENDORLIB}/httpclient/session.rb
|
||||
${RUBY_VENDORLIB}/httpclient/ssl_config.rb
|
||||
${RUBY_VENDORLIB}/httpclient/timeout.rb
|
||||
${RUBY_VENDORLIB}/httpclient/util.rb
|
||||
${RUBY_VENDORLIB}/oauthclient.rb
|
||||
@comment $NetBSD: PLIST,v 1.2 2011/04/15 11:06:51 obache Exp $
|
||||
${GEM_HOME}/cache/${GEM_NAME}.gem
|
||||
${GEM_LIBDIR}/lib/hexdump.rb
|
||||
${GEM_LIBDIR}/lib/http-access2.rb
|
||||
${GEM_LIBDIR}/lib/http-access2.rbc
|
||||
${GEM_LIBDIR}/lib/http-access2/cookie.rb
|
||||
${GEM_LIBDIR}/lib/http-access2/http.rb
|
||||
${GEM_LIBDIR}/lib/httpclient.rb
|
||||
${GEM_LIBDIR}/lib/httpclient.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/auth.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/auth.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/cacert.p7s
|
||||
${GEM_LIBDIR}/lib/httpclient/cacert_sha1.p7s
|
||||
${GEM_LIBDIR}/lib/httpclient/connection.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/connection.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/cookie.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/cookie.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/http.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/http.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/session.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/session.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/ssl_config.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/ssl_config.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/timeout.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/timeout.rbc
|
||||
${GEM_LIBDIR}/lib/httpclient/util.rb
|
||||
${GEM_LIBDIR}/lib/httpclient/util.rbc
|
||||
${GEM_LIBDIR}/lib/oauthclient.rb
|
||||
${GEM_HOME}/specifications/${GEM_NAME}.gemspec
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/02/25 02:25:59 obache Exp $
|
||||
$NetBSD: distinfo,v 1.2 2011/04/15 11:06:51 obache Exp $
|
||||
|
||||
SHA1 (httpclient-2.1.6.1.tar.gz) = f420e20b7c6ac10e8eabce0d9bcf436e8e588da8
|
||||
RMD160 (httpclient-2.1.6.1.tar.gz) = bd66389b6c0c5dbf51129a8e3986640dc7c3854c
|
||||
Size (httpclient-2.1.6.1.tar.gz) = 253500 bytes
|
||||
SHA1 (patch-install.rb) = 20468591e2e2f0be7a654507dad653b570a5b5b6
|
||||
SHA1 (httpclient-2.2.0.gem) = 84d8b7fc4132c419ff99a108b95b292c1df625db
|
||||
RMD160 (httpclient-2.2.0.gem) = dcedb01c1fb6cec5cd6eeed66c461c81bc2747da
|
||||
Size (httpclient-2.2.0.gem) = 230912 bytes
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-install.rb,v 1.1.1.1 2011/02/25 02:25:59 obache Exp $
|
||||
|
||||
* staged-installation support
|
||||
|
||||
--- install.rb.orig 2010-12-20 11:05:43.000000000 +0000
|
||||
+++ install.rb
|
||||
@@ -10,6 +10,10 @@ include Config
|
||||
SITELIBDIR = CONFIG["sitelibdir"]
|
||||
SRCPATH = File.join(File.dirname($0), 'lib')
|
||||
|
||||
+if (destdir = ENV['DESTDIR'])
|
||||
+ SITELIBDIR = File.join(destdir, SITELIBDIR)
|
||||
+end
|
||||
+
|
||||
def install_file(from, to)
|
||||
unless File.directory?(to)
|
||||
to = File.dirname(to)
|
Loading…
Reference in a new issue