Updated textproc/xapian to 1.2.2
tested on NetBSD 5.x amd64 changelog since 1.0.18 runs to 64k with no obvious highlights.
This commit is contained in:
parent
74c772c95d
commit
162caf3f93
5 changed files with 97 additions and 73 deletions
|
@ -1,10 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.11 2010/02/16 14:51:26 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2010/12/03 09:55:33 abs Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xapian-core-1.0.18
|
||||
DISTNAME= xapian-core-1.2.2
|
||||
PKGNAME= ${DISTNAME:S/-core//}
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://oligarchy.co.uk/xapian/1.0.18/
|
||||
MASTER_SITES= http://oligarchy.co.uk/xapian/1.2.2/
|
||||
|
||||
MAINTAINER= schmonz@NetBSD.org
|
||||
HOMEPAGE= http://xapian.org/
|
||||
|
@ -19,9 +19,16 @@ USE_LANGUAGES= c c++
|
|||
|
||||
TEST_TARGET= check
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.xapian
|
||||
.if ${OPSYS} == "Darwin"
|
||||
PKG_SUPPORTED_OPTIONS= xapian-flint-backend xapian-quartz-backend
|
||||
PKG_SUGGESTED_OPTIONS= xapian-flint-backend xapian-quartz-backend
|
||||
.else
|
||||
PKG_SUPPORTED_OPTIONS= xapian-flint-backend
|
||||
PKG_SUGGESTED_OPTIONS= xapian-flint-backend
|
||||
.endif
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2010/02/16 14:51:26 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2010/12/03 09:55:33 abs Exp $
|
||||
bin/copydatabase
|
||||
bin/delve
|
||||
${PLIST.quartz}bin/quartzcheck
|
||||
|
@ -10,33 +10,45 @@ bin/simpleindex
|
|||
bin/simplesearch
|
||||
${PLIST.flint}bin/xapian-check
|
||||
${PLIST.flint}bin/xapian-compact
|
||||
bin/xapian-chert-update
|
||||
bin/xapian-config
|
||||
${PLIST.flint}bin/xapian-inspect
|
||||
bin/xapian-metadata
|
||||
bin/xapian-progsrv
|
||||
bin/xapian-replicate
|
||||
bin/xapian-replicate-server
|
||||
bin/xapian-tcpsrv
|
||||
include/xapian.h
|
||||
include/xapian/base.h
|
||||
include/xapian/database.h
|
||||
include/xapian/dbfactory.h
|
||||
include/xapian/deprecated.h
|
||||
include/xapian/derefwrapper.h
|
||||
include/xapian/document.h
|
||||
include/xapian/enquire.h
|
||||
include/xapian/error.h
|
||||
include/xapian/errorhandler.h
|
||||
include/xapian/expanddecider.h
|
||||
include/xapian/keymaker.h
|
||||
include/xapian/matchspy.h
|
||||
include/xapian/positioniterator.h
|
||||
include/xapian/postingiterator.h
|
||||
include/xapian/postingsource.h
|
||||
include/xapian/query.h
|
||||
include/xapian/queryparser.h
|
||||
include/xapian/sorter.h
|
||||
include/xapian/registry.h
|
||||
include/xapian/stem.h
|
||||
include/xapian/termgenerator.h
|
||||
include/xapian/termiterator.h
|
||||
include/xapian/types.h
|
||||
include/xapian/unicode.h
|
||||
include/xapian/valueiterator.h
|
||||
include/xapian/valuesetmatchdecider.h
|
||||
include/xapian/version.h
|
||||
include/xapian/visibility.h
|
||||
include/xapian/weight.h
|
||||
lib/cmake/xapian/xapian-config-version.cmake
|
||||
lib/cmake/xapian/xapian-config.cmake
|
||||
lib/libxapian.la
|
||||
man/man1/copydatabase.1
|
||||
man/man1/delve.1
|
||||
|
@ -46,9 +58,13 @@ ${PLIST.quartz}man/man1/quartzdump.1
|
|||
man/man1/quest.1
|
||||
${PLIST.flint}man/man1/xapian-check.1
|
||||
${PLIST.flint}man/man1/xapian-compact.1
|
||||
man/man1/xapian-chert-update.1
|
||||
man/man1/xapian-config.1
|
||||
${PLIST.flint}man/man1/xapian-inspect.1
|
||||
man/man1/xapian-metadata.1
|
||||
man/man1/xapian-progsrv.1
|
||||
man/man1/xapian-replicate-server.1
|
||||
man/man1/xapian-replicate.1
|
||||
man/man1/xapian-tcpsrv.1
|
||||
share/aclocal/xapian.m4
|
||||
share/doc/xapian-core/admin_notes.html
|
||||
|
@ -90,6 +106,9 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1Database__inherit__graph.png
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1DateValueRangeProcessor-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DateValueRangeProcessor.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DateValueRangeProcessor__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DecreasingValueWeightPostingSource-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DecreasingValueWeightPostingSource.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DecreasingValueWeightPostingSource__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DocNotFoundError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DocNotFoundError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1DocNotFoundError__inherit__graph.png
|
||||
|
@ -118,6 +137,9 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1ExpandDecider__inherit__graph.p
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1FeatureUnavailableError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1FeatureUnavailableError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1FeatureUnavailableError__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1FixedWeightPostingSource-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1FixedWeightPostingSource.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1FixedWeightPostingSource__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1InternalError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1InternalError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1InternalError__inherit__graph.png
|
||||
|
@ -127,6 +149,9 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1InvalidArgumentError__inherit__
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1InvalidOperationError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1InvalidOperationError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1InvalidOperationError__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1KeyMaker-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1KeyMaker.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1KeyMaker__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1LogicError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1LogicError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1LogicError__inherit__graph.png
|
||||
|
@ -136,6 +161,13 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1MSetIterator-members.html
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1MSetIterator.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MatchDecider-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MatchDecider.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MatchDecider__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MatchSpy-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MatchSpy.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MatchSpy__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MultiValueKeyMaker-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MultiValueKeyMaker.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MultiValueKeyMaker__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MultiValueSorter-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MultiValueSorter.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1MultiValueSorter__inherit__graph.png
|
||||
|
@ -152,6 +184,9 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1PositionIterator-members.html
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1PositionIterator.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1PostingIterator-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1PostingIterator.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1PostingSource-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1PostingSource.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1PostingSource__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Query-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Query.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1QueryParser-members.html
|
||||
|
@ -164,9 +199,14 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1RSet.html
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1RangeError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1RangeError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1RangeError__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Registry-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Registry.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1RuntimeError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1RuntimeError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1RuntimeError__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1SerialisationError-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1SerialisationError.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1SerialisationError__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1SimpleStopper-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1SimpleStopper.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1SimpleStopper__inherit__graph.png
|
||||
|
@ -193,8 +233,23 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1UnimplementedError.html
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1UnimplementedError__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Utf8Iterator-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Utf8Iterator.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueCountMatchSpy-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueCountMatchSpy.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueCountMatchSpy__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueIterator-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueIterator.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueMapPostingSource-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueMapPostingSource.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueMapPostingSource__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValuePostingSource-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValuePostingSource.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValuePostingSource__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueSetMatchDecider-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueSetMatchDecider.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueSetMatchDecider__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueWeightPostingSource-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueWeightPostingSource.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1ValueWeightPostingSource__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Weight-members.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Weight.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1Weight__inherit__graph.png
|
||||
|
@ -202,6 +257,7 @@ share/doc/xapian-core/apidoc/html/classXapian_1_1WritableDatabase-members.html
|
|||
share/doc/xapian-core/apidoc/html/classXapian_1_1WritableDatabase.html
|
||||
share/doc/xapian-core/apidoc/html/classXapian_1_1WritableDatabase__inherit__graph.png
|
||||
share/doc/xapian-core/apidoc/html/classes.html
|
||||
share/doc/xapian-core/apidoc/html/closed.gif
|
||||
share/doc/xapian-core/apidoc/html/database_8h.html
|
||||
share/doc/xapian-core/apidoc/html/dbfactory_8h.html
|
||||
share/doc/xapian-core/apidoc/html/deprecated.html
|
||||
|
@ -213,18 +269,6 @@ share/doc/xapian-core/apidoc/html/error_8h.html
|
|||
share/doc/xapian-core/apidoc/html/errorhandler_8h.html
|
||||
share/doc/xapian-core/apidoc/html/expanddecider_8h.html
|
||||
share/doc/xapian-core/apidoc/html/files.html
|
||||
share/doc/xapian-core/apidoc/html/form_0.png
|
||||
share/doc/xapian-core/apidoc/html/form_1.png
|
||||
share/doc/xapian-core/apidoc/html/form_10.png
|
||||
share/doc/xapian-core/apidoc/html/form_11.png
|
||||
share/doc/xapian-core/apidoc/html/form_2.png
|
||||
share/doc/xapian-core/apidoc/html/form_3.png
|
||||
share/doc/xapian-core/apidoc/html/form_4.png
|
||||
share/doc/xapian-core/apidoc/html/form_5.png
|
||||
share/doc/xapian-core/apidoc/html/form_6.png
|
||||
share/doc/xapian-core/apidoc/html/form_7.png
|
||||
share/doc/xapian-core/apidoc/html/form_8.png
|
||||
share/doc/xapian-core/apidoc/html/form_9.png
|
||||
share/doc/xapian-core/apidoc/html/functions.html
|
||||
share/doc/xapian-core/apidoc/html/functions_0x62.html
|
||||
share/doc/xapian-core/apidoc/html/functions_0x63.html
|
||||
|
@ -248,6 +292,7 @@ share/doc/xapian-core/apidoc/html/functions_0x75.html
|
|||
share/doc/xapian-core/apidoc/html/functions_0x76.html
|
||||
share/doc/xapian-core/apidoc/html/functions_0x77.html
|
||||
share/doc/xapian-core/apidoc/html/functions_0x7e.html
|
||||
share/doc/xapian-core/apidoc/html/functions_enum.html
|
||||
share/doc/xapian-core/apidoc/html/functions_eval.html
|
||||
share/doc/xapian-core/apidoc/html/functions_func.html
|
||||
share/doc/xapian-core/apidoc/html/functions_func_0x62.html
|
||||
|
@ -272,12 +317,11 @@ share/doc/xapian-core/apidoc/html/functions_func_0x75.html
|
|||
share/doc/xapian-core/apidoc/html/functions_func_0x76.html
|
||||
share/doc/xapian-core/apidoc/html/functions_func_0x77.html
|
||||
share/doc/xapian-core/apidoc/html/functions_func_0x7e.html
|
||||
share/doc/xapian-core/apidoc/html/functions_rela.html
|
||||
share/doc/xapian-core/apidoc/html/functions_type.html
|
||||
share/doc/xapian-core/apidoc/html/functions_vars.html
|
||||
share/doc/xapian-core/apidoc/html/globals.html
|
||||
share/doc/xapian-core/apidoc/html/globals_func.html
|
||||
share/doc/xapian-core/apidoc/html/globals_type.html
|
||||
share/doc/xapian-core/apidoc/html/globals_vars.html
|
||||
share/doc/xapian-core/apidoc/html/globals_defs.html
|
||||
share/doc/xapian-core/apidoc/html/graph_legend.html
|
||||
share/doc/xapian-core/apidoc/html/graph_legend.png
|
||||
share/doc/xapian-core/apidoc/html/hierarchy.html
|
||||
|
@ -300,6 +344,10 @@ share/doc/xapian-core/apidoc/html/inherit__graph__21.png
|
|||
share/doc/xapian-core/apidoc/html/inherit__graph__22.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__23.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__24.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__25.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__26.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__27.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__28.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__3.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__4.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__5.png
|
||||
|
@ -308,25 +356,33 @@ share/doc/xapian-core/apidoc/html/inherit__graph__7.png
|
|||
share/doc/xapian-core/apidoc/html/inherit__graph__8.png
|
||||
share/doc/xapian-core/apidoc/html/inherit__graph__9.png
|
||||
share/doc/xapian-core/apidoc/html/inherits.html
|
||||
share/doc/xapian-core/apidoc/html/keymaker_8h.html
|
||||
share/doc/xapian-core/apidoc/html/matchspy_8h.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1Auto.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1Brass.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1Chert.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1Flint.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1InMemory.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1Quartz.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1Remote.html
|
||||
share/doc/xapian-core/apidoc/html/namespaceXapian_1_1Unicode.html
|
||||
share/doc/xapian-core/apidoc/html/namespacemembers.html
|
||||
share/doc/xapian-core/apidoc/html/namespacemembers_enum.html
|
||||
share/doc/xapian-core/apidoc/html/namespacemembers_func.html
|
||||
share/doc/xapian-core/apidoc/html/namespacemembers_type.html
|
||||
share/doc/xapian-core/apidoc/html/namespacemembers_vars.html
|
||||
share/doc/xapian-core/apidoc/html/namespaces.html
|
||||
share/doc/xapian-core/apidoc/html/open.gif
|
||||
share/doc/xapian-core/apidoc/html/pages.html
|
||||
share/doc/xapian-core/apidoc/html/positioniterator_8h.html
|
||||
share/doc/xapian-core/apidoc/html/postingiterator_8h.html
|
||||
share/doc/xapian-core/apidoc/html/postingsource_8h.html
|
||||
share/doc/xapian-core/apidoc/html/query_8h.html
|
||||
share/doc/xapian-core/apidoc/html/queryparser_8h.html
|
||||
share/doc/xapian-core/apidoc/html/sorter_8h.html
|
||||
share/doc/xapian-core/apidoc/html/registry_8h.html
|
||||
share/doc/xapian-core/apidoc/html/stem_8h.html
|
||||
share/doc/xapian-core/apidoc/html/structXapian_1_1StemImplementation-members.html
|
||||
share/doc/xapian-core/apidoc/html/structXapian_1_1StemImplementation.html
|
||||
share/doc/xapian-core/apidoc/html/structXapian_1_1ValueRangeProcessor-members.html
|
||||
share/doc/xapian-core/apidoc/html/structXapian_1_1ValueRangeProcessor.html
|
||||
share/doc/xapian-core/apidoc/html/structXapian_1_1ValueRangeProcessor__inherit__graph.png
|
||||
|
@ -339,9 +395,12 @@ share/doc/xapian-core/apidoc/html/termiterator_8h.html
|
|||
share/doc/xapian-core/apidoc/html/types_8h.html
|
||||
share/doc/xapian-core/apidoc/html/unicode_8h.html
|
||||
share/doc/xapian-core/apidoc/html/valueiterator_8h.html
|
||||
share/doc/xapian-core/apidoc/html/valuesetmatchdecider_8h.html
|
||||
share/doc/xapian-core/apidoc/html/version_8h.html
|
||||
share/doc/xapian-core/apidoc/html/weight_8h.html
|
||||
share/doc/xapian-core/apidoc/html/xapian_8h.html
|
||||
share/doc/xapian-core/bm25.html
|
||||
share/doc/xapian-core/categorisation.html
|
||||
share/doc/xapian-core/code_structure.html
|
||||
share/doc/xapian-core/deprecation.html
|
||||
share/doc/xapian-core/glossary.html
|
||||
|
@ -351,7 +410,8 @@ share/doc/xapian-core/internals.html
|
|||
share/doc/xapian-core/intro_ir.html
|
||||
share/doc/xapian-core/matcherdesign.html
|
||||
share/doc/xapian-core/overview.html
|
||||
share/doc/xapian-core/quartzdesign.html
|
||||
share/doc/xapian-core/postingsource.html
|
||||
${PLIST.quartz}share/doc/xapian-core/quartzdesign.html
|
||||
share/doc/xapian-core/queryparser.html
|
||||
share/doc/xapian-core/quickstart.html
|
||||
share/doc/xapian-core/quickstartexpand.cc.html
|
||||
|
@ -359,7 +419,10 @@ share/doc/xapian-core/quickstartindex.cc.html
|
|||
share/doc/xapian-core/quickstartsearch.cc.html
|
||||
share/doc/xapian-core/remote.html
|
||||
share/doc/xapian-core/remote_protocol.html
|
||||
share/doc/xapian-core/replication.html
|
||||
share/doc/xapian-core/replication_protocol.html
|
||||
share/doc/xapian-core/scalability.html
|
||||
share/doc/xapian-core/serialisation.html
|
||||
share/doc/xapian-core/sorting.html
|
||||
share/doc/xapian-core/spelling.html
|
||||
share/doc/xapian-core/stemming.html
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.9 2010/02/16 14:51:26 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.10 2010/12/03 09:55:33 abs Exp $
|
||||
|
||||
SHA1 (xapian-core-1.0.18.tar.gz) = 36f2cfc082c8a18d63bc31319f241a717ea3dd1e
|
||||
RMD160 (xapian-core-1.0.18.tar.gz) = 2757ff6837c21d6d7209ffe9b90ae41f48e85f59
|
||||
Size (xapian-core-1.0.18.tar.gz) = 3318636 bytes
|
||||
SHA1 (patch-aa) = 13ed32d321966aed09b25ea5fb66cf8ae4e59181
|
||||
SHA1 (patch-ab) = da0ddb6ee3cef1b463afdd92f889e27eae5f3075
|
||||
SHA1 (xapian-core-1.2.2.tar.gz) = 9e8036689650556428ecc605d03a695df561bfa6
|
||||
RMD160 (xapian-core-1.2.2.tar.gz) = a56912884ff302f5da2545c80c7bcd81f3bddef4
|
||||
Size (xapian-core-1.2.2.tar.gz) = 3849005 bytes
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2009/11/24 21:57:53 agc Exp $
|
||||
|
||||
provide a stringise function for systems with 64-bit time_t's.
|
||||
|
||||
--- common/utils.h 2009/11/24 21:19:07 1.1
|
||||
+++ common/utils.h 2009/11/24 21:19:49
|
||||
@@ -52,10 +52,9 @@
|
||||
XAPIAN_VISIBILITY_DEFAULT
|
||||
string om_tostring(unsigned long int a);
|
||||
|
||||
-#ifdef __WIN32__
|
||||
/// Convert a 64 bit integer to a string
|
||||
-string om_tostring(__int64 a);
|
||||
-#endif
|
||||
+XAPIAN_VISIBILITY_DEFAULT
|
||||
+string om_tostring(long long a);
|
||||
|
||||
/// Convert a double to a string
|
||||
XAPIAN_VISIBILITY_DEFAULT
|
|
@ -1,25 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2009/11/24 21:57:53 agc Exp $
|
||||
|
||||
provide a stringise function for systems with 64-bit time_t's.
|
||||
|
||||
--- common/utils.cc 2009/11/24 21:19:54 1.1
|
||||
+++ common/utils.cc 2009/11/24 21:20:41
|
||||
@@ -73,16 +73,11 @@
|
||||
CONVERT_TO_STRING("%lu")
|
||||
}
|
||||
|
||||
-#ifdef __WIN32__
|
||||
string
|
||||
-om_tostring(__int64 val)
|
||||
+om_tostring(long long val)
|
||||
{
|
||||
- // Avoid a format string warning from GCC - mingw uses the MS C runtime DLL
|
||||
- // which does understand "%I64d", but GCC doesn't know that.
|
||||
- static const char fmt[] = { '%', 'I', '6', '4', 'd', 0 };
|
||||
- CONVERT_TO_STRING(fmt)
|
||||
+ CONVERT_TO_STRING("%lld")
|
||||
}
|
||||
-#endif
|
||||
|
||||
string
|
||||
om_tostring(double val)
|
Loading…
Reference in a new issue