Update wget to 1.17.1:

* Changes in Wget 1.17.1

* Fix compile error when IPv6 is disabled or SSL is not present.

* Fix HSTS memory leak.

* Fix progress output in non-C locales.

* Fix SIGSEGV when -N and --content-disposition are used together.

* Add --check-certificate=quiet to tell wget to not print any warning about
  invalid certificates.
This commit is contained in:
wiz 2015-12-13 08:30:24 +00:00
parent 861bb40de5
commit 163f441be5
3 changed files with 7 additions and 40 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.127 2015/11/21 09:44:53 wiz Exp $
# $NetBSD: Makefile,v 1.128 2015/12/13 08:30:24 wiz Exp $
DISTNAME= wget-1.17
DISTNAME= wget-1.17.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU:=wget/}
EXTRACT_SUFX= .tar.xz

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.49 2015/11/23 21:49:04 schmonz Exp $
$NetBSD: distinfo,v 1.50 2015/12/13 08:30:24 wiz Exp $
SHA1 (wget-1.17.tar.xz) = 442330c7381593bdde568d15b758b76bdb9b98a2
RMD160 (wget-1.17.tar.xz) = ea35738ca2e5b60a191b45a698b0a98766fc57d6
SHA512 (wget-1.17.tar.xz) = 4936dad41580f6ba33df73de041e407cd6dd5266af4af947ebf4c54457f0f296e3462cfff1fb203b27ff5760ec4f6f4d24ea4faceeea461f98c22b031225947f
Size (wget-1.17.tar.xz) = 1884628 bytes
SHA1 (wget-1.17.1.tar.xz) = 8ae737ab2252607ce708f98d1dd7559ebf047f48
RMD160 (wget-1.17.1.tar.xz) = 8ad5e9936c66ced9ad4ffc5012484a38f4a15cee
SHA512 (wget-1.17.1.tar.xz) = aa13584c94d0911268aeee9d6c7b1a7de259e0ec0f9daebe767e1f45afba097a6e9de09f370e55ead7acc9faa68f189063ac9e3d2d4a8d490f0b4edb6adc19ba
Size (wget-1.17.1.tar.xz) = 1894140 bytes
SHA1 (patch-doc_wget.texi) = 6db25b3500ff4617b5ade34d9013b1f9876104f8
SHA1 (patch-src_ftp-basic.c) = 9e8a9457c5e947d234dc639818e49589d5c72e9e

View file

@ -1,32 +0,0 @@
$NetBSD: patch-src_ftp-basic.c,v 1.1 2015/11/23 21:49:05 schmonz Exp $
Fix linker errors when building with --disable-ipv6.
From <URL:http://permalink.gmane.org/gmane.comp.web.wget.general/14984>
--- src/ftp-basic.c.orig 2015-11-09 15:24:06.000000000 +0000
+++ src/ftp-basic.c
@@ -428,6 +428,7 @@ ip_address_to_eprt_repr (const ip_addres
snprintf (buf, buflen, "|%d|%s|%d|", afnum, print_address (addr), port);
buf[buflen - 1] = '\0';
}
+#endif /* ENABLE_IPV6 */
#ifdef HAVE_SSL
/*
@@ -542,6 +543,7 @@ bail:
}
#endif /* HAVE_SSL */
+#ifdef ENABLE_IPV6
/* Bind a port and send the appropriate PORT command to the FTP
server. Use acceptport after RETR, to get the socket of data
connection. */
@@ -599,7 +601,7 @@ ftp_eprt (int csock, int *local_sock)
xfree (respline);
return FTPOK;
}
-#endif
+#endif /* ENABLE_IPV6 */
/* Similar to ftp_port, but uses `PASV' to initiate the passive FTP
transfer. Reads the response from server and parses it. Reads the