Logging option added, defaults to same logging as rdist.
This commit is contained in:
parent
e574980986
commit
1675dcd54a
3 changed files with 6 additions and 41 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.11 2006/01/05 19:38:40 christos Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2006/06/04 07:58:36 kim Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sdist-1.6
|
||||
PKGREVISION= 1
|
||||
DISTNAME= sdist-1.7
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.gw.com/pub/people/kim/
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.4 2006/01/05 19:38:40 christos Exp $
|
||||
$NetBSD: distinfo,v 1.5 2006/06/04 07:58:36 kim Exp $
|
||||
|
||||
SHA1 (sdist-1.6.tar.gz) = 5de04da4a637f10328ca1772bc01211173710c2a
|
||||
RMD160 (sdist-1.6.tar.gz) = 4ab4fd11a6af2835fc0df8c8c83014ff8783966d
|
||||
Size (sdist-1.6.tar.gz) = 2848 bytes
|
||||
SHA1 (patch-aa) = 30e790d7a955ef77a5476015f9c4ea0e26ee27b0
|
||||
SHA1 (sdist-1.7.tar.gz) = 661e6061f23a0b93fbb3f594f320fad6a0d08795
|
||||
RMD160 (sdist-1.7.tar.gz) = ce2bc68d5db77bc724d9b4ffa42d410742b411f9
|
||||
Size (sdist-1.7.tar.gz) = 2879 bytes
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/01/05 19:38:40 christos Exp $
|
||||
|
||||
--- sdist.sh.orig 2001-03-29 17:00:37.000000000 -0500
|
||||
+++ sdist.sh 2006-01-05 14:37:14.000000000 -0500
|
||||
@@ -26,6 +26,7 @@
|
||||
OPTS=
|
||||
# default timeout for rdist -- 2 minutes instead of 15
|
||||
timeout=120
|
||||
+logopts="stdout=nerror,ferror,warning"
|
||||
|
||||
|
||||
while [ "$1" != "" ]; do
|
||||
@@ -48,6 +49,11 @@
|
||||
maxkids="$2"
|
||||
shift
|
||||
;;
|
||||
+ -l)
|
||||
+ OPTS="$OPTS $1 $2"
|
||||
+ logopts="$2"
|
||||
+ shift
|
||||
+ ;;
|
||||
-f) OPTS="$OPTS $1 $2"
|
||||
if [ "$any_servers" = "false" ]; then
|
||||
any_servers="true"
|
||||
@@ -152,7 +158,7 @@
|
||||
done
|
||||
|
||||
# Use an rdist file for multiple directories and parallel updates.
|
||||
-@RDIST@ -t $timeout -M $maxkids $rdistopts -f - << __EOF || exit $?
|
||||
+@RDIST@ -t $timeout -M $maxkids -l $logopts $rdistopts -f - << __EOF || exit $?
|
||||
($dirs) -> ($servers $allmasters)
|
||||
$extras
|
||||
install $destdir ;
|
Loading…
Reference in a new issue